aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2013-10-14 00:59:18 +0800
committerolivierd <olivierd@FreeBSD.org>2013-10-14 00:59:18 +0800
commitc8afa5f7cd1de72202bba98119e344b65857e6f6 (patch)
tree0004a4739068dc47734317546bc1f10153123886 /devel
parent60adebe132004f7e3b039a5f8148a1f5b3111eed (diff)
downloadfreebsd-ports-gnome-c8afa5f7cd1de72202bba98119e344b65857e6f6.tar.gz
freebsd-ports-gnome-c8afa5f7cd1de72202bba98119e344b65857e6f6.tar.zst
freebsd-ports-gnome-c8afa5f7cd1de72202bba98119e344b65857e6f6.zip
- Update to 0.8.1
- Add PYTHON_PY3K_PLIST_HACK macro - Replace pkg-plist by PYDISTUTILS_AUTOPLIST (maintainer) - Support STAGEDIR - Add patch, which prevents to download another release of 'distribute' not supported by ports tree PR: ports/182934 Submitted by: myself Approved by: Johannes Meixner (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/py-xmltodict/Makefile13
-rw-r--r--devel/py-xmltodict/distinfo4
-rw-r--r--devel/py-xmltodict/files/patch-setup.py21
-rw-r--r--devel/py-xmltodict/pkg-plist3
4 files changed, 27 insertions, 14 deletions
diff --git a/devel/py-xmltodict/Makefile b/devel/py-xmltodict/Makefile
index 847263d29860..7d2a570f79eb 100644
--- a/devel/py-xmltodict/Makefile
+++ b/devel/py-xmltodict/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xmltodict
-PORTVERSION= 0.7.0
+PORTVERSION= 0.8.1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,12 +14,7 @@ LICENSE= MIT
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+PYTHON_PY3K_PLIST_HACK= yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} >= 320
-.include "${PORTSDIR}/devel/py-virtualenv/files/py3k-fix-pkg-plist.inc"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/py-xmltodict/distinfo b/devel/py-xmltodict/distinfo
index 43fc2f7b0b60..5c66f8b31e2f 100644
--- a/devel/py-xmltodict/distinfo
+++ b/devel/py-xmltodict/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xmltodict-0.7.0.tar.gz) = 3868de239d2e487402eef15ab733ad8eea9c06f31422845571557b0b91f84dd7
-SIZE (xmltodict-0.7.0.tar.gz) = 12193
+SHA256 (xmltodict-0.8.1.tar.gz) = d02e6320413b9c2c5b26e21fe670cb461e2be5af384201de74cff4ea14219a63
+SIZE (xmltodict-0.8.1.tar.gz) = 30348
diff --git a/devel/py-xmltodict/files/patch-setup.py b/devel/py-xmltodict/files/patch-setup.py
new file mode 100644
index 000000000000..25ad9020c1de
--- /dev/null
+++ b/devel/py-xmltodict/files/patch-setup.py
@@ -0,0 +1,21 @@
+Use 'distribute' package provides by ports tree.
+
+--- ./setup.py.orig 2013-10-11 00:08:24.000000000 +0000
++++ ./setup.py 2013-10-12 21:59:11.000000000 +0000
+@@ -1,8 +1,6 @@
+ #!/usr/bin/env python
+-from distribute_setup import use_setuptools
+-use_setuptools()
+
+-from setuptools import setup
++from distutils.core import setup
+ import xmltodict
+
+ setup(name='xmltodict',
+@@ -30,5 +28,5 @@
+ 'Topic :: Text Processing :: Markup :: XML',
+ ],
+ py_modules=['xmltodict'],
+- setup_requires=['nose>=1.0', 'coverage'],
++ #setup_requires=['nose>=1.0', 'coverage'],
+ )
diff --git a/devel/py-xmltodict/pkg-plist b/devel/py-xmltodict/pkg-plist
deleted file mode 100644
index 458987f8d7c0..000000000000
--- a/devel/py-xmltodict/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%PYTHON_SITELIBDIR%%/xmltodict.py
-%%PYTHON_SITELIBDIR%%/xmltodict.pyc
-%%PYTHON_SITELIBDIR%%/xmltodict.pyo