aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-06 13:50:01 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-06 13:50:01 +0800
commitca740dd9787fd7f89c756e8f6d5cec026aa322bd (patch)
tree3c1b18344b1e42a324d5492566f678c2ea3b3f2a /devel
parent8a801bc778c025f8e184372a320a418b1d0fce3f (diff)
downloadfreebsd-ports-gnome-ca740dd9787fd7f89c756e8f6d5cec026aa322bd.tar.gz
freebsd-ports-gnome-ca740dd9787fd7f89c756e8f6d5cec026aa322bd.tar.zst
freebsd-ports-gnome-ca740dd9787fd7f89c756e8f6d5cec026aa322bd.zip
- Update to 0.4.0
- Add RE2C option - Pass maintainership to submitter - While I'm here: - Remove leading indefinite article from COMMENT - Remove unnecessary PHP_MODNAME and USE_PHP_BUILD - Use USES=tar:tgz Changes: http://pecl.php.net/package-changelog.php?package=SPL_Types PR: 188275 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/pecl-spl_types/Makefile17
-rw-r--r--devel/pecl-spl_types/distinfo4
-rw-r--r--devel/pecl-spl_types/files/patch-spl_type.c20
3 files changed, 11 insertions, 30 deletions
diff --git a/devel/pecl-spl_types/Makefile b/devel/pecl-spl_types/Makefile
index 486e8fffeabc..25afe67b26de 100644
--- a/devel/pecl-spl_types/Makefile
+++ b/devel/pecl-spl_types/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= spl_types
-PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTVERSION= 0.4.0
CATEGORIES= devel pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -11,17 +10,19 @@ DISTNAME= SPL_Types-${PORTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A PECL extension of a collection of special typehandling classes
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= PECL extension of a collection of special typehandling classes
LICENSE= PHP301
+OPTIONS_DEFINE= RE2C
+RE2C_DESC= Compile regular expression 2 C
+RE2C_RUN_DEPENDS= re2c:${PORTSDIR}/devel/re2c
+
USE_PHP= spl
-USE_PHP_BUILD= yes
+#USE_PHP_BUILD= yes
USE_PHPEXT= yes
-PHP_MODNAME= spl_types
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
+USES= tar:tgz
CONFIGURE_ARGS= --enable-spl-types
CFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/pecl-spl_types/distinfo b/devel/pecl-spl_types/distinfo
index 9ee1edb27da5..dee55ce545b7 100644
--- a/devel/pecl-spl_types/distinfo
+++ b/devel/pecl-spl_types/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PECL/SPL_Types-0.3.0.tgz) = 1e11b0c01a4743cf3216942412fa89e5a5e5157491a6be8f12bab8e0a7136fcd
-SIZE (PECL/SPL_Types-0.3.0.tgz) = 8100
+SHA256 (PECL/SPL_Types-0.4.0.tgz) = b44101401b2664822fd17e6f491d912203496108ff9d0b86b043bff67c5f724f
+SIZE (PECL/SPL_Types-0.4.0.tgz) = 8388
diff --git a/devel/pecl-spl_types/files/patch-spl_type.c b/devel/pecl-spl_types/files/patch-spl_type.c
deleted file mode 100644
index d5579c8f5810..000000000000
--- a/devel/pecl-spl_types/files/patch-spl_type.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./spl_type.c.orig 2010-04-12 13:52:44.000000000 -0400
-+++ ./spl_type.c 2010-04-12 13:52:53.000000000 -0400
-@@ -402,7 +402,7 @@
- return spl_type_object_new_ex(class_type, 1, NULL, spl_type_set_float TSRMLS_CC);
- }
- /* {{{ Method and class definitions */
--static ZEND_BEGIN_ARG_INFO_EX(arg_SplType___construct, 0, 0, 0)
-+ZEND_BEGIN_ARG_INFO_EX(arg_SplType___construct, 0, 0, 0)
- ZEND_ARG_INFO(0, initial_value)
- ZEND_ARG_INFO(0, strict)
- ZEND_END_ARG_INFO()
-@@ -412,7 +412,7 @@
- {NULL, NULL, NULL}
- };
-
--static ZEND_BEGIN_ARG_INFO_EX(arg_SplEnum_getConstList, 0, 0, 0)
-+ZEND_BEGIN_ARG_INFO_EX(arg_SplEnum_getConstList, 0, 0, 0)
- ZEND_ARG_INFO(0, include_default)
- ZEND_END_ARG_INFO()
-