aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-02-14 17:39:16 +0800
committersobomax <sobomax@FreeBSD.org>2002-02-14 17:39:16 +0800
commitcc4c6846a12cfbbaad264ebbe75e5963b73b3655 (patch)
treea80baf1179afffdcc5cfa4fc58b781ac45faf429 /devel
parent083bbfd304dc0b9bf9a773b682b7c147881e17a4 (diff)
downloadfreebsd-ports-gnome-cc4c6846a12cfbbaad264ebbe75e5963b73b3655.tar.gz
freebsd-ports-gnome-cc4c6846a12cfbbaad264ebbe75e5963b73b3655.tar.zst
freebsd-ports-gnome-cc4c6846a12cfbbaad264ebbe75e5963b73b3655.zip
Add libbonobo 1.110.0, a component and compound document system for GNOME2.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libbonobo/Makefile37
-rw-r--r--devel/libbonobo/distinfo1
-rw-r--r--devel/libbonobo/files/patch-Makefile.in14
-rw-r--r--devel/libbonobo/files/patch-intltool-merge.in14
-rw-r--r--devel/libbonobo/files/patch-ltmain.sh45
-rw-r--r--devel/libbonobo/pkg-comment1
-rw-r--r--devel/libbonobo/pkg-descr5
-rw-r--r--devel/libbonobo/pkg-plist127
9 files changed, 245 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8c6aa3015e8a..f0e27dfb1a77 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -230,6 +230,7 @@
SUBDIR += libafterbase
SUBDIR += libast
SUBDIR += libavl
+ SUBDIR += libbonobo
SUBDIR += libcache
SUBDIR += libcapsinetwork
SUBDIR += libcii
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
new file mode 100644
index 000000000000..3e052567ccbd
--- /dev/null
+++ b/devel/libbonobo/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: libbonobo
+# Date Created: 14 February 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbonobo
+PORTVERSION= 1.110.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= glib-1.3.13:${PORTSDIR}/devel/glib13 \
+ bonobo-activation.3:${PORTSDIR}/devel/bonobo-activation
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_BISON= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -pthread"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
+
+.include <bsd.port.mk>
diff --git a/devel/libbonobo/distinfo b/devel/libbonobo/distinfo
new file mode 100644
index 000000000000..2676b543fa6e
--- /dev/null
+++ b/devel/libbonobo/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/libbonobo-1.110.0.tar.bz2) = 4341e22e07cf7c603b8a3d2c21804af6
diff --git a/devel/libbonobo/files/patch-Makefile.in b/devel/libbonobo/files/patch-Makefile.in
new file mode 100644
index 000000000000..fd62bf9e3249
--- /dev/null
+++ b/devel/libbonobo/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.in 2002/02/14 09:30:47 1.1
++++ Makefile.in 2002/02/14 09:30:57
+@@ -122,7 +122,7 @@
+ YACC = @YACC@
+ cxxflags_set = @cxxflags_set@
+
+-SUBDIRS = idl bonobo monikers samples tests po doc
++SUBDIRS = idl bonobo monikers samples po doc
+
+ libincludedir = $(includedir)/libbonobo-2.0
+ libinclude_HEADERS = libbonobo.h
diff --git a/devel/libbonobo/files/patch-intltool-merge.in b/devel/libbonobo/files/patch-intltool-merge.in
new file mode 100644
index 000000000000..9bdb5a48384b
--- /dev/null
+++ b/devel/libbonobo/files/patch-intltool-merge.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- intltool-merge.in 2002/02/14 09:09:06 1.1
++++ intltool-merge.in 2002/02/14 09:09:15
+@@ -265,7 +265,7 @@
+
+ if ($UTF8_ARG) {
+ my $encoding = get_po_encoding ($po_file);
+- open PO_FILE, "iconv -f $encoding -t UTF-8 $po_file|";
++ open PO_FILE, "giconv -f $encoding -t UTF-8 $po_file|";
+ } else {
+ open PO_FILE, "<$po_file";
+ }
diff --git a/devel/libbonobo/files/patch-ltmain.sh b/devel/libbonobo/files/patch-ltmain.sh
new file mode 100644
index 000000000000..91713d2306f8
--- /dev/null
+++ b/devel/libbonobo/files/patch-ltmain.sh
@@ -0,0 +1,45 @@
+
+$FreeBSD$
+
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4179,10 +4190,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/libbonobo/pkg-comment b/devel/libbonobo/pkg-comment
new file mode 100644
index 000000000000..4b4fcf8bf396
--- /dev/null
+++ b/devel/libbonobo/pkg-comment
@@ -0,0 +1 @@
+A component and compound document system for GNOME2
diff --git a/devel/libbonobo/pkg-descr b/devel/libbonobo/pkg-descr
new file mode 100644
index 000000000000..19f9323f3690
--- /dev/null
+++ b/devel/libbonobo/pkg-descr
@@ -0,0 +1,5 @@
+Bonobo is a set of language and system independant CORBA interfaces
+for creating reusable components, controls and creating compound
+documents.
+
+WWW: http://www.gnome.org/
diff --git a/devel/libbonobo/pkg-plist b/devel/libbonobo/pkg-plist
new file mode 100644
index 000000000000..94a3672e895b
--- /dev/null
+++ b/devel/libbonobo/pkg-plist
@@ -0,0 +1,127 @@
+bin/echo-client-2
+include/libbonobo-2.0/bonobo/Bonobo.h
+include/libbonobo-2.0/bonobo/bonobo-arg.h
+include/libbonobo-2.0/bonobo/bonobo-context.h
+include/libbonobo-2.0/bonobo/bonobo-event-source.h
+include/libbonobo-2.0/bonobo/bonobo-exception.h
+include/libbonobo-2.0/bonobo/bonobo-generic-factory.h
+include/libbonobo-2.0/bonobo/bonobo-i18n.h
+include/libbonobo-2.0/bonobo/bonobo-item-container.h
+include/libbonobo-2.0/bonobo/bonobo-item-handler.h
+include/libbonobo-2.0/bonobo/bonobo-listener.h
+include/libbonobo-2.0/bonobo/bonobo-macros.h
+include/libbonobo-2.0/bonobo/bonobo-main.h
+include/libbonobo-2.0/bonobo/bonobo-moniker-extender.h
+include/libbonobo-2.0/bonobo/bonobo-moniker-simple.h
+include/libbonobo-2.0/bonobo/bonobo-moniker-util.h
+include/libbonobo-2.0/bonobo/bonobo-moniker.h
+include/libbonobo-2.0/bonobo/bonobo-object.h
+include/libbonobo-2.0/bonobo/bonobo-persist-client.h
+include/libbonobo-2.0/bonobo/bonobo-persist-file.h
+include/libbonobo-2.0/bonobo/bonobo-persist-stream.h
+include/libbonobo-2.0/bonobo/bonobo-persist.h
+include/libbonobo-2.0/bonobo/bonobo-property-bag-client.h
+include/libbonobo-2.0/bonobo/bonobo-property-bag.h
+include/libbonobo-2.0/bonobo/bonobo-shlib-factory.h
+include/libbonobo-2.0/bonobo/bonobo-storage-memory.h
+include/libbonobo-2.0/bonobo/bonobo-storage.h
+include/libbonobo-2.0/bonobo/bonobo-stream-client.h
+include/libbonobo-2.0/bonobo/bonobo-stream-memory.h
+include/libbonobo-2.0/bonobo/bonobo-stream.h
+include/libbonobo-2.0/bonobo/bonobo-types.h
+include/libbonobo-2.0/bonobo/bonobo-xobject.h
+include/libbonobo-2.0/libbonobo.h
+lib/bonobo-2.0/samples/bonobo-echo-2
+lib/bonobo/monikers/libmoniker_std_2.so
+lib/libbonobo-2.a
+lib/libbonobo-2.so
+lib/libbonobo-2.so.0
+lib/orbit-2.0/Bonobo_module.so
+libdata/bonobo/servers/Bonobo_Moniker_std.server
+libdata/bonobo/servers/Bonobo_Sample_Echo.server
+libdata/pkgconfig/libbonobo-2.0.pc
+share/doc/libbonobo/c4.html
+share/doc/libbonobo/index.html
+share/doc/libbonobo/index.sgml
+share/doc/libbonobo/libbonobo-bonobo-arg.html
+share/doc/libbonobo/libbonobo-bonobo-config-database.html
+share/doc/libbonobo/libbonobo-bonobo-context.html
+share/doc/libbonobo/libbonobo-bonobo-event-source.html
+share/doc/libbonobo/libbonobo-bonobo-exception.html
+share/doc/libbonobo/libbonobo-bonobo-generic-factory.html
+share/doc/libbonobo/libbonobo-bonobo-i18n.html
+share/doc/libbonobo/libbonobo-bonobo-item-container.html
+share/doc/libbonobo/libbonobo-bonobo-item-handler.html
+share/doc/libbonobo/libbonobo-bonobo-listener.html
+share/doc/libbonobo/libbonobo-bonobo-macros.html
+share/doc/libbonobo/libbonobo-bonobo-main.html
+share/doc/libbonobo/libbonobo-bonobo-moniker-context.html
+share/doc/libbonobo/libbonobo-bonobo-moniker-extender.html
+share/doc/libbonobo/libbonobo-bonobo-moniker-simple.html
+share/doc/libbonobo/libbonobo-bonobo-moniker-util.html
+share/doc/libbonobo/libbonobo-bonobo-moniker.html
+share/doc/libbonobo/libbonobo-bonobo-object.html
+share/doc/libbonobo/libbonobo-bonobo-persist-client.html
+share/doc/libbonobo/libbonobo-bonobo-persist-file.html
+share/doc/libbonobo/libbonobo-bonobo-persist-stream.html
+share/doc/libbonobo/libbonobo-bonobo-persist.html
+share/doc/libbonobo/libbonobo-bonobo-property-bag-client.html
+share/doc/libbonobo/libbonobo-bonobo-property-bag.html
+share/doc/libbonobo/libbonobo-bonobo-running-context.html
+share/doc/libbonobo/libbonobo-bonobo-shlib-factory.html
+share/doc/libbonobo/libbonobo-bonobo-shutdown.html
+share/doc/libbonobo/libbonobo-bonobo-storage-memory.html
+share/doc/libbonobo/libbonobo-bonobo-storage.html
+share/doc/libbonobo/libbonobo-bonobo-stream-client.html
+share/doc/libbonobo/libbonobo-bonobo-stream-memory.html
+share/doc/libbonobo/libbonobo-bonobo-transient.html
+share/doc/libbonobo/libbonobo-bonobo-types.html
+share/doc/libbonobo/libbonobo-bonobo-xobject.html
+share/idl/bonobo-2.0/Bonobo.idl
+share/idl/bonobo-2.0/Bonobo_Canvas.idl
+share/idl/bonobo-2.0/Bonobo_Clipboard.idl
+share/idl/bonobo-2.0/Bonobo_Context.idl
+share/idl/bonobo-2.0/Bonobo_Control.idl
+share/idl/bonobo-2.0/Bonobo_Embeddable.idl
+share/idl/bonobo-2.0/Bonobo_Exception.idl
+share/idl/bonobo-2.0/Bonobo_Gdk.idl
+share/idl/bonobo-2.0/Bonobo_ItemContainer.idl
+share/idl/bonobo-2.0/Bonobo_Listener.idl
+share/idl/bonobo-2.0/Bonobo_Moniker.idl
+share/idl/bonobo-2.0/Bonobo_Persist.idl
+share/idl/bonobo-2.0/Bonobo_Print.idl
+share/idl/bonobo-2.0/Bonobo_Property.idl
+share/idl/bonobo-2.0/Bonobo_Sample_Echo.idl
+share/idl/bonobo-2.0/Bonobo_Storage.idl
+share/idl/bonobo-2.0/Bonobo_UI.idl
+share/idl/bonobo-2.0/Bonobo_Zoomable.idl
+share/locale/az/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/bg/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/ca/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/es/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/fr/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/gl/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/hu/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/it/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/ja/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/ms/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/nn/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/no/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/pt/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/ru/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/sk/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/sv/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/ta/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/uk/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/zh_CN/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/zh_TW/LC_MESSAGES/libbonobo-2.0.mo
+@dirrm share/idl/bonobo-2.0
+@dirrm share/doc/libbonobo
+@dirrm lib/orbit-2.0
+@dirrm lib/bonobo/monikers
+@dirrm lib/bonobo-2.0/samples
+@dirrm lib/bonobo-2.0
+@dirrm lib/bonobo
+@dirrm include/libbonobo-2.0/bonobo
+@dirrm include/libbonobo-2.0