aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-07-14 23:21:44 +0800
committertcberner <tcberner@FreeBSD.org>2017-07-14 23:21:44 +0800
commitccc6e8280cccec5fa3041e9e17276311f81f3dfb (patch)
tree7bc75836b4259027beb5c71aeee6725f00300d27 /devel
parent478893951e96623083c2333b4a3fdc1e737ccf92 (diff)
downloadfreebsd-ports-gnome-ccc6e8280cccec5fa3041e9e17276311f81f3dfb.tar.gz
freebsd-ports-gnome-ccc6e8280cccec5fa3041e9e17276311f81f3dfb.tar.zst
freebsd-ports-gnome-ccc6e8280cccec5fa3041e9e17276311f81f3dfb.zip
Fix build on armv6.
This uses the parts added in r442475. PR: 217425 Submitted by: Mikaƫl Urankar <mikael.urankar@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/py-pykde4/files/patch-CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/py-pykde4/files/patch-CMakeLists.txt b/devel/py-pykde4/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1b3ccdc67277
--- /dev/null
+++ b/devel/py-pykde4/files/patch-CMakeLists.txt
@@ -0,0 +1,21 @@
+--- CMakeLists.txt.orig 2014-08-14 22:17:11 UTC
++++ CMakeLists.txt
+@@ -99,6 +99,9 @@ include_directories(
+ ${KDEPIMLIBS_INCLUDE_DIRS}
+ )
+
++# Pull in ARM configuration options if needed
++STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "")
++
+ set(SIP_INCLUDES ${CMAKE_BINARY_DIR} ${PYQT4_SIP_DIR} sip)
+ set(SIP_CONCAT_PARTS 8)
+ if (WIN32)
+@@ -106,7 +109,7 @@ if (WIN32)
+ else ()
+ set(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG})
+ endif ()
+-set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
++set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK})
+
+ set(SIP_FILES_INSTALL_DIR ${SHARE_INSTALL_PREFIX}/sip)
+