aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2009-02-27 18:24:48 +0800
committerjadawin <jadawin@FreeBSD.org>2009-02-27 18:24:48 +0800
commitcf69e454b9c8ed3a629a9ab9f55ebd89f9f70e5e (patch)
tree3f2eb1861b79a8300c5b2329424e6ecf5a82ad17 /devel
parent14eb74ead1d741bc32063c0283887d3d8a4539b8 (diff)
downloadfreebsd-ports-gnome-cf69e454b9c8ed3a629a9ab9f55ebd89f9f70e5e.tar.gz
freebsd-ports-gnome-cf69e454b9c8ed3a629a9ab9f55ebd89f9f70e5e.tar.zst
freebsd-ports-gnome-cf69e454b9c8ed3a629a9ab9f55ebd89f9f70e5e.zip
Pytemplate is a small project intending to give python developpers a starting
framework. It permits to create properly scripts without struggling with configuration files, logging properties development. They are already available through a main class that the new script will inherit. WWW: http://bulot.org/wiki/doku.php?id=projects:python:pytemplate PR: ports/132121 Submitted by: Benoit Calvez <benoit at litchis.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytemplate/Makefile34
-rw-r--r--devel/py-pytemplate/distinfo3
-rw-r--r--devel/py-pytemplate/pkg-descr6
-rw-r--r--devel/py-pytemplate/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a821144296cf..455a15cfb4f5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2298,6 +2298,7 @@
SUBDIR += py-pymarc
SUBDIR += py-pyro
SUBDIR += py-pyshapelib
+ SUBDIR += py-pytemplate
SUBDIR += py-pytz
SUBDIR += py-pyutil
SUBDIR += py-qt4-assistant
diff --git a/devel/py-pytemplate/Makefile b/devel/py-pytemplate/Makefile
new file mode 100644
index 000000000000..48e98ab94e59
--- /dev/null
+++ b/devel/py-pytemplate/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pytemplate
+# Date created: 2009-02-24
+# Whom: Benoit Calvez <benoit@litchis.org>
+#
+# $FreeBSD$
+
+PORTNAME= pytemplate
+PORTVERSION= 1.5.1
+CATEGORIES= devel python
+MASTER_SITES= http://www.bulot.org/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= benoit@litchis.org
+COMMENT= Pytemplate gives python developpers a starting framework
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+EXAMPLESDIR= ${PREFIX}/share/examples/py-pytemplate
+
+EXAMPLES= daemonexample.py example.py threadexample.py
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for f in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytemplate/distinfo b/devel/py-pytemplate/distinfo
new file mode 100644
index 000000000000..5fd1cb80a126
--- /dev/null
+++ b/devel/py-pytemplate/distinfo
@@ -0,0 +1,3 @@
+MD5 (pytemplate-1.5.1.tar.gz) = 61190e02d87e95f78a3d115ea191e6ae
+SHA256 (pytemplate-1.5.1.tar.gz) = fc43424db195b667a85bae132bf66e67c416f327c1a6c2c0aa66f9a9345a9bc5
+SIZE (pytemplate-1.5.1.tar.gz) = 17926
diff --git a/devel/py-pytemplate/pkg-descr b/devel/py-pytemplate/pkg-descr
new file mode 100644
index 000000000000..b51cd33cddc5
--- /dev/null
+++ b/devel/py-pytemplate/pkg-descr
@@ -0,0 +1,6 @@
+Pytemplate is a small project intending to give python developpers a starting
+framework. It permits to create properly scripts without struggling with
+configuration files, logging properties development. They are already available
+through a main class that the new script will inherit.
+
+WWW: http://bulot.org/wiki/doku.php?id=projects:python:pytemplate
diff --git a/devel/py-pytemplate/pkg-plist b/devel/py-pytemplate/pkg-plist
new file mode 100644
index 000000000000..8f3dd9f53737
--- /dev/null
+++ b/devel/py-pytemplate/pkg-plist
@@ -0,0 +1,7 @@
+%%PYTHON_SITELIBDIR%%/pytemplate.py
+%%PYTHON_SITELIBDIR%%/pytemplate.pyc
+%%PYTHON_SITELIBDIR%%/pytemplate.pyo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/daemonexample.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/threadexample.py
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%