aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2014-11-03 21:07:17 +0800
committermartymac <martymac@FreeBSD.org>2014-11-03 21:07:17 +0800
commitd097a9a7a4ecc953a5ac5f0f1fb6570e90e34639 (patch)
tree27000af1220f5a5eca078b504533d9aa9c2f8a0b /devel
parentf9c54edf39180c45797ef40dacf496c695b7ea8e (diff)
downloadfreebsd-ports-gnome-d097a9a7a4ecc953a5ac5f0f1fb6570e90e34639.tar.gz
freebsd-ports-gnome-d097a9a7a4ecc953a5ac5f0f1fb6570e90e34639.tar.zst
freebsd-ports-gnome-d097a9a7a4ecc953a5ac5f0f1fb6570e90e34639.zip
Update Simgear and Flightgear ports to 3.2.0
PR: 194571 Submitted by: mike.d.ft402@gmail.com
Diffstat (limited to 'devel')
-rw-r--r--devel/simgear/Makefile15
-rw-r--r--devel/simgear/distinfo4
-rw-r--r--devel/simgear/files/patch-CMakeLists.txt57
-rw-r--r--devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h18
-rw-r--r--devel/simgear/files/patch-simgear-debug-BufferedLogCallback.cxx11
-rw-r--r--devel/simgear/files/patch-simgear-timing-timestamp.cxx20
-rw-r--r--devel/simgear/pkg-plist16
7 files changed, 61 insertions, 80 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 1872ddfe36ce..44dec14bd6ff 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= simgear
-PORTVERSION= 3.0.0
-PORTREVISION= 2
+PORTVERSION= 3.2.0
CATEGORIES= devel games
MASTER_SITES= http://mirrors.ibiblio.org/simgear/ftp/Source/ \
ftp://ftp.de.flightgear.org/pub/simgear/Source/ \
@@ -22,7 +21,13 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
-USES= tar:bzip2 cmake openal:al,alut
-CMAKE_ARGS+= -DJPEG_FACTORY:BOOL=ON
+USES= tar:bzip2 cmake compiler openal:al,alut
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# When building with Gcc, needs Gcc 4.6+
+.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} < 46
+USE_GCC= 4.6+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/simgear/distinfo b/devel/simgear/distinfo
index d4e117b909c1..20c9f5c9f01b 100644
--- a/devel/simgear/distinfo
+++ b/devel/simgear/distinfo
@@ -1,2 +1,2 @@
-SHA256 (simgear-3.0.0.tar.bz2) = 09448f87e6c2b5b6101a5a4eac331c1e1b998d61ec2e59614449110de2e68016
-SIZE (simgear-3.0.0.tar.bz2) = 969971
+SHA256 (simgear-3.2.0.tar.bz2) = b456cdc63b37d609bc24b347d43dc275eb7d06f5d92b18aeb0e66eedd3819c86
+SIZE (simgear-3.2.0.tar.bz2) = 1020432
diff --git a/devel/simgear/files/patch-CMakeLists.txt b/devel/simgear/files/patch-CMakeLists.txt
index f5612ac461b5..b07596c161eb 100644
--- a/devel/simgear/files/patch-CMakeLists.txt
+++ b/devel/simgear/files/patch-CMakeLists.txt
@@ -1,44 +1,17 @@
---- CMakeLists.txt.orig 2014-02-15 01:04:11.000000000 +0100
-+++ CMakeLists.txt 2014-03-10 18:06:13.000000000 +0100
-@@ -259,18 +259,20 @@
- endif(HAVE_CLOCK_GETTIME)
+--- CMakeLists.txt.orig 2014-10-21 07:26:42.608036396 +0200
++++ CMakeLists.txt 2014-10-21 07:27:18.571673862 +0200
+@@ -276,12 +276,12 @@
+ # isnan might not be real symbol, so can't check using function_exists
+ check_cxx_source_compiles(
+ "#include <cmath>
+- void f() { isnan(0.0);} "
++ int main() { return isnan(0.0);} "
+ HAVE_ISNAN)
- set(DL_LIBRARY "")
--check_cxx_source_compiles(
-- "#include <dlfcn.h>
-- int main(void) {
-- return 0;
-- }
-- "
-- HAVE_DLFCN_H)
--
--if(HAVE_DLFCN_H)
-- check_library_exists(dl dlerror "" HAVE_DL)
-- set(DL_LIBRARY "dl")
--endif()
-+if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
-+ check_cxx_source_compiles(
-+ "#include <dlfcn.h>
-+ int main(void) {
-+ return 0;
-+ }
-+ "
-+ HAVE_DLFCN_H)
-+
-+ if(HAVE_DLFCN_H)
-+ check_library_exists(dl dlerror "" HAVE_DL)
-+ set(DL_LIBRARY "dl")
-+ endif()
-+endif (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
-
- SET(CMAKE_DEBUG_POSTFIX "d" CACHE STRING "add a postfix, usually 'd' on windows")
- SET(CMAKE_RELEASE_POSTFIX "" CACHE STRING "add a postfix, usually empty on windows")
-@@ -342,7 +344,7 @@
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${WARNING_FLAGS_CXX} ${MSVC_FLAGS} ${BOOST_CXX_FLAGS}")
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} ${MSVC_LD_FLAGS}")
-
--include_directories(${PROJECT_SOURCE_DIR})
-+include_directories(BEFORE ${PROJECT_SOURCE_DIR})
- include_directories(${PROJECT_SOURCE_DIR}/simgear/canvas/ShivaVG/include)
- include_directories(${PROJECT_BINARY_DIR}/simgear)
+ check_cxx_source_compiles(
+ "#include <cmath>
+- void f() { std::isnan(0.0);} "
++ int main() { return std::isnan(0.0);} "
+ HAVE_STD_ISNAN)
+ if(CMAKE_COMPILER_IS_GNUCXX)
diff --git a/devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h b/devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h
index 58c1c4bd4af4..71b638290e75 100644
--- a/devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h
+++ b/devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h
@@ -1,11 +1,11 @@
---- simgear/canvas/ShivaVG/src/shDefs.h.orig 2013-02-20 17:17:38.000000000 +0100
-+++ simgear/canvas/ShivaVG/src/shDefs.h 2013-02-20 17:18:16.000000000 +0100
-@@ -34,7 +34,7 @@
- #include <math.h>
- #include <float.h>
+--- simgear/canvas/ShivaVG/src/shDefs.h.orig 2014-10-28 09:45:41.492715364 +0100
++++ simgear/canvas/ShivaVG/src/shDefs.h 2014-10-28 09:54:06.791735417 +0100
+@@ -156,7 +156,7 @@
--#ifndef VG_API_MACOSX
-+#if !defined(VG_API_MACOSX) && !defined(__FreeBSD__)
- # include <malloc.h>
- #endif
+ /* OpenGL headers */
+-#if defined(VG_API_LINUX)
++#if defined(VG_API_LINUX) || defined(VG_API_FREEBSD)
+ #include <GL/gl.h>
+ #include <GL/glx.h>
+ #elif defined(VG_API_MACOSX)
diff --git a/devel/simgear/files/patch-simgear-debug-BufferedLogCallback.cxx b/devel/simgear/files/patch-simgear-debug-BufferedLogCallback.cxx
new file mode 100644
index 000000000000..90badfd7c093
--- /dev/null
+++ b/devel/simgear/files/patch-simgear-debug-BufferedLogCallback.cxx
@@ -0,0 +1,11 @@
+--- simgear/debug/BufferedLogCallback.cxx.orig 2014-10-27 09:26:46.499707738 +0100
++++ simgear/debug/BufferedLogCallback.cxx 2014-10-27 09:27:54.034557089 +0100
+@@ -26,6 +26,8 @@
+ #include <simgear/sg_inlines.h>
+ #include <simgear/threads/SGThread.hxx>
+ #include <simgear/threads/SGGuard.hxx>
++
++#include <cstdlib> // for malloc
+
+ namespace simgear
+ {
diff --git a/devel/simgear/files/patch-simgear-timing-timestamp.cxx b/devel/simgear/files/patch-simgear-timing-timestamp.cxx
deleted file mode 100644
index a896dd0f02e4..000000000000
--- a/devel/simgear/files/patch-simgear-timing-timestamp.cxx
+++ /dev/null
@@ -1,20 +0,0 @@
---- simgear/timing/timestamp.cxx.orig 2012-03-09 10:37:52.770699568 +0100
-+++ simgear/timing/timestamp.cxx 2012-03-09 10:38:40.266717310 +0100
-@@ -139,7 +139,7 @@
- // the timer tick) accuracy which is too bad to catch 60Hz...
- bool SGTimeStamp::sleepUntil(const SGTimeStamp& abstime)
- {
--#if defined(_POSIX_TIMERS) && (0 < _POSIX_TIMERS)
-+#if defined(_POSIX_TIMERS) && (0 < _POSIX_TIMERS) && !defined(__FreeBSD__)
- SGTimeStamp abstimeForSleep = abstime;
-
- // Always undersleep by resolution of the clock
-@@ -234,7 +234,7 @@
-
- bool SGTimeStamp::sleepFor(const SGTimeStamp& reltime)
- {
--#if defined(_POSIX_TIMERS) && (0 < _POSIX_TIMERS)
-+#if defined(_POSIX_TIMERS) && (0 < _POSIX_TIMERS) && !defined(__FreeBSD__)
- struct timespec ts;
- ts.tv_sec = reltime._sec;
- ts.tv_nsec = reltime._nsec;
diff --git a/devel/simgear/pkg-plist b/devel/simgear/pkg-plist
index aaed851f262b..608d0e3df43f 100644
--- a/devel/simgear/pkg-plist
+++ b/devel/simgear/pkg-plist
@@ -29,7 +29,7 @@ include/simgear/canvas/CanvasMgr.hxx
include/simgear/canvas/CanvasObjectPlacement.hxx
include/simgear/canvas/CanvasPlacement.hxx
include/simgear/canvas/CanvasSystemAdapter.hxx
-include/simgear/canvas/MouseEvent.hxx
+include/simgear/canvas/CanvasWindow.hxx
include/simgear/canvas/ODGauge.hxx
include/simgear/canvas/ShivaVG/openvg.h
include/simgear/canvas/ShivaVG/vgu.h
@@ -42,6 +42,13 @@ include/simgear/canvas/elements/CanvasMap.hxx
include/simgear/canvas/elements/CanvasPath.hxx
include/simgear/canvas/elements/CanvasText.hxx
include/simgear/canvas/elements/detail/add_segment_variadic.hxx
+include/simgear/canvas/events/CustomEvent.hxx
+include/simgear/canvas/events/MouseEvent.hxx
+include/simgear/canvas/layout/BoxLayout.hxx
+include/simgear/canvas/layout/Layout.hxx
+include/simgear/canvas/layout/LayoutItem.hxx
+include/simgear/canvas/layout/NasalWidget.hxx
+include/simgear/canvas/layout/SpacerItem.hxx
include/simgear/compiler.h
include/simgear/constants.h
include/simgear/debug/BufferedLogCallback.hxx
@@ -117,6 +124,8 @@ include/simgear/math/sg_types.hxx
include/simgear/misc/CSSBorder.hxx
include/simgear/misc/ListDiff.hxx
include/simgear/misc/ResourceManager.hxx
+include/simgear/misc/SVGpreserveAspectRatio.hxx
+include/simgear/misc/SimpleMarkdown.hxx
include/simgear/misc/gzcontainerfile.hxx
include/simgear/misc/interpolator.hxx
include/simgear/misc/make_new.hxx
@@ -131,7 +140,9 @@ include/simgear/misc/texcoord.hxx
include/simgear/misc/zfstream.hxx
include/simgear/nasal/cppbind/Ghost.hxx
include/simgear/nasal/cppbind/NasalCallContext.hxx
+include/simgear/nasal/cppbind/NasalContext.hxx
include/simgear/nasal/cppbind/NasalHash.hxx
+include/simgear/nasal/cppbind/NasalObject.hxx
include/simgear/nasal/cppbind/NasalObjectHolder.hxx
include/simgear/nasal/cppbind/NasalString.hxx
include/simgear/nasal/cppbind/detail/from_nasal_function_templates.hxx
@@ -258,7 +269,6 @@ include/simgear/scene/util/parse_color.hxx
include/simgear/scene/util/project.hxx
include/simgear/screen/colors.hxx
include/simgear/screen/extensions.hxx
-include/simgear/screen/jpgfactory.hxx
include/simgear/screen/screen-dump.hxx
include/simgear/screen/tr.h
include/simgear/serial/serial.hxx
@@ -287,8 +297,10 @@ include/simgear/structure/StateMachine.hxx
include/simgear/structure/StringTable.hxx
include/simgear/structure/callback.hxx
include/simgear/structure/commands.hxx
+include/simgear/structure/detail/function_list_template.hxx
include/simgear/structure/event_mgr.hxx
include/simgear/structure/exception.hxx
+include/simgear/structure/function_list.hxx
include/simgear/structure/intern.hxx
include/simgear/structure/map.hxx
include/simgear/structure/singleton.hpp