aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-28 02:30:29 +0800
committerantoine <antoine@FreeBSD.org>2014-09-28 02:30:29 +0800
commitda29c3e72538f818f9507b5a950391fa5caa027a (patch)
tree4f0de34ec7ac9ffe9b187c2104e01de13d1c7b3b /devel
parent5b53f401d6bd72d85259f069f8dd746cabfcb689 (diff)
downloadfreebsd-ports-gnome-da29c3e72538f818f9507b5a950391fa5caa027a.tar.gz
freebsd-ports-gnome-da29c3e72538f818f9507b5a950391fa5caa027a.tar.zst
freebsd-ports-gnome-da29c3e72538f818f9507b5a950391fa5caa027a.zip
- Remove bogus IGNORE
- Allow staging as a regular user
Diffstat (limited to 'devel')
-rw-r--r--devel/linux_kdump/Makefile5
-rw-r--r--devel/linux_kdump/files/patch-Makefile9
2 files changed, 5 insertions, 9 deletions
diff --git a/devel/linux_kdump/Makefile b/devel/linux_kdump/Makefile
index 3f2b79b34284..9a4d3a9dbb16 100644
--- a/devel/linux_kdump/Makefile
+++ b/devel/linux_kdump/Makefile
@@ -13,11 +13,11 @@ COMMENT= Linux-compatibility ktrace.out processor
BUILD_DEPENDS= ${RUN_DEPENDS} # USE_LINUX_APPS only sets RUN_DEPENDS
+USES= uidfix
USE_LINUX= yes
USE_LINUX_APPS= devtools
ONLY_FOR_ARCHS= i386 amd64
-NO_MANCOMPRESS= yes
PLIST_FILES= bin/linux_kdump man/man1/linux_kdump.1.gz
.include <bsd.port.pre.mk>
@@ -32,8 +32,5 @@ IGNORE= requires kernel source present in ${SRC_BASE}/sys
.if !exists(${SRC_BASE}/usr.bin/ktrace/subr.c)
IGNORE= requires ktrace source present in ${SRC_BASE}/usr.bin/ktrace
.endif
-.if ! (exists(${LINUXBASE}/etc/fedora-release) || exists(${LINUXBASE}/etc/centos-release))
-IGNORE= does not build without a linux base, use the package instead
-.endif
.include <bsd.port.post.mk>
diff --git a/devel/linux_kdump/files/patch-Makefile b/devel/linux_kdump/files/patch-Makefile
index a1f7ded56f69..a75bcb1d3d3b 100644
--- a/devel/linux_kdump/files/patch-Makefile
+++ b/devel/linux_kdump/files/patch-Makefile
@@ -1,6 +1,6 @@
---- ./Makefile.orig 2004-02-14 09:05:13.000000000 +0200
-+++ ./Makefile 2014-03-28 08:43:01.000000000 +0200
-@@ -2,14 +2,19 @@
+--- Makefile.orig 2004-02-14 07:05:13 UTC
++++ Makefile
+@@ -2,14 +2,18 @@
PROG= linux_kdump
SRCS= kdump.c linux_ioctl.c subr.c syscallnames.c
@@ -13,7 +13,6 @@
-BINDIR= /bin
-DESTDIR=${PREFIX}
-MANDIR= /man/man
-+DESTDIR?=${STAGEDIR}${PREFIX}
+BINDIR= ${PREFIX}/bin
+MANDIR= ${PREFIX}/man/man
SRCDIR?=/usr/src
@@ -24,7 +23,7 @@
.PATH: ${SRCDIR}/usr.bin/ktrace
default: depend all
-@@ -23,4 +28,9 @@
+@@ -23,4 +27,9 @@
linux_ioctl.c: mkioctls.linux
/bin/sh ${.CURDIR}/mkioctls.linux