aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-11-29 23:14:08 +0800
committerkoobs <koobs@FreeBSD.org>2013-11-29 23:14:08 +0800
commitdb76d915648929b44f9714e016a06e80b9a6ad36 (patch)
treec781c6d68148f20e9c9dee923d993fb221fc8079 /devel
parent0d9e12fd11e2105439d7dc3f67ae79e2c714bba4 (diff)
downloadfreebsd-ports-gnome-db76d915648929b44f9714e016a06e80b9a6ad36.tar.gz
freebsd-ports-gnome-db76d915648929b44f9714e016a06e80b9a6ad36.tar.zst
freebsd-ports-gnome-db76d915648929b44f9714e016a06e80b9a6ad36.zip
devel/yasm-devel: Copy devel/yasm and update to 1.2.0.29 [NEW PORT]
- Update to 1.2.0.29 (g87c0) - Enable STAGE support - Update pkg-plist - Adjust MASTER_SITES and MASTER_SITE_SUBDIR to suit snapshots - Add -devel PKGNAMESUFFIX - Remove indefinite article from and update COMMENT for uniqueness - Update MAINTAINER - Add NLS and DEBUG options - Remove custom INSTALL_TARGET - Remove MAN* macros - Add regression-test: target - Update pkg-descr
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/yasm-devel/Makefile44
-rw-r--r--devel/yasm-devel/distinfo2
-rw-r--r--devel/yasm-devel/pkg-descr8
-rw-r--r--devel/yasm-devel/pkg-plist39
5 files changed, 94 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 91427c0c51e4..15ad0f3f7e5b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4527,6 +4527,7 @@
SUBDIR += yajl-tcl
SUBDIR += yaml-cpp
SUBDIR += yasm
+ SUBDIR += yasm-devel
SUBDIR += z80-asm
SUBDIR += z80asm
SUBDIR += z80ex
diff --git a/devel/yasm-devel/Makefile b/devel/yasm-devel/Makefile
new file mode 100644
index 000000000000..f633ec8f8297
--- /dev/null
+++ b/devel/yasm-devel/Makefile
@@ -0,0 +1,44 @@
+# Created by: ijliao
+# $FreeBSD$
+
+PORTNAME= yasm
+PORTVERSION= 1.2.0.29
+DISTVERSIONSUFFIX= .g87c0
+CATEGORIES= devel lang
+MASTER_SITES= http://www.tortall.net/projects/yasm/snapshots/%SUBDIR%/
+MASTER_SITE_SUBDIR= v${DISTVERSION}${DISTVERSIONSUFFIX}
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Complete rewrite of the NASM assembler (Development Snapshot)
+
+LICENSE= BSD
+
+OPTIONS_DEFINE= DEBUG NLS
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --disable-python --disable-python-bindings
+
+NLS_USES= gettext iconv
+NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_ON= --with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_OFF= --without-libiconv-prefix \
+ --without-libintl-prefix
+
+CONFLICTS_INSTALL= yasm-[0-9]*
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG} || defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if ${ARCH} == "ia64"
+CFLAGS:= ${CFLAGS:C/-O[0-9]//g}
+.endif
+
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} check
+
+.include <bsd.port.mk>
diff --git a/devel/yasm-devel/distinfo b/devel/yasm-devel/distinfo
new file mode 100644
index 000000000000..faafe666284a
--- /dev/null
+++ b/devel/yasm-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (yasm-1.2.0.29.g87c0.tar.gz) = 1d73e87cfc58ef89fd2bb63c680bdb32c6b99f07159744722f5e9dd00b9b876f
+SIZE (yasm-1.2.0.29.g87c0.tar.gz) = 1428812
diff --git a/devel/yasm-devel/pkg-descr b/devel/yasm-devel/pkg-descr
new file mode 100644
index 000000000000..c37a780ded0b
--- /dev/null
+++ b/devel/yasm-devel/pkg-descr
@@ -0,0 +1,8 @@
+YASM is a complete rewrite of the NASM assembler under the "new" BSD License.
+
+Yasm currently supports the x86 and AMD64 instruction sets, accepts
+NASM and GAS assembler syntaxes, outputs binary, ELF32, ELF64, COFF, Mach-O
+(32 and 64), RDOFF2, Win32, and Win64 object formats, and generates source
+debugging information in STABS, DWARF 2, and CodeView 8 formats.
+
+WWW: http://www.tortall.net/projects/yasm/
diff --git a/devel/yasm-devel/pkg-plist b/devel/yasm-devel/pkg-plist
new file mode 100644
index 000000000000..e7762ceb239a
--- /dev/null
+++ b/devel/yasm-devel/pkg-plist
@@ -0,0 +1,39 @@
+bin/yasm
+bin/ytasm
+bin/vsyasm
+include/libyasm.h
+include/libyasm-stdint.h
+include/libyasm/arch.h
+include/libyasm/assocdat.h
+include/libyasm/bitvect.h
+include/libyasm/bytecode.h
+include/libyasm/compat-queue.h
+include/libyasm/coretype.h
+include/libyasm/dbgfmt.h
+include/libyasm/errwarn.h
+include/libyasm/expr.h
+include/libyasm/file.h
+include/libyasm/floatnum.h
+include/libyasm/hamt.h
+include/libyasm/insn.h
+include/libyasm/intnum.h
+include/libyasm/inttree.h
+include/libyasm/linemap.h
+include/libyasm/listfmt.h
+include/libyasm/md5.h
+include/libyasm/module.h
+include/libyasm/objfmt.h
+include/libyasm/parser.h
+include/libyasm/phash.h
+include/libyasm/preproc.h
+include/libyasm/section.h
+include/libyasm/symrec.h
+include/libyasm/valparam.h
+include/libyasm/value.h
+lib/libyasm.a
+man/man1/yasm.1.gz
+man/man7/yasm_arch.7.gz
+man/man7/yasm_dbgfmts.7.gz
+man/man7/yasm_objfmts.7.gz
+man/man7/yasm_parsers.7.gz
+@dirrm include/libyasm