aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlbr <lbr@FreeBSD.org>2008-07-28 08:55:02 +0800
committerlbr <lbr@FreeBSD.org>2008-07-28 08:55:02 +0800
commitdd02ef3c0fed26f0df6fb91088f48d8664da25dd (patch)
tree75be7bc13da2e0938015d5bbcd17852a8d03a0e5 /devel
parent69337eb52ef826fa66bc7499182ca9d1794e0dcd (diff)
downloadfreebsd-ports-gnome-dd02ef3c0fed26f0df6fb91088f48d8664da25dd.tar.gz
freebsd-ports-gnome-dd02ef3c0fed26f0df6fb91088f48d8664da25dd.tar.zst
freebsd-ports-gnome-dd02ef3c0fed26f0df6fb91088f48d8664da25dd.zip
New port: devel/p5-MooseX-Daemonize, Role for daemonizing your Moose based application
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MooseX-Daemonize/Makefile31
-rw-r--r--devel/p5-MooseX-Daemonize/distinfo3
-rw-r--r--devel/p5-MooseX-Daemonize/pkg-descr5
-rw-r--r--devel/p5-MooseX-Daemonize/pkg-plist14
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1947a9ec10aa..daa4f0afbf5a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1472,6 +1472,7 @@
SUBDIR += p5-MooseX-Async
SUBDIR += p5-MooseX-AttributeHelpers
SUBDIR += p5-MooseX-ClassAttribute
+ SUBDIR += p5-MooseX-Daemonize
SUBDIR += p5-MooseX-Getopt
SUBDIR += p5-MooseX-IOC
SUBDIR += p5-MooseX-POE
diff --git a/devel/p5-MooseX-Daemonize/Makefile b/devel/p5-MooseX-Daemonize/Makefile
new file mode 100644
index 000000000000..f0ba07a03726
--- /dev/null
+++ b/devel/p5-MooseX-Daemonize/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-MooseX-Daemonize
+# Date created: 28 Jul 2008
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-Daemonize
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Role for daemonizing your Moose based application
+
+RUN_DEPENDS= p5-Moose>=0.33:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Getopt>=0.07:${PORTSDIR}/devel/p5-MooseX-Getopt \
+ p5-MooseX-Types-Path-Class>=0:${PORTSDIR}/devel/p5-MooseX-Types-Path-Class
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= MooseX::Daemonize.3 \
+ MooseX::Daemonize::Core.3 \
+ MooseX::Daemonize::Pid.3 \
+ MooseX::Daemonize::Pid::File.3 \
+ MooseX::Daemonize::WithPidFile.3 \
+ Test::MooseX::Daemonize.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-Daemonize/distinfo b/devel/p5-MooseX-Daemonize/distinfo
new file mode 100644
index 000000000000..a70cdd42a502
--- /dev/null
+++ b/devel/p5-MooseX-Daemonize/distinfo
@@ -0,0 +1,3 @@
+MD5 (MooseX-Daemonize-0.07.tar.gz) = 68e61b2a762baa4d0a44a499a7586524
+SHA256 (MooseX-Daemonize-0.07.tar.gz) = 2d43fa15bfab50ae6560e7fde4b123de8d96ffbddbc3506accf1ac05d036e873
+SIZE (MooseX-Daemonize-0.07.tar.gz) = 32430
diff --git a/devel/p5-MooseX-Daemonize/pkg-descr b/devel/p5-MooseX-Daemonize/pkg-descr
new file mode 100644
index 000000000000..02826e969d87
--- /dev/null
+++ b/devel/p5-MooseX-Daemonize/pkg-descr
@@ -0,0 +1,5 @@
+Often you want to write a persistant daemon that has a pid file, and responds
+appropriately to Signals. This module provides a set of basic roles as an
+infrastructure to do that.
+
+WWW: http://search.cpan.org/dist/MooseX-Daemonize/
diff --git a/devel/p5-MooseX-Daemonize/pkg-plist b/devel/p5-MooseX-Daemonize/pkg-plist
new file mode 100644
index 000000000000..3dd0dff2cf08
--- /dev/null
+++ b/devel/p5-MooseX-Daemonize/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/MooseX/Daemonize.pm
+%%SITE_PERL%%/MooseX/Daemonize/Core.pm
+%%SITE_PERL%%/MooseX/Daemonize/Pid.pm
+%%SITE_PERL%%/MooseX/Daemonize/Pid/File.pm
+%%SITE_PERL%%/MooseX/Daemonize/WithPidFile.pm
+%%SITE_PERL%%/Test/MooseX/Daemonize.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Daemonize/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/Daemonize
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX
+@dirrmtry %%SITE_PERL%%/MooseX/Daemonize/Pid
+@dirrmtry %%SITE_PERL%%/MooseX/Daemonize
+@dirrmtry %%SITE_PERL%%/MooseX
+@dirrmtry %%SITE_PERL%%/Test/MooseX
+@dirrmtry %%SITE_PERL%%/Test