aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-06-13 10:28:29 +0800
committeraaron <aaron@FreeBSD.org>2006-06-13 10:28:29 +0800
commite065315f8373c4177534b38cdac9bae966eb3503 (patch)
treee20aa4ea8c1a73c662d89102340191b2f7521328 /devel
parent60187e712c154617721cba14b35728cbfe318541 (diff)
downloadfreebsd-ports-gnome-e065315f8373c4177534b38cdac9bae966eb3503.tar.gz
freebsd-ports-gnome-e065315f8373c4177534b38cdac9bae966eb3503.tar.zst
freebsd-ports-gnome-e065315f8373c4177534b38cdac9bae966eb3503.zip
Adding port devel/p5-Class-STL-Containers, Perl extension for STL-like
object management. Approved by: tobez (implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-STL-Containers/Makefile26
-rw-r--r--devel/p5-Class-STL-Containers/distinfo3
-rw-r--r--devel/p5-Class-STL-Containers/pkg-descr8
-rw-r--r--devel/p5-Class-STL-Containers/pkg-plist20
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 42423eefc9d3..3b813fafcc87 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -809,6 +809,7 @@
SUBDIR += p5-Class-Prototyped
SUBDIR += p5-Class-ReturnValue
SUBDIR += p5-Class-Roles
+ SUBDIR += p5-Class-STL-Containers
SUBDIR += p5-Class-Singleton
SUBDIR += p5-Class-Spiffy
SUBDIR += p5-Class-StateMachine
diff --git a/devel/p5-Class-STL-Containers/Makefile b/devel/p5-Class-STL-Containers/Makefile
new file mode 100644
index 000000000000..7d69d5e519a0
--- /dev/null
+++ b/devel/p5-Class-STL-Containers/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Class-STL-Containers
+# Date created: 12 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-STL-Containers
+PORTVERSION= 0.26
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl extension for STL-like object management
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500807
+IGNORE= requires at least Perl 5.8.7. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-STL-Containers/distinfo b/devel/p5-Class-STL-Containers/distinfo
new file mode 100644
index 000000000000..636ab789f57b
--- /dev/null
+++ b/devel/p5-Class-STL-Containers/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-STL-Containers-0.26.tar.gz) = d24625f7cb3543cd699d04d2b8205002
+SHA256 (Class-STL-Containers-0.26.tar.gz) = 8993d408f68e834e663998b78540906c7c3d6b5a6c4ffbca84395f66ddee0259
+SIZE (Class-STL-Containers-0.26.tar.gz) = 64190
diff --git a/devel/p5-Class-STL-Containers/pkg-descr b/devel/p5-Class-STL-Containers/pkg-descr
new file mode 100644
index 000000000000..1f942a3e04b5
--- /dev/null
+++ b/devel/p5-Class-STL-Containers/pkg-descr
@@ -0,0 +1,8 @@
+This package provides a framework for rapid Object Oriented Perl
+application development. It consists of a number of base classes that are
+similar to the C++/STL framework, plus a number of helper classes which
+provide the glue to transparently generate common functions, and will
+enable you to put your Perl application together very quickly.
+
+WWW: http://search.cpan.org/dist/Class-STL-Containers
+Author: m gaffiero <gaffie@users.sourceforge.net>
diff --git a/devel/p5-Class-STL-Containers/pkg-plist b/devel/p5-Class-STL-Containers/pkg-plist
new file mode 100644
index 000000000000..404fa7d943d3
--- /dev/null
+++ b/devel/p5-Class-STL-Containers/pkg-plist
@@ -0,0 +1,20 @@
+%%SITE_PERL%%/Class/STL/Algorithms.pm
+%%SITE_PERL%%/Class/STL/ClassMembers.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/Constructor.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/DataMember.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/Disable.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/FunctionMember.pm
+%%SITE_PERL%%/Class/STL/ClassMembers/SingletonConstructor.pm
+%%SITE_PERL%%/Class/STL/Containers.pm
+%%SITE_PERL%%/Class/STL/Element.pm
+%%SITE_PERL%%/Class/STL/Iterators.pm
+%%SITE_PERL%%/Class/STL/Trace.pm
+%%SITE_PERL%%/Class/STL/Utilities.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/STL/Containers/.packlist
+%%SITE_PERL%%/stl.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/STL/Containers
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/STL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrmtry %%SITE_PERL%%/Class/STL/ClassMembers
+@dirrmtry %%SITE_PERL%%/Class/STL
+@dirrmtry %%SITE_PERL%%/Class