aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-31 06:19:12 +0800
committermiwi <miwi@FreeBSD.org>2006-12-31 06:19:12 +0800
commite12c6b3332884e9686838a72aa73d8277bc88cc1 (patch)
tree15a2ac8185cd8c3108fb137e6d6dde03bd2212c8 /devel
parent61c29d0c74b4d2cdf924764c26169a53902b3414 (diff)
downloadfreebsd-ports-gnome-e12c6b3332884e9686838a72aa73d8277bc88cc1.tar.gz
freebsd-ports-gnome-e12c6b3332884e9686838a72aa73d8277bc88cc1.tar.zst
freebsd-ports-gnome-e12c6b3332884e9686838a72aa73d8277bc88cc1.zip
Config::Properties is a near implementation of the java.util.Properties API.
It is designed to allow easy reading, writing and manipulation of Java-style property files. WWW: http://search.cpan.org/dist/Config-Properties/ PR: ports/107289 Submitted by: Craig Manley <cmanley@xs4all.nl>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-Properties/Makefile28
-rw-r--r--devel/p5-Config-Properties/distinfo3
-rw-r--r--devel/p5-Config-Properties/pkg-descr5
-rw-r--r--devel/p5-Config-Properties/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 16566305f027..70a876885705 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -920,6 +920,7 @@
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Config-IniHash
SUBDIR += p5-Config-Objective
+ SUBDIR += p5-Config-Properties
SUBDIR += p5-Config-Record
SUBDIR += p5-Config-Setting
SUBDIR += p5-Config-Simple
diff --git a/devel/p5-Config-Properties/Makefile b/devel/p5-Config-Properties/Makefile
new file mode 100644
index 000000000000..2be05abc16bf
--- /dev/null
+++ b/devel/p5-Config-Properties/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Config-Properties
+# Date created: 28 December 2006
+# Whom: Craig Manley
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-Properties
+PORTVERSION= 0.65
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cmanley@xs4all.nl
+COMMENT= Read and write property files
+
+PERL_CONFIGURE= yes
+
+MAN3= Config::Properties.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Config-Properties/distinfo b/devel/p5-Config-Properties/distinfo
new file mode 100644
index 000000000000..653bab331c17
--- /dev/null
+++ b/devel/p5-Config-Properties/distinfo
@@ -0,0 +1,3 @@
+MD5 (Config-Properties-0.65.tar.gz) = cc3f8e5d1feb41d4241ae43d04a81828
+SHA256 (Config-Properties-0.65.tar.gz) = 6a7662d355c9c81621abe4599b0dcb73e579790490c98050f61dd626e825bb7b
+SIZE (Config-Properties-0.65.tar.gz) = 11010
diff --git a/devel/p5-Config-Properties/pkg-descr b/devel/p5-Config-Properties/pkg-descr
new file mode 100644
index 000000000000..bf883b3ae021
--- /dev/null
+++ b/devel/p5-Config-Properties/pkg-descr
@@ -0,0 +1,5 @@
+Config::Properties is a near implementation of the java.util.Properties API.
+It is designed to allow easy reading, writing and manipulation of Java-style
+property files.
+
+WWW: http://search.cpan.org/dist/Config-Properties/
diff --git a/devel/p5-Config-Properties/pkg-plist b/devel/p5-Config-Properties/pkg-plist
new file mode 100644
index 000000000000..076102f4290a
--- /dev/null
+++ b/devel/p5-Config-Properties/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Properties/.packlist
+%%SITE_PERL%%/Config/Properties.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Properties
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config
+@dirrmtry %%SITE_PERL%%/Config