aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-08 00:51:08 +0800
committerAndrej Zverev <az@FreeBSD.org>2013-09-08 00:51:08 +0800
commite209b7678250647a7be44fab70319191cf50885a (patch)
treea64fbf7eb40a41e7cab4953a7e665e88ee9b92b0 /devel
parentb6d26c26ecca351493dee10f65d135d28d3af653 (diff)
downloadfreebsd-ports-gnome-e209b7678250647a7be44fab70319191cf50885a.tar.gz
freebsd-ports-gnome-e209b7678250647a7be44fab70319191cf50885a.tar.zst
freebsd-ports-gnome-e209b7678250647a7be44fab70319191cf50885a.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'devel')
-rw-r--r--devel/lcov/Makefile9
-rw-r--r--devel/p5-Config-INI-Simple/Makefile9
-rw-r--r--devel/p5-Data-Range-Compare/Makefile9
-rw-r--r--devel/p5-DateTime-Format-DateParse/Makefile3
-rw-r--r--devel/p5-Exception-Class-TryCatch/Makefile9
-rw-r--r--devel/p5-ExtUtils-CChecker/Makefile9
-rw-r--r--devel/p5-IO-Lambda/Makefile8
-rw-r--r--devel/p5-Inline-TT/Makefile9
-rw-r--r--devel/p5-Log-Any-Adapter-Dispatch/Makefile8
-rw-r--r--devel/p5-Module-Info/Makefile9
-rw-r--r--devel/p5-Module-Install/Makefile9
-rw-r--r--devel/p5-PAR-Packer/Makefile9
-rw-r--r--devel/p5-Parse-PlainConfig/Makefile9
-rw-r--r--devel/p5-Rcs-Agent/Makefile3
-rw-r--r--devel/p5-SVN-Look/Makefile9
-rw-r--r--devel/p5-Test-Net-RabbitMQ/Makefile9
-rw-r--r--devel/p5-TimeDate/Makefile9
-rw-r--r--devel/p5-boolean/Makefile3
-rw-r--r--devel/p5-capitalization/Makefile9
19 files changed, 53 insertions, 98 deletions
diff --git a/devel/lcov/Makefile b/devel/lcov/Makefile
index 3553bb3f4545..61570b6601db 100644
--- a/devel/lcov/Makefile
+++ b/devel/lcov/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lcov
-# Date created: 2010-02-11
-# Whom: Romain Tartiere <romain@FreeBSD.org>
-#
+# Created by: Romain Tartiere <romain@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= lcov
PORTVERSION= 1.10
@@ -19,7 +15,8 @@ LICENSE= GPLv1
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
PLIST_FILES= bin/lcov bin/gendesc bin/genhtml bin/genpng bin/geninfo
MAN1= gendesc.1 genhtml.1 geninfo.1 genpng.1 lcov.1
diff --git a/devel/p5-Config-INI-Simple/Makefile b/devel/p5-Config-INI-Simple/Makefile
index 37852ee7118f..30b20c9e779a 100644
--- a/devel/p5-Config-INI-Simple/Makefile
+++ b/devel/p5-Config-INI-Simple/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Config-INI-Simple
-# Date created: 2006-07-11
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Config-INI-Simple
PORTVERSION= 0.02
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Simple reading and writing from an INI file
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Config::INI::Simple.3
diff --git a/devel/p5-Data-Range-Compare/Makefile b/devel/p5-Data-Range-Compare/Makefile
index 97164304b990..fe6fbb61a68f 100644
--- a/devel/p5-Data-Range-Compare/Makefile
+++ b/devel/p5-Data-Range-Compare/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Data-Range-Compare
-# Date created: 2010-11-10
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Data-Range-Compare
PORTVERSION= 1.030
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Find gaps & intersections in lists of ranges
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Data::Range::Compare.3 \
Data::Range::Compare::Cookbook.3 \
diff --git a/devel/p5-DateTime-Format-DateParse/Makefile b/devel/p5-DateTime-Format-DateParse/Makefile
index 638005f3d0c2..ebedad6691eb 100644
--- a/devel/p5-DateTime-Format-DateParse/Makefile
+++ b/devel/p5-DateTime-Format-DateParse/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= DateTime::Format::DateParse.3
diff --git a/devel/p5-Exception-Class-TryCatch/Makefile b/devel/p5-Exception-Class-TryCatch/Makefile
index b7b0fe24c846..5d7d7e90384c 100644
--- a/devel/p5-Exception-Class-TryCatch/Makefile
+++ b/devel/p5-Exception-Class-TryCatch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Exception-Class-TryCatch
-# Date created: 2008-02-14
-# Whom: Felippe de Meirelles Motta <lippemail@gmail.com>
-#
+# Created by: Felippe de Meirelles Motta <lippemail@gmail.com>
# $FreeBSD$
-#
PORTNAME= Exception-Class-TryCatch
PORTVERSION= 1.12
@@ -19,7 +15,8 @@ BUILD_DEPENDS+= p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
RUN_DEPENDS+= p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Exception::Class::TryCatch.3
diff --git a/devel/p5-ExtUtils-CChecker/Makefile b/devel/p5-ExtUtils-CChecker/Makefile
index 602a04761b92..0252ab4e6b22 100644
--- a/devel/p5-ExtUtils-CChecker/Makefile
+++ b/devel/p5-ExtUtils-CChecker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ExtUtils::CChecker
-# Date created: 21 Feb 2010
-# Whom: Sahil Tandon <sahil@tandon.net>
-#
+# Created by: Sahil Tandon <sahil@tandon.net>
# $FreeBSD$
-#
PORTNAME= ExtUtils-CChecker
PORTVERSION= 0.08
@@ -16,7 +12,8 @@ COMMENT= Configure-time utilities for using C headers, libraries, OS features
TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ExtUtils::CChecker.3
diff --git a/devel/p5-IO-Lambda/Makefile b/devel/p5-IO-Lambda/Makefile
index f0492849757b..b97a1eadc141 100644
--- a/devel/p5-IO-Lambda/Makefile
+++ b/devel/p5-IO-Lambda/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: devel/p5-IO-Lambda
-# Date created: 06 Nov 2008
-# Whom: Vany Serezhkin <ivan@serezhkin.com>
-#
+# Created by: Vany Serezhkin <ivan@serezhkin.com>
# $FreeBSD$
PORTNAME= IO-Lambda
@@ -23,7 +20,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-AnyEvent>=4.33:${PORTSDIR}/devel/p5-AnyEvent \
p5-DBI>=1.60.4:${PORTSDIR}/databases/p5-DBI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS+= --no-online-tests
MAN3= IO::Lambda.3 \
diff --git a/devel/p5-Inline-TT/Makefile b/devel/p5-Inline-TT/Makefile
index 28ddca44689a..ccfd5d6fb27d 100644
--- a/devel/p5-Inline-TT/Makefile
+++ b/devel/p5-Inline-TT/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Inline-TT
-# Date created: 2006-09-26
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Inline-TT
PORTVERSION= 0.07
@@ -18,7 +14,8 @@ COMMENT= Provides inline support for template toolkit 2.x
RUN_DEPENDS= p5-Inline>=0.42:${PORTSDIR}/devel/p5-Inline \
p5-Template-Toolkit>=2.0:${PORTSDIR}/www/p5-Template-Toolkit
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Inline::TT.3
diff --git a/devel/p5-Log-Any-Adapter-Dispatch/Makefile b/devel/p5-Log-Any-Adapter-Dispatch/Makefile
index d82ebf1eb2dc..6afe871e355b 100644
--- a/devel/p5-Log-Any-Adapter-Dispatch/Makefile
+++ b/devel/p5-Log-Any-Adapter-Dispatch/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Log::Any::Adapter::Dispatch
-# Date created: 30 Aug 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Log-Any-Adapter-Dispatch
PORTVERSION= 0.06
@@ -19,7 +14,8 @@ RUN_DEPENDS= \
p5-Log-Dispatch>=2.26:${PORTSDIR}/devel/p5-Log-Dispatch
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Any::Adapter::Dispatch.3
diff --git a/devel/p5-Module-Info/Makefile b/devel/p5-Module-Info/Makefile
index b31cd8ba1466..c1de07877de6 100644
--- a/devel/p5-Module-Info/Makefile
+++ b/devel/p5-Module-Info/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Module::Info
-# Date created: 29 June 2003
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
-#
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Module-Info
PORTVERSION= 0.34
@@ -17,7 +13,8 @@ COMMENT= Provides information about Perl modules
BUILD_DEPENDS= p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= module_info.1 pfunc.1
MAN3= B::BUtils.3 B::Module::Info.3 Module::Info.3
diff --git a/devel/p5-Module-Install/Makefile b/devel/p5-Module-Install/Makefile
index b2ee0b937246..1863d7cb5567 100644
--- a/devel/p5-Module-Install/Makefile
+++ b/devel/p5-Module-Install/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Module-Install
-# Date created: Sep 15 2004
-# Whom: clsung
-#
+# Created by: clsung
# $FreeBSD$
-#
PORTNAME= Module-Install
PORTVERSION= 1.06
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-File-Remove>=1.42:${PORTSDIR}/devel/p5-File-Remove \
p5-libwww>=5.812:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= --skip
MAN3= inc::Module::Install.3 \
diff --git a/devel/p5-PAR-Packer/Makefile b/devel/p5-PAR-Packer/Makefile
index 24b50e60cd1b..04e052f5aee3 100644
--- a/devel/p5-PAR-Packer/Makefile
+++ b/devel/p5-PAR-Packer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-PAR-Packer
-# Date created: Dec 06 2006
-# Whom: Rong-En Fan <rafan@FreeBSD.org>
-#
+# Created by: Rong-En Fan <rafan@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= PAR-Packer
PORTVERSION= 1.01.4
@@ -27,7 +23,8 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
CONFLICTS= sketchy-*
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE= yes
MAN1= par.pl.1 parl.1 pp.1 tkpp.1
diff --git a/devel/p5-Parse-PlainConfig/Makefile b/devel/p5-Parse-PlainConfig/Makefile
index 8ab7e0e1b6be..496a7b822cde 100644
--- a/devel/p5-Parse-PlainConfig/Makefile
+++ b/devel/p5-Parse-PlainConfig/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Parse-PlainConfig
-# Date created: December 2nd 2010
-# Whom: Peter Vereshagin <peter@vereshagin.org>
-#
+# Created by: Peter Vereshagin <peter@vereshagin.org>
# $FreeBSD$
-#
PORTNAME= Parse-PlainConfig
PORTVERSION= 2.06
@@ -18,7 +14,8 @@ RUN_DEPENDS= p5-Paranoid>0:${PORTSDIR}/devel/p5-Paranoid \
p5-Text-ParseWords>0:${PORTSDIR}/textproc/p5-Text-ParseWords \
p5-Text-Tabs+Wrap>0:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Parse::PlainConfig.3
diff --git a/devel/p5-Rcs-Agent/Makefile b/devel/p5-Rcs-Agent/Makefile
index dcdb079f9b29..dc1d610774ed 100644
--- a/devel/p5-Rcs-Agent/Makefile
+++ b/devel/p5-Rcs-Agent/Makefile
@@ -13,7 +13,8 @@ COMMENT= A perl module for RCS archive manipulation
BUILD_DEPENDS= p5-String-ShellQuote>1.00:${PORTSDIR}/textproc/p5-String-ShellQuote
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Rcs::Agent.3
diff --git a/devel/p5-SVN-Look/Makefile b/devel/p5-SVN-Look/Makefile
index 1eb58cd3228c..4153b2479c1d 100644
--- a/devel/p5-SVN-Look/Makefile
+++ b/devel/p5-SVN-Look/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: SVN::Look
-# Date created: 2009-01-27
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= SVN-Look
PORTVERSION= 0.38
@@ -21,7 +17,8 @@ RUN_DEPENDS= subversion>=1.7.0:${PORTSDIR}/devel/subversion \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-PathTools>=0:${PORTSDIR}/devel/p5-PathTools
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SVN::Look.3
diff --git a/devel/p5-Test-Net-RabbitMQ/Makefile b/devel/p5-Test-Net-RabbitMQ/Makefile
index 991bbd686c59..db23d3207763 100644
--- a/devel/p5-Test-Net-RabbitMQ/Makefile
+++ b/devel/p5-Test-Net-RabbitMQ/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Test-Net-RabbitMQ
-# Date created: 2010-09-10
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Test-Net-RabbitMQ
PORTVERSION= 0.09
@@ -20,7 +16,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Test::Net::RabbitMQ.3
diff --git a/devel/p5-TimeDate/Makefile b/devel/p5-TimeDate/Makefile
index 71a9d3291c2f..68121ea7e0b2 100644
--- a/devel/p5-TimeDate/Makefile
+++ b/devel/p5-TimeDate/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-TimeDate
-# Date created: Mon Sep 1 17:03:41 CEST 1997
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
-#
+# Created by: Andreas Klemm <andreas@klemm.gtn.com>
# $FreeBSD$
-#
PORTNAME= TimeDate
PORTVERSION= 2.30
@@ -17,7 +13,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Perl5 module containing a better/faster date parser for absolute dates
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Date::Format.3 Date::Language.3 Date::Language::Bulgarian.3 \
Date::Language::Hungarian.3 Date::Parse.3 Time::Zone.3
diff --git a/devel/p5-boolean/Makefile b/devel/p5-boolean/Makefile
index e05772e664c6..081f31323511 100644
--- a/devel/p5-boolean/Makefile
+++ b/devel/p5-boolean/Makefile
@@ -14,7 +14,8 @@ COMMENT= Boolean support for Perl
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= boolean.3
diff --git a/devel/p5-capitalization/Makefile b/devel/p5-capitalization/Makefile
index 78d16dc5546b..125d6ab592e8 100644
--- a/devel/p5-capitalization/Makefile
+++ b/devel/p5-capitalization/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: capitalization.pm
-# Date created: 29 August 2005
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
-#
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= capitalization
PORTVERSION= 0.03
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Devel-Symdump>=0:${PORTSDIR}/devel/p5-Devel-Symdump \
p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= capitalization.3