aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2013-10-21 02:07:19 +0800
committerjhale <jhale@FreeBSD.org>2013-10-21 02:07:19 +0800
commite263afe1afd53c61842adeb585ab48fecffa381a (patch)
treec4971dae6f393033363762e1853d45ff770f0af8 /devel
parent8f8a4112f2ecc82bb1cafb8fd2c214f63a2f6c90 (diff)
downloadfreebsd-ports-gnome-e263afe1afd53c61842adeb585ab48fecffa381a.tar.gz
freebsd-ports-gnome-e263afe1afd53c61842adeb585ab48fecffa381a.tar.zst
freebsd-ports-gnome-e263afe1afd53c61842adeb585ab48fecffa381a.zip
- Support staging
- Use new LIB_DEPENDS syntax - Use options helpers
Diffstat (limited to 'devel')
-rw-r--r--devel/libchipcard/Makefile40
1 files changed, 17 insertions, 23 deletions
diff --git a/devel/libchipcard/Makefile b/devel/libchipcard/Makefile
index 20dc0df0c931..1e170ace513a 100644
--- a/devel/libchipcard/Makefile
+++ b/devel/libchipcard/Makefile
@@ -12,17 +12,13 @@ COMMENT= Library for easy access to chipcards
LICENSE= LGPL21
-LIB_DEPENDS= pcsclite:${PORTSDIR}/devel/pcsc-lite \
- gwenhywfar:${PORTSDIR}/devel/gwenhywfar
+LIB_DEPENDS= libpcsclite.so:${PORTSDIR}/devel/pcsc-lite \
+ libgwenhywfar.so:${PORTSDIR}/devel/gwenhywfar
+USES= gmake
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
USE_OPENSSL= yes
-OPTIONS_DEFINE= DOXYGEN MEMDEBUG
-
-MEMDEBUG_DESC= Enable memory debugger statistic
-
GNU_CONFIGURE= yes
CONFIGURE_ENV+= aq_distrib_name="FreeBSD"
CONFIGURE_ARGS+=--enable-release="yes" \
@@ -36,18 +32,16 @@ USE_LDCONFIG= yes
GWEN_SHLIB_VER= 60
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOXYGEN MEMDEBUG
-.if ${PORT_OPTIONS:MDOXYGEN}
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
- dot:${PORTSDIR}/graphics/graphviz
-CONFIGURE_ARGS+=--enable-full-doc
-.endif
+DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen \
+ dot:${PORTSDIR}/graphics/graphviz
+DOXYGEN_CONFIGURE_ENABLE= full-doc
-.if ${PORT_OPTIONS:MMEMDEBUG}
-CONFIGURE_ARGS+=--enable-memtrace
-.endif
+MEMDEBUG_DESC= Enable memory debugger statistic
+MEMDEBUG_CONFIGURE_ENABLE= memtrace
+
+.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} -e 's|aq_endian\" ==|aq_endian\" =|g' \
@@ -62,13 +56,13 @@ post-build:
post-install:
.if ${PORT_OPTIONS:MDOXYGEN}
- ${MKDIR} ${DOCSDIR}/apidoc
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/apidoc
cd ${WRKSRC}/apidoc && \
- ${COPYTREE_SHARE} \* ${DOCSDIR}/apidoc
- @${FIND} -P ${DOCSDIR} -type f 2>/dev/null | \
- ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
- @${FIND} -P -d ${DOCSDIR} -type d 2>/dev/null | \
- ${SED} -ne 's,^${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
+ ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}/apidoc
+ @${FIND} -P ${STAGEDIR}${DOCSDIR} -type f 2>/dev/null | \
+ ${SED} -ne 's|^${STAGEDIR}${PREFIX}/||p' >> ${TMPPLIST}
+ @${FIND} -P -d ${STAGEDIR}${DOCSDIR} -type d 2>/dev/null | \
+ ${SED} -ne 's|^${STAGEDIR}${PREFIX}/|@dirrm |p' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>