aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-10-05 07:08:40 +0800
committeredwin <edwin@FreeBSD.org>2007-10-05 07:08:40 +0800
commite3738b71992051f7eeeb01ee044f2b9ed0da8d7f (patch)
tree3765bd064ace710e31db7a0460d9aeb483a2fcf1 /devel
parent8825523b31cac0a270aea3a253c2c8f183c41f8f (diff)
downloadfreebsd-ports-gnome-e3738b71992051f7eeeb01ee044f2b9ed0da8d7f.tar.gz
freebsd-ports-gnome-e3738b71992051f7eeeb01ee044f2b9ed0da8d7f.tar.zst
freebsd-ports-gnome-e3738b71992051f7eeeb01ee044f2b9ed0da8d7f.zip
Remove always true/always false OSVERSION conditions.
Diffstat (limited to 'devel')
-rw-r--r--devel/pecl-statgrab/Makefile4
-rw-r--r--devel/valgrind-snapshot/Makefile10
-rw-r--r--devel/valgrind/Makefile10
3 files changed, 0 insertions, 24 deletions
diff --git a/devel/pecl-statgrab/Makefile b/devel/pecl-statgrab/Makefile
index 4dd1912ea114..db0576029225 100644
--- a/devel/pecl-statgrab/Makefile
+++ b/devel/pecl-statgrab/Makefile
@@ -29,10 +29,6 @@ CONFIGURE_ARGS= --with-statgrab=${LOCALBASE}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-EXTRA_LIBS= -lkvm
-.endif
-
.if ${PHP_VER} < 5
post-patch:
@${PATCH} -d ${WRKSRC} -p0 < ${FILESDIR}/php_statgrab.h.patch
diff --git a/devel/valgrind-snapshot/Makefile b/devel/valgrind-snapshot/Makefile
index 35d05ab45509..6151aec05b6c 100644
--- a/devel/valgrind-snapshot/Makefile
+++ b/devel/valgrind-snapshot/Makefile
@@ -80,16 +80,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/coregrind/vg_unistd.h \
${PREFIX}/include/valgrind
-# Check if kernel is built with USER_LDT option (FreeBSD 4 only)
-.if ${OSVERSION} < 500000
- @${PREFIX}/bin/valgrind --tool=memcheck true 2> ${WRKDIR}/ldt.test
- @${GREP} i386_set_ldt ${WRKDIR}/ldt.test >/dev/null &&\
- ${ECHO_CMD} !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! && \
- ${ECHO_CMD} Please rebuild your kernel with ``options USER_LDT''! && \
- ${ECHO_CMD} Otherwise, valgrind will not be able to perform pointer analysis! && \
- ${ECHO_CMD} !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! || true
-.endif
-
# Generate suppression files
.ifndef (PACKAGE_BUILDING)
@yes | ${PREFIX}/bin/valgrind --tool=memcheck --gen-suppressions=yes true 2>&1 \
diff --git a/devel/valgrind/Makefile b/devel/valgrind/Makefile
index 091adbc89647..593c3ffd62d1 100644
--- a/devel/valgrind/Makefile
+++ b/devel/valgrind/Makefile
@@ -76,16 +76,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/coregrind/vg_unistd.h \
${PREFIX}/include/valgrind
-# Check if kernel is built with USER_LDT option (FreeBSD 4 only)
-.if ${OSVERSION} < 500000
- @${PREFIX}/bin/valgrind --tool=memcheck true 2> ${WRKDIR}/ldt.test
- @${GREP} i386_set_ldt ${WRKDIR}/ldt.test >/dev/null &&\
- ${ECHO_CMD} !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! && \
- ${ECHO_CMD} Please rebuild your kernel with ``options USER_LDT''! && \
- ${ECHO_CMD} Otherwise, valgrind will not be able to perform pointer analysis! && \
- ${ECHO_CMD} !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! || true
-.endif
-
.ifndef (PACKAGE_BUILDING)
@yes | ${PREFIX}/bin/valgrind --tool=memcheck --gen-suppressions=yes true 2>&1 \
| ${SED} -e 's,.*{$$,{,' \