aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-11-15 06:58:49 +0800
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-11-15 06:58:49 +0800
commite3afc5c3cea672199664a8d5fb042ca8db85d2cc (patch)
treec1174843cbcc7751ec3931f2bb16095bb4c59036 /devel
parent3f5c5014413e95cee1677f09cdff82a12b380551 (diff)
downloadfreebsd-ports-gnome-e3afc5c3cea672199664a8d5fb042ca8db85d2cc.tar.gz
freebsd-ports-gnome-e3afc5c3cea672199664a8d5fb042ca8db85d2cc.tar.zst
freebsd-ports-gnome-e3afc5c3cea672199664a8d5fb042ca8db85d2cc.zip
- Add missing dependency
- Fix a problem with OpenSSL support. Now net/twinkle can compile without problems. - Bump PORTREVISION Tested by: pav Reported by: pav
Diffstat (limited to 'devel')
-rw-r--r--devel/libzrtpcpp/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/libzrtpcpp/Makefile b/devel/libzrtpcpp/Makefile
index a8a767fcfca2..69e9a9d34881 100644
--- a/devel/libzrtpcpp/Makefile
+++ b/devel/libzrtpcpp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libzrtpcpp
PORTVERSION= 1.4.6
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR=ccrtp
@@ -14,14 +15,15 @@ MASTER_SITE_SUBDIR=ccrtp
MAINTAINER= acm@FreeBSD.org
COMMENT= ZRTP extension for GNU ccRTP
-LIB_DEPENDS= ccrtp1-1.7.0:${PORTSDIR}/devel/ccrtp
+LIB_DEPENDS= ccrtp1-1.7.0:${PORTSDIR}/devel/ccrtp \
+ gcrypt.16:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_OPENSSL= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include -I${OPENSSLINC}
+LDFLAGS+= -L${LOCALBASE}/lib -L${OPENSSLLIB}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes