aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-06-29 01:38:52 +0800
committerade <ade@FreeBSD.org>2000-06-29 01:38:52 +0800
commite5f68b597960573863b2471333d6536c5bd54709 (patch)
treed3d890b453f32799deaf1140ee4056cc0e78d8a8 /devel
parentaaa50ea1e8aee612152557319e0e63c5b6e198a2 (diff)
downloadfreebsd-ports-gnome-e5f68b597960573863b2471333d6536c5bd54709.tar.gz
freebsd-ports-gnome-e5f68b597960573863b2471333d6536c5bd54709.tar.zst
freebsd-ports-gnome-e5f68b597960573863b2471333d6536c5bd54709.zip
Dryad is an embryonic debugger, based around
the GNOME Debugging Framework (GDF)
Diffstat (limited to 'devel')
-rw-r--r--devel/dryad/Makefile32
-rw-r--r--devel/dryad/distinfo1
-rw-r--r--devel/dryad/pkg-comment1
-rw-r--r--devel/dryad/pkg-descr4
-rw-r--r--devel/dryad/pkg-plist9
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/dryad/Makefile b/devel/dryad/Makefile
new file mode 100644
index 000000000000..0e24252b5a31
--- /dev/null
+++ b/devel/dryad/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: dryad
+# Date created: 28th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dryad
+PORTVERSION= 0.1.2
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/dryad
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ glade.3:${PORTSDIR}/devel/libglade \
+ oaf.0:${PORTSDIR}/devel/oaf \
+ bonobo.2:${PORTSDIR}/devel/bonobo \
+ gdf.0:${PORTSDIR}/devel/gnome-debug
+RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/devel/dryad/distinfo b/devel/dryad/distinfo
new file mode 100644
index 000000000000..5bddc92a5075
--- /dev/null
+++ b/devel/dryad/distinfo
@@ -0,0 +1 @@
+MD5 (dryad-0.1.2.tar.gz) = 22cb7da6ffd19134cf82d66146d0a64c
diff --git a/devel/dryad/pkg-comment b/devel/dryad/pkg-comment
new file mode 100644
index 000000000000..2ea6019b54c8
--- /dev/null
+++ b/devel/dryad/pkg-comment
@@ -0,0 +1 @@
+GNOME based standalone debugging frontend
diff --git a/devel/dryad/pkg-descr b/devel/dryad/pkg-descr
new file mode 100644
index 000000000000..e4906fd4e0cb
--- /dev/null
+++ b/devel/dryad/pkg-descr
@@ -0,0 +1,4 @@
+Dryad is a GNOME based standalone debugging frontend.
+It is nowhere near done yet.
+
+WWW: http://www.gnome.org/
diff --git a/devel/dryad/pkg-plist b/devel/dryad/pkg-plist
new file mode 100644
index 000000000000..4145f7ae8a66
--- /dev/null
+++ b/devel/dryad/pkg-plist
@@ -0,0 +1,9 @@
+bin/dryad
+share/gnome/apps/Development/dryad.desktop
+share/gnome/dryad/glade/detach.xpm
+share/gnome/dryad/glade/dryad.glade
+share/gnome/dryad/glade/step-into.xpm
+share/gnome/dryad/glade/step-out.xpm
+share/gnome/dryad/glade/step-over.xpm
+@dirrm share/gnome/dryad/glade
+@dirrm share/gnome/dryad