aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-07-03 01:57:07 +0800
committernork <nork@FreeBSD.org>2003-07-03 01:57:07 +0800
commite962a0aaeb0df9b4ea7d41c07d4969929112d60d (patch)
tree612f632a15f41a788d707306b1102c02a305f719 /devel
parentbf39b89125cae9af2d0509b88bc8d0720e98509c (diff)
downloadfreebsd-ports-gnome-e962a0aaeb0df9b4ea7d41c07d4969929112d60d.tar.gz
freebsd-ports-gnome-e962a0aaeb0df9b4ea7d41c07d4969929112d60d.tar.zst
freebsd-ports-gnome-e962a0aaeb0df9b4ea7d41c07d4969929112d60d.zip
o Update to 20030629.
o Support for Configuration ROM stub (dcons_crom). o Take MAINTAINER-ship to me. o Install/Deinstal /dev/dcons and /dev/dconsctl on 4-STABLE. Submitted by: simokawa (developper)
Diffstat (limited to 'devel')
-rw-r--r--devel/dcons/Makefile37
-rw-r--r--devel/dcons/distinfo2
-rw-r--r--devel/dcons/files/Makefile2
-rw-r--r--devel/dcons/files/dcons.sh3
-rw-r--r--devel/dcons/files/share::man::man4::Makefile2
-rw-r--r--devel/dcons/pkg-plist6
6 files changed, 42 insertions, 10 deletions
diff --git a/devel/dcons/Makefile b/devel/dcons/Makefile
index 259c06f1d4d3..5afe45fbcd03 100644
--- a/devel/dcons/Makefile
+++ b/devel/dcons/Makefile
@@ -6,26 +6,43 @@
#
PORTNAME= dcons
-PORTVERSION= 20030525
+PORTVERSION= 20030629
CATEGORIES= devel sysutils
MASTER_SITES= http://people.FreeBSD.org/~simokawa/firewire/
-MAINTAINER= simokawa@FreeBSD.org
+MAINTAINER= nork@FreeBSD.org
COMMENT= Dumb CONSole device driver
NO_WRKSUBDIR= yes
MANCOMPRESSED= yes
-MAN4= dcons.4
+MAN4= dcons.4 dcons_crom.4
MAN8= fwchat.8
PKGMESSAGE= ${WRKSRC}/pkg-message
+.include <bsd.port.pre.mk>
KMODDIR= ${PREFIX}/lib/dcons
MAKE_ENV= KMODDIR=${KMODDIR} \
- BINDIR=${PREFIX}/bin \
+ BINDIR=${PREFIX}/sbin \
MANDIR=${MANPREFIX}/man/man
-PLIST_SUB= KMODDIR=${KMODDIR}
+MKNOD?= /sbin/mknod
+MAKEDEV= /dev/MAKEDEV
+DCONS_DEV= /dev/dcons
+DCONS_MAJOR= 184
+DCONS_MINOR= 0
+DCONS_MODE= 0622
+DCONSCTL_DEV= /dev/dconsctl
+DCONSCTL_MAJOR= 184
+DCONSCTL_MINOR= 2
+DCONSCTL_MODE= 0600
+PLIST_SUB= KMODDIR=${KMODDIR} MKNOD=${MKNOD} MAKEDEV=${MAKEDEV} \
+ DCONS_DEV=${DCONS_DEV} \
+ DCONS_MAJOR=${DCONS_MAJOR} DCONS_MINOR=${DCONS_MINOR} \
+ DCONS_MODE=${DCONS_MODE} \
+ DCONSCTL_DEV=${DCONSCTL_DEV} \
+ DCONSCTL_MAJOR=${DCONSCTL_MAJOR} DCONSCTL_MINOR=${DCONSCTL_MINOR} \
+ DCONSCTL_MODE=${DCONSCTL_MODE}
post-extract:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@@ -43,8 +60,16 @@ pre-install:
@${INSTALL_DATA} ${WRKSRC}/README.dcons ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/usr.sbin/fwchat/gdb-usage ${DOCSDIR}/
@${INSTALL_DATA} ${WRKSRC}/usr.sbin/fwchat/sample-script ${DOCSDIR}/
+ if [ -x ${MAKEDEV} ]; then \
+ ${RM} -f ${DCONS_DEV}; \
+ ${MKNOD} ${DCONS_DEV} c ${DCONS_MAJOR} ${DCONS_MINOR}; \
+ ${CHMOD} ${DCONS_MODE} ${DCONS_DEV}; \
+ ${RM} -f ${DCONSCTL_DEV}; \
+ ${MKNOD} ${DCONSCTL_DEV} c ${DCONSCTL_MAJOR} ${DCONSCTL_MINOR}; \
+ ${CHMOD} ${DCONSCTL_MODE} ${DCONSCTL_DEV}; \
+ fi
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/dcons/distinfo b/devel/dcons/distinfo
index ecb507c6d7ef..b8e6343b9368 100644
--- a/devel/dcons/distinfo
+++ b/devel/dcons/distinfo
@@ -1 +1 @@
-MD5 (dcons-20030525.tar.gz) = f1dee68374ff9532c67755aed6f1f1ca
+MD5 (dcons-20030629.tar.gz) = 1e55ce86f6422cd837274360292f1834
diff --git a/devel/dcons/files/Makefile b/devel/dcons/files/Makefile
index 435278e414bf..bf4476d97863 100644
--- a/devel/dcons/files/Makefile
+++ b/devel/dcons/files/Makefile
@@ -1,5 +1,5 @@
# $FreeBSD$
-SUBDIR= sys/modules/dcons usr.sbin/fwchat share/man/man4
+SUBDIR= sys/modules/dcons sys/modules/dcons_crom usr.sbin/fwchat share/man/man4
.include <bsd.subdir.mk>
diff --git a/devel/dcons/files/dcons.sh b/devel/dcons/files/dcons.sh
index d4800ac0153c..602934c1384e 100644
--- a/devel/dcons/files/dcons.sh
+++ b/devel/dcons/files/dcons.sh
@@ -17,6 +17,8 @@ start)
case ${dcons_enable:-NO} in
[Yy][Ee][Ss])
/sbin/kldload ${PREFIX}/lib/dcons/dcons.ko && echo -n ' dcons'
+ /sbin/kldload ${PREFIX}/lib/dcons/dcons_crom.ko && echo -n ' dcons_crom'
+ /usr/sbin/fwcontrol -r
;;
esac
;;
@@ -24,6 +26,7 @@ stop)
case ${dcons_enable:-NO} in
[Yy][Ee][Ss])
/sbin/kldunload dcons & echo -n ' dcons'
+ /sbin/kldunload dcons_crom & echo -n ' dcons_crom'
;;
esac
;;
diff --git a/devel/dcons/files/share::man::man4::Makefile b/devel/dcons/files/share::man::man4::Makefile
index b906348121b5..29d5ec7c0c03 100644
--- a/devel/dcons/files/share::man::man4::Makefile
+++ b/devel/dcons/files/share::man::man4::Makefile
@@ -1,3 +1,3 @@
-MAN= dcons.4
+MAN= dcons.4 dcons_crom.4
.include <bsd.prog.mk>
diff --git a/devel/dcons/pkg-plist b/devel/dcons/pkg-plist
index 34fff7ee0536..d4afd3f1ab7a 100644
--- a/devel/dcons/pkg-plist
+++ b/devel/dcons/pkg-plist
@@ -1,7 +1,11 @@
-bin/fwchat
+sbin/fwchat
+@unexec [ -f %%MAKEDEV%% ] && /bin/rm -f %%DCONS_DEV%% %%DCONSCTL_DEV%% || true
@unexec /bin/rm -f %D/lib/dcons/linker.hints
lib/dcons/dcons.ko
+lib/dcons/dcons_crom.ko
@exec type kldxref > /dev/null 2>&1 && kldxref %D/lib/dcons
+@exec [ -f %%MAKEDEV%% ] && /bin/rm -f %%DCONS_DEV%%; %%MKNOD%% %%DCONS_DEV%% c %%DCONS_MAJOR%% %%DCONS_MINOR%%; /bin/chmod %%DCONS_MODE%% || true
+@exec [ -f %%MAKEDEV%% ] && /bin/rm -f %%DCONSCTL_DEV%%; %%MKNOD%% %%DCONSCTL_DEV%% c %%DCONSCTL_MAJOR%% %%DCONSCTL_MINOR%%; /bin/chmod %%DCONSCTL_MODE%% || true
etc/rc.d/dcons.sh
%%DOCSDIR%%/gdb-usage
%%DOCSDIR%%/README.dcons