aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-01-06 15:31:44 +0800
committersergei <sergei@FreeBSD.org>2004-01-06 15:31:44 +0800
commitea676a2a35aa333facbe29d697ddeff71e0be0d6 (patch)
tree3ac6957634fe554d37fd0261dced882cd1e2ec81 /devel
parent8aaea79cc9974289247b5fb8ccd7751427bfa018 (diff)
downloadfreebsd-ports-gnome-ea676a2a35aa333facbe29d697ddeff71e0be0d6.tar.gz
freebsd-ports-gnome-ea676a2a35aa333facbe29d697ddeff71e0be0d6.tar.zst
freebsd-ports-gnome-ea676a2a35aa333facbe29d697ddeff71e0be0d6.zip
- Allow some Makefile variables to be overriden by slave port(s)
- Remove maintainer's URL from MASTER_SITES PR: 60962 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/ace+tao/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/devel/ace+tao/Makefile b/devel/ace+tao/Makefile
index fe64ff5f5078..e827a3b27925 100644
--- a/devel/ace+tao/Makefile
+++ b/devel/ace+tao/Makefile
@@ -5,17 +5,18 @@
# $FreeBSD$
#
-PORTNAME= ace+tao
-PORTVERSION= ${ACE_VERSION}+${TAO_VERSION}
+PORTNAME?= ace+tao
+PORTVERSION?= ${ACE_VERSION}+${TAO_VERSION}
CATEGORIES= devel
# The distfile does not have version numbers, so try my mirror first
MASTER_SITES= http://deuce.doc.wustl.edu/ \
- http://www.ciam.ru/~sem/FreeBSD/ \
http://www.navicon.dk/mirrors/ace/deuce.doc.wustl.edu/
-DISTNAME= ${PORTNAME:U}
+DISTNAME?= ${PORTNAME:U}
MAINTAINER= sem@ciam.ru
-COMMENT= The Adaptive Communication Environment (ACE) with The ACE ORB (TAO)
+COMMENT?= The Adaptive Communication Environment (ACE) with The ACE ORB (TAO)
+
+CONFLICTS= ace-*
ACE_VERSION= 5.3.6
TAO_VERSION= 1.3.6
@@ -41,7 +42,7 @@ PLIST_SUB+= TAO=${TAO} TESTS=${TESTS}
.if defined(WITHOUT_TAO)
TAO= "@comment "
-PKGNAMESUFFIX= -notao
+PKGNAMESUFFIX?= -notao
.endif
.include <bsd.port.pre.mk>