aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-02-22 04:02:00 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-02-22 04:02:00 +0800
commitead7e6753883be8fbfb44bdf91a51b9b1205df96 (patch)
tree19d44c4e6b7da909c5a84049591338a0613dbc64 /devel
parent453c9999365e6f06afa6560380fb83bd4aaeb62d (diff)
downloadfreebsd-ports-gnome-ead7e6753883be8fbfb44bdf91a51b9b1205df96.tar.gz
freebsd-ports-gnome-ead7e6753883be8fbfb44bdf91a51b9b1205df96.tar.zst
freebsd-ports-gnome-ead7e6753883be8fbfb44bdf91a51b9b1205df96.zip
A Ruby driver for MongoDB.
WWW: https://github.com/mongodb/mongo-ruby-driver PR: ports/165368 Submitted by: Evan Sarmiento <bsdports@wayfair.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-mongo/Makefile23
-rw-r--r--devel/rubygem-mongo/distinfo2
-rw-r--r--devel/rubygem-mongo/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 59956c271c5b..b18a4793b8c0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3700,6 +3700,7 @@
SUBDIR += rubygem-mkrf
SUBDIR += rubygem-mocha
SUBDIR += rubygem-moneta
+ SUBDIR += rubygem-mongo
SUBDIR += rubygem-msgpack
SUBDIR += rubygem-multi_json
SUBDIR += rubygem-mutter
diff --git a/devel/rubygem-mongo/Makefile b/devel/rubygem-mongo/Makefile
new file mode 100644
index 000000000000..9a31fe19cd26
--- /dev/null
+++ b/devel/rubygem-mongo/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: rubygem-mongo
+# Date created: 18 Feburary 2012
+# Whom: Evan Sarmiento <bsdports@wayfair.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mongo
+PORTVERSION= 1.5.2
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby library for mongo
+
+RUN_DEPENDS= rubygem-bson>=1.5.2:${PORTSDIR}/databases/rubygem-bson
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/mongo_console
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-mongo/distinfo b/devel/rubygem-mongo/distinfo
new file mode 100644
index 000000000000..1920d2928296
--- /dev/null
+++ b/devel/rubygem-mongo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/mongo-1.5.2.gem) = 11f7ccd2252274d104ce500a2348c6a4dfb422980478e97a44cbfb4f919c9b98
+SIZE (rubygem/mongo-1.5.2.gem) = 129536
diff --git a/devel/rubygem-mongo/pkg-descr b/devel/rubygem-mongo/pkg-descr
new file mode 100644
index 000000000000..8c20f3cac080
--- /dev/null
+++ b/devel/rubygem-mongo/pkg-descr
@@ -0,0 +1,3 @@
+A Ruby driver for MongoDB.
+
+WWW: https://github.com/mongodb/mongo-ruby-driver