aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-09-29 04:02:16 +0800
committerantoine <antoine@FreeBSD.org>2016-09-29 04:02:16 +0800
commitecb6993eab7a3fec539208d9c4599cba3a0a3443 (patch)
treee64160cc4e7487eda75a6e8b99f70be3de2342af /devel
parentb019573443cab183f583595265f56cfb2fc7cdc9 (diff)
downloadfreebsd-ports-gnome-ecb6993eab7a3fec539208d9c4599cba3a0a3443.tar.gz
freebsd-ports-gnome-ecb6993eab7a3fec539208d9c4599cba3a0a3443.tar.zst
freebsd-ports-gnome-ecb6993eab7a3fec539208d9c4599cba3a0a3443.zip
New port: devel/py-pathlib2
Backport of standard pathlib module which tracks the standard library module, so all the newest features of the standard pathlib can be used also on older Python versions. WWW: https://pypi.python.org/pypi/pathlib2/ PR: 213049
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pathlib2/Makefile27
-rw-r--r--devel/py-pathlib2/distinfo3
-rw-r--r--devel/py-pathlib2/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6982431b11b6..c2c3e6da829a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4302,6 +4302,7 @@
SUBDIR += py-parsedatetime
SUBDIR += py-path.py
SUBDIR += py-pathlib
+ SUBDIR += py-pathlib2
SUBDIR += py-pathtools
SUBDIR += py-paver
SUBDIR += py-pbr
diff --git a/devel/py-pathlib2/Makefile b/devel/py-pathlib2/Makefile
new file mode 100644
index 000000000000..ac6f8e26e212
--- /dev/null
+++ b/devel/py-pathlib2/Makefile
@@ -0,0 +1,27 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pathlib2
+PORTVERSION= 2.1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Object-oriented filesystem paths
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+do-test:
+ @(cd ${WRKSRC} && \
+ ${PYTHON_CMD} test_pathlib2.py && \
+ ${PYTHON_CMD} test_pathlib2_with_py2_unicode_literals.py)
+
+.include <bsd.port.mk>
diff --git a/devel/py-pathlib2/distinfo b/devel/py-pathlib2/distinfo
new file mode 100644
index 000000000000..a0b9adf5f03f
--- /dev/null
+++ b/devel/py-pathlib2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475082260
+SHA256 (pathlib2-2.1.0.tar.gz) = deb3a960c1d55868dfbcac98432358b92ba89d95029cddd4040db1f27405055c
+SIZE (pathlib2-2.1.0.tar.gz) = 30390
diff --git a/devel/py-pathlib2/pkg-descr b/devel/py-pathlib2/pkg-descr
new file mode 100644
index 000000000000..a47bedffa560
--- /dev/null
+++ b/devel/py-pathlib2/pkg-descr
@@ -0,0 +1,5 @@
+Backport of standard pathlib module which tracks the standard library module,
+so all the newest features of the standard pathlib can be used also on older
+Python versions.
+
+WWW: https://pypi.python.org/pypi/pathlib2/