aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-01 17:55:36 +0800
committerMartin Wilke <miwi@FreeBSD.org>2007-03-01 17:55:36 +0800
commitef1797d07deae150b7d309065c94a60076014504 (patch)
tree8ff4ac649e9df327cf50bdcc36de51840ef09b27 /devel
parentef791aa1bf803fa475c903309afaad53e39440ad (diff)
downloadfreebsd-ports-gnome-ef1797d07deae150b7d309065c94a60076014504.tar.gz
freebsd-ports-gnome-ef1797d07deae150b7d309065c94a60076014504.tar.zst
freebsd-ports-gnome-ef1797d07deae150b7d309065c94a60076014504.zip
pp is a python module which provides mechanism for parallel execution of
python code on SMP (systems with multiple processors or cores) and clusters (computers connected via network) It is light, easy to install and integrate with other python software. pp is an open source and cross-platform module written in pure python WWW: http://www.parallelpython.com/ PR: ports/109665 Submitted by: Li-Wen Hsu <lwhsu at lwhsu.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pp/Makefile26
-rw-r--r--devel/py-pp/distinfo3
-rw-r--r--devel/py-pp/pkg-descr9
-rw-r--r--devel/py-pp/pkg-plist13
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 83bbeeb8c907..c5e84580d8bb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1809,6 +1809,7 @@
SUBDIR += py-plex
SUBDIR += py-ply
SUBDIR += py-pmock
+ SUBDIR += py-pp
SUBDIR += py-pqueue
SUBDIR += py-protocols
SUBDIR += py-protocols-devel
diff --git a/devel/py-pp/Makefile b/devel/py-pp/Makefile
new file mode 100644
index 000000000000..879c9f96963f
--- /dev/null
+++ b/devel/py-pp/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-pp
+# Date created: Feb. 28, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pp
+PORTVERSION= 1.3.2
+CATEGORIES= devel python
+MASTER_SITES= http://www.parallelpython.com/downloads/pp/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Parallel python execution server
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,^#!/usr/bin/python,#!${PYTHON_CMD},' ${WRKSRC}/ppserver.py
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ppserver.py ${TARGETDIR}/bin/
+
+.include <bsd.port.mk>
diff --git a/devel/py-pp/distinfo b/devel/py-pp/distinfo
new file mode 100644
index 000000000000..ab1418596bf0
--- /dev/null
+++ b/devel/py-pp/distinfo
@@ -0,0 +1,3 @@
+MD5 (pp-1.3.2.tar.gz) = 1cd0692877a5b19dcc9d4a40aea7ef4d
+SHA256 (pp-1.3.2.tar.gz) = 3dff3acad3a16a87ecba7e557afc2b7d55c5692e71c67a6d60972f8a549e64b7
+SIZE (pp-1.3.2.tar.gz) = 9024
diff --git a/devel/py-pp/pkg-descr b/devel/py-pp/pkg-descr
new file mode 100644
index 000000000000..601d486b6bc0
--- /dev/null
+++ b/devel/py-pp/pkg-descr
@@ -0,0 +1,9 @@
+pp is a python module which provides mechanism for parallel execution of
+python code on SMP (systems with multiple processors or cores) and clusters
+(computers connected via network)
+
+It is light, easy to install and integrate with other python software.
+
+pp is an open source and cross-platform module written in pure python
+
+WWW: http://www.parallelpython.com/
diff --git a/devel/py-pp/pkg-plist b/devel/py-pp/pkg-plist
new file mode 100644
index 000000000000..b5f9991901f9
--- /dev/null
+++ b/devel/py-pp/pkg-plist
@@ -0,0 +1,13 @@
+bin/ppserver.py
+%%PYTHON_SITELIBDIR%%/pp.py
+%%PYTHON_SITELIBDIR%%/pp.pyc
+%%PYTHON_SITELIBDIR%%/pp.pyo
+%%PYTHON_SITELIBDIR%%/ppserver.py
+%%PYTHON_SITELIBDIR%%/ppserver.pyc
+%%PYTHON_SITELIBDIR%%/ppserver.pyo
+%%PYTHON_SITELIBDIR%%/pptransport.py
+%%PYTHON_SITELIBDIR%%/pptransport.pyc
+%%PYTHON_SITELIBDIR%%/pptransport.pyo
+%%PYTHON_SITELIBDIR%%/ppworker.py
+%%PYTHON_SITELIBDIR%%/ppworker.pyc
+%%PYTHON_SITELIBDIR%%/ppworker.pyo