aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-06-09 20:53:52 +0800
committererwin <erwin@FreeBSD.org>2006-06-09 20:53:52 +0800
commitf2af6a0ecc6975f82de7b0f27fdaab367bf041f0 (patch)
treebb6d9d0768ac3dbb325d557cae355397fbba2f61 /devel
parent63ef3af77472d89b81f9fd4a3af4ff65abc3ba49 (diff)
downloadfreebsd-ports-gnome-f2af6a0ecc6975f82de7b0f27fdaab367bf041f0.tar.gz
freebsd-ports-gnome-f2af6a0ecc6975f82de7b0f27fdaab367bf041f0.tar.zst
freebsd-ports-gnome-f2af6a0ecc6975f82de7b0f27fdaab367bf041f0.zip
This module exports a clone() function which unlocks the builtin
functionality perl uses to clone a new interpreter and its values. WWW: http://search.cpan.org/dist/Scalar-Util-Clone/ PR: ports/98735 Submitted by: Zach Thompson <hideo@lastamericanempire.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Scalar-Util-Clone/Makefile34
-rw-r--r--devel/p5-Scalar-Util-Clone/distinfo3
-rw-r--r--devel/p5-Scalar-Util-Clone/pkg-descr4
-rw-r--r--devel/p5-Scalar-Util-Clone/pkg-plist9
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bf7884a40bc5..06375a4676b1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1209,6 +1209,7 @@
SUBDIR += p5-SVN-Notify
SUBDIR += p5-SVN-Simple
SUBDIR += p5-SVN-Web
+ SUBDIR += p5-Scalar-Util-Clone
SUBDIR += p5-Search-Binary
SUBDIR += p5-Set-Array
SUBDIR += p5-Set-Crontab
diff --git a/devel/p5-Scalar-Util-Clone/Makefile b/devel/p5-Scalar-Util-Clone/Makefile
new file mode 100644
index 000000000000..45057c392c6f
--- /dev/null
+++ b/devel/p5-Scalar-Util-Clone/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: devel/p5-Scalar-Util-Clone
+# Date created: 08 June 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Scalar-Util-Clone
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Scalar
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Recursively copy datatypes using Perl's builtin functions
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Scalar::Util::Clone.3
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @${PERL} -pi -e '$$_ = undef if /''OPTIMIZE''/' ${WRKSRC}/Makefile.PL
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Scalar-Util-Clone/distinfo b/devel/p5-Scalar-Util-Clone/distinfo
new file mode 100644
index 000000000000..f0355b12ef5a
--- /dev/null
+++ b/devel/p5-Scalar-Util-Clone/distinfo
@@ -0,0 +1,3 @@
+MD5 (Scalar-Util-Clone-0.04.tar.gz) = 466d571e224cc3df608a65ddeaaea5df
+SHA256 (Scalar-Util-Clone-0.04.tar.gz) = 4b8f9efd79f8346c87d8eac0953b64cb8edc56feb9cddd2e354b61070ecd430b
+SIZE (Scalar-Util-Clone-0.04.tar.gz) = 40933
diff --git a/devel/p5-Scalar-Util-Clone/pkg-descr b/devel/p5-Scalar-Util-Clone/pkg-descr
new file mode 100644
index 000000000000..a228b9351840
--- /dev/null
+++ b/devel/p5-Scalar-Util-Clone/pkg-descr
@@ -0,0 +1,4 @@
+This module exports a clone() function which unlocks the builtin
+functionality perl uses to clone a new interpreter and its values.
+
+WWW: http://search.cpan.org/dist/Scalar-Util-Clone/
diff --git a/devel/p5-Scalar-Util-Clone/pkg-plist b/devel/p5-Scalar-Util-Clone/pkg-plist
new file mode 100644
index 000000000000..7009d28f8561
--- /dev/null
+++ b/devel/p5-Scalar-Util-Clone/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Scalar/Util/Clone.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Util/Clone/Clone.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Util/Clone/Clone.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Util/Clone/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Scalar/Util
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Scalar
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Util/Clone
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Util/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar