aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-03-28 06:29:00 +0800
committertobik <tobik@FreeBSD.org>2018-03-28 06:29:00 +0800
commitf46ede90e457acb9c8ea20ab2ab0df61fc19dea7 (patch)
tree2cf962d9a7db1817730451fb09333b419ed32d2e /devel
parent49015d4a1583d5615ea0a7145d5cef4e01926040 (diff)
downloadfreebsd-ports-gnome-f46ede90e457acb9c8ea20ab2ab0df61fc19dea7.tar.gz
freebsd-ports-gnome-f46ede90e457acb9c8ea20ab2ab0df61fc19dea7.tar.zst
freebsd-ports-gnome-f46ede90e457acb9c8ea20ab2ab0df61fc19dea7.zip
devel/woff2: Improve port quality
- Install converter tools - Provide an actual comment and description Based on the initial new port submission from Greg that I missed earlier. PR: 226165 Submitted by: greg@unrelenting.technology
Diffstat (limited to 'devel')
-rw-r--r--devel/woff2/Makefile6
-rw-r--r--devel/woff2/files/patch-CMakeLists.txt11
-rw-r--r--devel/woff2/pkg-descr4
-rw-r--r--devel/woff2/pkg-plist3
4 files changed, 21 insertions, 3 deletions
diff --git a/devel/woff2/Makefile b/devel/woff2/Makefile
index 0b3725286a72..6830b1c62e7b 100644
--- a/devel/woff2/Makefile
+++ b/devel/woff2/Makefile
@@ -3,19 +3,21 @@
PORTNAME= woff2
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= tobik@FreeBSD.org
-COMMENT= Font compression reference code
+COMMENT= Library and converter tools for the WOFF 2.0 web font format
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libbrotlidec.so:archivers/brotli
-USES= cmake
+USES= cmake:outsource
USE_GITHUB= yes
GH_ACCOUNT= google
+USE_LDCONFIG= yes
PLIST_SUB= SHLIBVER=${DISTVERSION}
diff --git a/devel/woff2/files/patch-CMakeLists.txt b/devel/woff2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..af81cf08ad8a
--- /dev/null
+++ b/devel/woff2/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-03-27 22:12:33 UTC
++++ CMakeLists.txt
+@@ -268,7 +268,7 @@ if (NOT BUILD_SHARED_LIBS)
+ endif()
+
+ install(
+- TARGETS woff2common woff2dec woff2enc
++ TARGETS woff2common woff2dec woff2enc woff2_decompress woff2_compress woff2_info
+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}"
+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}"
diff --git a/devel/woff2/pkg-descr b/devel/woff2/pkg-descr
index f0a466b5e74d..117281d3f59a 100644
--- a/devel/woff2/pkg-descr
+++ b/devel/woff2/pkg-descr
@@ -1,3 +1,5 @@
-Font compression reference code
+The reference implementation of the Web Open Font Format 2.0, including
+libraries for decoding and encoding fonts, and command line utilities
+to convert between TTF and WOFF2.
WWW: https://github.com/google/woff2
diff --git a/devel/woff2/pkg-plist b/devel/woff2/pkg-plist
index 9a4fb46ac9b5..0bc2fe227707 100644
--- a/devel/woff2/pkg-plist
+++ b/devel/woff2/pkg-plist
@@ -1,3 +1,6 @@
+bin/woff2_compress
+bin/woff2_decompress
+bin/woff2_info
include/woff2/decode.h
include/woff2/encode.h
include/woff2/output.h