aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-01-11 06:04:32 +0800
committerlofi <lofi@FreeBSD.org>2005-01-11 06:04:32 +0800
commitf5c9798d5bc1b93f3f17203c588c628e70a47a6d (patch)
tree02cf5f96970220515641c3ba3e3136ad16e05aac /devel
parentacd5a23a5d4bdb9e9996548889f6c5c888656243 (diff)
downloadfreebsd-ports-gnome-f5c9798d5bc1b93f3f17203c588c628e70a47a6d.tar.gz
freebsd-ports-gnome-f5c9798d5bc1b93f3f17203c588c628e70a47a6d.tar.zst
freebsd-ports-gnome-f5c9798d5bc1b93f3f17203c588c628e70a47a6d.zip
Don't restrict ports depending on py-qt to python 2.3 anymore.
Diffstat (limited to 'devel')
-rw-r--r--devel/eric/Makefile3
-rw-r--r--devel/kodos/Makefile3
-rw-r--r--devel/py-sip/Makefile4
3 files changed, 6 insertions, 4 deletions
diff --git a/devel/eric/Makefile b/devel/eric/Makefile
index 8fe59edd94d7..7cdd20ea810c 100644
--- a/devel/eric/Makefile
+++ b/devel/eric/Makefile
@@ -7,6 +7,7 @@
PORTNAME= eric
PORTVERSION= 3.3.1
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://www.die-offenbachs.de/detlev/files/
@@ -17,7 +18,7 @@ BUILD_DEPENDS= ${X11BASE}/lib/libqscintilla.so:${PORTSDIR}/x11-toolkits/qscintil
${LOCALBASE}/bin/sip:${PORTSDIR}/devel/py-sip\
pyuic:${PORTSDIR}/x11-toolkits/py-qt
-USE_PYTHON= 2.3
+USE_PYTHON= yes
USE_REINPLACE= yes
NO_BUILD= yes
diff --git a/devel/kodos/Makefile b/devel/kodos/Makefile
index b8a76f0c1e82..dd5bc807edb6 100644
--- a/devel/kodos/Makefile
+++ b/devel/kodos/Makefile
@@ -9,6 +9,7 @@
PORTNAME= kodos
PORTVERSION= 2.4.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +20,7 @@ COMMENT= The Python Regular Expression Debugger
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/qt.so:${PORTSDIR}/x11-toolkits/py-qt
USE_REINPLACE= yes
-USE_PYTHON= 1.5-2.3
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
PLIST_FILES= bin/kodos ${PYTHON_SITELIBDIR:S,^${PREFIX}/,,}/kodos.pth
diff --git a/devel/py-sip/Makefile b/devel/py-sip/Makefile
index 02441006e18d..a33bb355d5d9 100644
--- a/devel/py-sip/Makefile
+++ b/devel/py-sip/Makefile
@@ -6,7 +6,7 @@
PORTNAME= sip
PORTVERSION= 4.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= http://www.river-bank.demon.co.uk/download/sip/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +16,7 @@ COMMENT= Python to C and C++ bindings generator
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-USE_PYTHON= 2.3
+USE_PYTHON= yes
USE_QT_VER= 3
.include <bsd.port.pre.mk>