aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-03 01:31:10 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-03 01:31:10 +0800
commitf6043f637474700d4e8433ce436650d55351ea33 (patch)
tree8f2f3a4c4a73604e0857b4af25a536a915d82fed /devel
parent293b389458824a57a71bfc91be750d0660998f70 (diff)
downloadfreebsd-ports-gnome-f6043f637474700d4e8433ce436650d55351ea33.tar.gz
freebsd-ports-gnome-f6043f637474700d4e8433ce436650d55351ea33.tar.zst
freebsd-ports-gnome-f6043f637474700d4e8433ce436650d55351ea33.zip
- Add LICENSE
- Strip shared library - Support STAGEDIR - While I'm here, move pkg-message to Makefile otherwise it'll be printed after installation PR: ports/184438 Submitted by: Rodrigo Osorio <rodrigo@bebik.net> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/libtap/Makefile20
-rw-r--r--devel/libtap/pkg-message8
-rw-r--r--devel/libtap/pkg-plist1
3 files changed, 15 insertions, 14 deletions
diff --git a/devel/libtap/Makefile b/devel/libtap/Makefile
index 00590cedf147..615ff251522e 100644
--- a/devel/libtap/Makefile
+++ b/devel/libtap/Makefile
@@ -5,22 +5,30 @@ PORTNAME= libtap
PORTVERSION= 1.01
PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= nik
+MASTER_SITES= LOCAL/nik
DISTNAME= tap-${PORTVERSION}
MAINTAINER= rodrigo@bebik.net
COMMENT= Library implementing the Test Anything Protocol
+LICENSE= BSD
+
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-MAN3= tap.3
-
-NO_STAGE= yes
post-build:
- @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} "If you have Perl and Test::Harness installed you can run the test suite"
+ @${ECHO_MSG} "for libtap by running"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " make check"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "or"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " prove -r"
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtap.so
check:
(cd ${WRKSRC}; ${MAKE} check)
diff --git a/devel/libtap/pkg-message b/devel/libtap/pkg-message
deleted file mode 100644
index 3247a2b3bf1f..000000000000
--- a/devel/libtap/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-If you have Perl and Test::Harness installed you can run the test suite
-for libtap by running
-
- make check
-
-or
-
- prove -r
diff --git a/devel/libtap/pkg-plist b/devel/libtap/pkg-plist
index 139a1effe876..7368633ddc79 100644
--- a/devel/libtap/pkg-plist
+++ b/devel/libtap/pkg-plist
@@ -3,3 +3,4 @@ lib/libtap.a
lib/libtap.la
lib/libtap.so
lib/libtap.so.0
+man/man3/tap.3.gz