aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-03-13 22:55:35 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-03-13 22:55:35 +0800
commitf692026f1e05a1b1fd288afcf0f3039ebb7f8622 (patch)
treeb49bf77e46f19af64ddab7912fbb5b3e366e52aa /devel
parentab82cb76b1eb3420291e746f5697a69e86d4c481 (diff)
downloadfreebsd-ports-gnome-f692026f1e05a1b1fd288afcf0f3039ebb7f8622.tar.gz
freebsd-ports-gnome-f692026f1e05a1b1fd288afcf0f3039ebb7f8622.tar.zst
freebsd-ports-gnome-f692026f1e05a1b1fd288afcf0f3039ebb7f8622.zip
- Add p5-Git-Version-Compare 1.001
Git::Version::Compare contains a selection of subroutines that make dealing with Git-related things (like versions) a little bit easier. The strings to compare can be version numbers, tags from git.git or the output of git version or git describe. These routines collect the knowledge about Git versions that was accumulated while developing Git::Repository. WWW: http://search.cpan.org/dist/Git-Version-Compare/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Git-Version-Compare/Makefile24
-rw-r--r--devel/p5-Git-Version-Compare/distinfo2
-rw-r--r--devel/p5-Git-Version-Compare/pkg-descr10
-rw-r--r--devel/p5-Git-Version-Compare/pkg-plist2
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e23de7767474..2ec0cc9deb65 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2371,6 +2371,7 @@
SUBDIR += p5-Git-Repository
SUBDIR += p5-Git-Repository-Plugin-Log
SUBDIR += p5-Git-Sub
+ SUBDIR += p5-Git-Version-Compare
SUBDIR += p5-Git-Wrapper
SUBDIR += p5-Glib-Object-Introspection
SUBDIR += p5-Glib2
diff --git a/devel/p5-Git-Version-Compare/Makefile b/devel/p5-Git-Version-Compare/Makefile
new file mode 100644
index 000000000000..e90da94a9712
--- /dev/null
+++ b/devel/p5-Git-Version-Compare/Makefile
@@ -0,0 +1,24 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Git-Version-Compare
+PORTVERSION= 1.001
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Functions to compare Git versions
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Git-Version-Compare/distinfo b/devel/p5-Git-Version-Compare/distinfo
new file mode 100644
index 000000000000..8bab476d3a01
--- /dev/null
+++ b/devel/p5-Git-Version-Compare/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Git-Version-Compare-1.001.tar.gz) = 1ffb4450b6dc445a705bfb174a29827169bf1f7094ae2cb88e94e54bdf95c7d1
+SIZE (Git-Version-Compare-1.001.tar.gz) = 17313
diff --git a/devel/p5-Git-Version-Compare/pkg-descr b/devel/p5-Git-Version-Compare/pkg-descr
new file mode 100644
index 000000000000..92860d84e147
--- /dev/null
+++ b/devel/p5-Git-Version-Compare/pkg-descr
@@ -0,0 +1,10 @@
+Git::Version::Compare contains a selection of subroutines that make dealing with
+Git-related things (like versions) a little bit easier.
+
+The strings to compare can be version numbers, tags from git.git or the output
+of git version or git describe.
+
+These routines collect the knowledge about Git versions that was accumulated
+while developing Git::Repository.
+
+WWW: http://search.cpan.org/dist/Git-Version-Compare/
diff --git a/devel/p5-Git-Version-Compare/pkg-plist b/devel/p5-Git-Version-Compare/pkg-plist
new file mode 100644
index 000000000000..d71d182395a7
--- /dev/null
+++ b/devel/p5-Git-Version-Compare/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Git/Version/Compare.pm
+%%PERL5_MAN3%%/Git::Version::Compare.3.gz