aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-02-02 17:27:42 +0800
committerkoobs <koobs@FreeBSD.org>2014-02-02 17:27:42 +0800
commitf6b28e08b380c4602e1d53aeca81d6a3e1cd587d (patch)
treefdcb0d8d731be7b5d7614534db933ec5a71ab77a /devel
parent9e5224f352dc8eaa807ff7bcb12b4c533560d33f (diff)
downloadfreebsd-ports-gnome-f6b28e08b380c4602e1d53aeca81d6a3e1cd587d.tar.gz
freebsd-ports-gnome-f6b28e08b380c4602e1d53aeca81d6a3e1cd587d.tar.zst
freebsd-ports-gnome-f6b28e08b380c4602e1d53aeca81d6a3e1cd587d.zip
devel/py-tapi: Framework for testing APIs [NEW PORT]
Tapi is a tool to automate the testing of your Application Programmer Interfaces (APIs). Features: * Test you API without writing any code (only edit a json file) * Test you APIs in a much more 'natural' way by specifying urls/verbs and what the output should be * Verify anything from response status codes, headers, body content etc * Also allows verification by issuing another API call to a different endpoint to ensure a prior API call worked * Execute arbitrary python scripts to populate request paramaters e.g. custom headers * Execute arbitrary python scripts to verify response from endpoint is valid * Tests your APIs using your own APIs WWW: https://github.com/jimmyislive/tapi/ PR: ports/186342 Submitted by: Johannes Jost Meixner <xmj@chaot.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-tapi/Makefile20
-rw-r--r--devel/py-tapi/distinfo2
-rw-r--r--devel/py-tapi/pkg-descr15
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 731254b9b45e..83ec76a1a331 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3807,6 +3807,7 @@
SUBDIR += py-sysctl
SUBDIR += py-sysv_ipc
SUBDIR += py-tables
+ SUBDIR += py-tapi
SUBDIR += py-tarantool-queue
SUBDIR += py-tconfpy
SUBDIR += py-tempstorage
diff --git a/devel/py-tapi/Makefile b/devel/py-tapi/Makefile
new file mode 100644
index 000000000000..38617f3a740a
--- /dev/null
+++ b/devel/py-tapi/Makefile
@@ -0,0 +1,20 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= tapi
+PORTVERSION= 0.1.7
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Tapi-${PORTVERSION}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Framework for testing APIs
+
+LICENSE= MIT
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-tapi/distinfo b/devel/py-tapi/distinfo
new file mode 100644
index 000000000000..37984f6f2074
--- /dev/null
+++ b/devel/py-tapi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Tapi-0.1.7.tar.gz) = 32dba29d491bde3b68c6678f85d6adcbc50ffbfed44a88f4b1fff4991c337bd7
+SIZE (Tapi-0.1.7.tar.gz) = 7567
diff --git a/devel/py-tapi/pkg-descr b/devel/py-tapi/pkg-descr
new file mode 100644
index 000000000000..ea4093b8b8c2
--- /dev/null
+++ b/devel/py-tapi/pkg-descr
@@ -0,0 +1,15 @@
+Tapi is a tool to automate the testing of your Application Programmer Interfaces
+(APIs). Features:
+
+- Test you API without writing any code (only edit a json file)
+- Test you APIs in a much more 'natural' way by specifying urls/verbs and what
+ the output should be
+- Verify anything from response status codes, headers, body content etc
+- Also allows verification by issuing another API call to a different endpoint
+ to ensure a prior API call worked
+- Execute arbitrary python scripts to populate request paramaters e.g. custom
+ headers
+- Execute arbitrary python scripts to verify response from endpoint is valid
+- Tests your APIs using your own APIs
+
+WWW: https://github.com/jimmyislive/tapi/