aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-19 06:50:19 +0800
committerpgj <pgj@FreeBSD.org>2012-02-19 06:50:19 +0800
commitf6b3c87ef6b9aef87d3a3789accf70a933242097 (patch)
tree062dc789989bade1120e733d181a5b69bfb67c44 /devel
parent95d0479dda1c86a0c3e81cfa072d26dc6eba6616 (diff)
downloadfreebsd-ports-gnome-f6b3c87ef6b9aef87d3a3789accf70a933242097.tar.gz
freebsd-ports-gnome-f6b3c87ef6b9aef87d3a3789accf70a933242097.tar.zst
freebsd-ports-gnome-f6b3c87ef6b9aef87d3a3789accf70a933242097.zip
ThreadScope is a graphical viewer for thread profile information
generated by the Glasgow Haskell Compiler (GHC). The ThreadScope program allows us to debug the parallel performance of Haskell programs. Using Threadscope we can check to see that work is well balanced across the available processors and spot performance issues relating to garbage collection or poor load balancing. WWW: http://hackage.haskell.org/package/threadscope Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-threadscope/Makefile26
-rw-r--r--devel/hs-threadscope/distinfo2
-rw-r--r--devel/hs-threadscope/files/patch-GUI__Main.hs10
-rw-r--r--devel/hs-threadscope/files/patch-GUI__Timeline__Render.hs11
-rw-r--r--devel/hs-threadscope/pkg-descr9
6 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 991cd77db70c..c92580f36d18 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -687,6 +687,7 @@
SUBDIR += hs-test-framework-quickcheck2
SUBDIR += hs-testpack
SUBDIR += hs-text
+ SUBDIR += hs-threadscope
SUBDIR += hs-transformers
SUBDIR += hs-transformers-base
SUBDIR += hs-transformers-docs
diff --git a/devel/hs-threadscope/Makefile b/devel/hs-threadscope/Makefile
new file mode 100644
index 000000000000..7b02963abb3f
--- /dev/null
+++ b/devel/hs-threadscope/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: hs-threadscope
+# Date created: December 6, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= threadscope
+PORTVERSION= 0.2.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A graphical tool for profiling parallel Haskell programs
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= binary cairo deepseq>=1.1 ghc-events>=0.3 glib gtk>=0.12 \
+ gtk2hs-buildtools mtl pango
+
+EXECUTABLE= threadscope
+STANDALONE= yes
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-threadscope/distinfo b/devel/hs-threadscope/distinfo
new file mode 100644
index 000000000000..4d1d17355fb2
--- /dev/null
+++ b/devel/hs-threadscope/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/threadscope-0.2.1.tar.gz) = afd7c9c3443c2f24b96c4d643893576e473a1006c99ede245e2f8ff1f8724923
+SIZE (cabal/threadscope-0.2.1.tar.gz) = 67264
diff --git a/devel/hs-threadscope/files/patch-GUI__Main.hs b/devel/hs-threadscope/files/patch-GUI__Main.hs
new file mode 100644
index 000000000000..e6d2e694f4d0
--- /dev/null
+++ b/devel/hs-threadscope/files/patch-GUI__Main.hs
@@ -0,0 +1,10 @@
+--- ./GUI/Main.hs.orig 2011-09-05 04:33:21.000000000 +0200
++++ ./GUI/Main.hs 2011-12-07 01:27:00.000000000 +0100
+@@ -79,7 +79,6 @@
+ | EventFileReload
+ | EventFileExport FilePath FileExportFormat
+
+--- | EventStateClear
+ | EventSetState HECs (Maybe FilePath) String Int Double
+
+ | EventShowSidebar Bool
diff --git a/devel/hs-threadscope/files/patch-GUI__Timeline__Render.hs b/devel/hs-threadscope/files/patch-GUI__Timeline__Render.hs
new file mode 100644
index 000000000000..4136bc29984c
--- /dev/null
+++ b/devel/hs-threadscope/files/patch-GUI__Timeline__Render.hs
@@ -0,0 +1,11 @@
+--- ./GUI/Timeline/Render.hs.orig 2011-12-07 01:21:24.000000000 +0100
++++ ./GUI/Timeline/Render.hs 2011-12-07 01:24:29.000000000 +0100
+@@ -91,7 +91,7 @@
+ region exposeRegion
+ clip
+ setSourceSurface surface 0 (-vadj_value)
+- -- ^^ this is where we adjust for the vertical scrollbar
++ -- this is where we adjust for the vertical scrollbar
+ setOperator OperatorSource
+ paint
+ when (scaleValue params > 0) $ do
diff --git a/devel/hs-threadscope/pkg-descr b/devel/hs-threadscope/pkg-descr
new file mode 100644
index 000000000000..10b8c7aa0d2e
--- /dev/null
+++ b/devel/hs-threadscope/pkg-descr
@@ -0,0 +1,9 @@
+ThreadScope is a graphical viewer for thread profile information
+generated by the Glasgow Haskell Compiler (GHC).
+
+The ThreadScope program allows us to debug the parallel performance of
+Haskell programs. Using Threadscope we can check to see that work is
+well balanced across the available processors and spot performance
+issues relating to garbage collection or poor load balancing.
+
+WWW: http://hackage.haskell.org/package/threadscope