aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2018-02-19 21:06:40 +0800
committermadpilot <madpilot@FreeBSD.org>2018-02-19 21:06:40 +0800
commitf6b41c62fea625e84b2b8857c73120b17486412d (patch)
tree50bdac1b9c8654ada306976d83988ad0af2dd30c /devel
parent5fa334bf411325161dae81275a3412184b636c59 (diff)
downloadfreebsd-ports-gnome-f6b41c62fea625e84b2b8857c73120b17486412d.tar.gz
freebsd-ports-gnome-f6b41c62fea625e84b2b8857c73120b17486412d.tar.zst
freebsd-ports-gnome-f6b41c62fea625e84b2b8857c73120b17486412d.zip
- Disable building the test suite by default to avoid conflict with
devel/googletest [1] - Add option TEST(disabled by default) allowing interested users to install the testing suite and register conflict with devel/googletest when enabled - While here silence portling warning PR: 225999 [1] Submitted by: Rainer Hurling <rhurlin@gwdg.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/yaml-cpp/Makefile13
-rw-r--r--devel/yaml-cpp/pkg-plist110
2 files changed, 65 insertions, 58 deletions
diff --git a/devel/yaml-cpp/Makefile b/devel/yaml-cpp/Makefile
index 82ea7691abeb..76d63bee630f 100644
--- a/devel/yaml-cpp/Makefile
+++ b/devel/yaml-cpp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= yaml-cpp
PORTVERSION= 0.6.1
+PORTREVISION= 1
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= devel
@@ -12,11 +13,17 @@ COMMENT= YAML parser and emitter in C++ matching the YAML 1.2 spec
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_GITHUB= yes
-GH_ACCOUNT= jbeder
-
USES= cmake
USE_LDCONFIG= yes
CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON -DYAML_CPP_BUILD_TOOLS=0
+OPTIONS_DEFINE= TEST
+OPTIONS_SUB= yes
+
+TEST_CMAKE_BOOL= YAML_CPP_BUILD_TESTS
+TEST_CONFLICTS_INSTALL= googletest
+
+USE_GITHUB= yes
+GH_ACCOUNT= jbeder
+
.include <bsd.port.mk>
diff --git a/devel/yaml-cpp/pkg-plist b/devel/yaml-cpp/pkg-plist
index a0e9f41ea60e..092bc896950a 100644
--- a/devel/yaml-cpp/pkg-plist
+++ b/devel/yaml-cpp/pkg-plist
@@ -1,54 +1,54 @@
-include/gmock/gmock-actions.h
-include/gmock/gmock-cardinalities.h
-include/gmock/gmock-generated-actions.h
-include/gmock/gmock-generated-actions.h.pump
-include/gmock/gmock-generated-function-mockers.h
-include/gmock/gmock-generated-function-mockers.h.pump
-include/gmock/gmock-generated-matchers.h
-include/gmock/gmock-generated-matchers.h.pump
-include/gmock/gmock-generated-nice-strict.h
-include/gmock/gmock-generated-nice-strict.h.pump
-include/gmock/gmock-matchers.h
-include/gmock/gmock-more-actions.h
-include/gmock/gmock-more-matchers.h
-include/gmock/gmock-spec-builders.h
-include/gmock/gmock.h
-include/gmock/internal/custom/gmock-generated-actions.h
-include/gmock/internal/custom/gmock-generated-actions.h.pump
-include/gmock/internal/custom/gmock-matchers.h
-include/gmock/internal/custom/gmock-port.h
-include/gmock/internal/gmock-generated-internal-utils.h
-include/gmock/internal/gmock-generated-internal-utils.h.pump
-include/gmock/internal/gmock-internal-utils.h
-include/gmock/internal/gmock-port.h
-include/gtest/gtest-death-test.h
-include/gtest/gtest-message.h
-include/gtest/gtest-param-test.h
-include/gtest/gtest-param-test.h.pump
-include/gtest/gtest-printers.h
-include/gtest/gtest-spi.h
-include/gtest/gtest-test-part.h
-include/gtest/gtest-typed-test.h
-include/gtest/gtest.h
-include/gtest/gtest_pred_impl.h
-include/gtest/gtest_prod.h
-include/gtest/internal/custom/gtest-port.h
-include/gtest/internal/custom/gtest-printers.h
-include/gtest/internal/custom/gtest.h
-include/gtest/internal/gtest-death-test-internal.h
-include/gtest/internal/gtest-filepath.h
-include/gtest/internal/gtest-internal.h
-include/gtest/internal/gtest-linked_ptr.h
-include/gtest/internal/gtest-param-util-generated.h
-include/gtest/internal/gtest-param-util-generated.h.pump
-include/gtest/internal/gtest-param-util.h
-include/gtest/internal/gtest-port-arch.h
-include/gtest/internal/gtest-port.h
-include/gtest/internal/gtest-string.h
-include/gtest/internal/gtest-tuple.h
-include/gtest/internal/gtest-tuple.h.pump
-include/gtest/internal/gtest-type-util.h
-include/gtest/internal/gtest-type-util.h.pump
+%%TEST%%include/gmock/gmock-actions.h
+%%TEST%%include/gmock/gmock-cardinalities.h
+%%TEST%%include/gmock/gmock-generated-actions.h
+%%TEST%%include/gmock/gmock-generated-actions.h.pump
+%%TEST%%include/gmock/gmock-generated-function-mockers.h
+%%TEST%%include/gmock/gmock-generated-function-mockers.h.pump
+%%TEST%%include/gmock/gmock-generated-matchers.h
+%%TEST%%include/gmock/gmock-generated-matchers.h.pump
+%%TEST%%include/gmock/gmock-generated-nice-strict.h
+%%TEST%%include/gmock/gmock-generated-nice-strict.h.pump
+%%TEST%%include/gmock/gmock-matchers.h
+%%TEST%%include/gmock/gmock-more-actions.h
+%%TEST%%include/gmock/gmock-more-matchers.h
+%%TEST%%include/gmock/gmock-spec-builders.h
+%%TEST%%include/gmock/gmock.h
+%%TEST%%include/gmock/internal/custom/gmock-generated-actions.h
+%%TEST%%include/gmock/internal/custom/gmock-generated-actions.h.pump
+%%TEST%%include/gmock/internal/custom/gmock-matchers.h
+%%TEST%%include/gmock/internal/custom/gmock-port.h
+%%TEST%%include/gmock/internal/gmock-generated-internal-utils.h
+%%TEST%%include/gmock/internal/gmock-generated-internal-utils.h.pump
+%%TEST%%include/gmock/internal/gmock-internal-utils.h
+%%TEST%%include/gmock/internal/gmock-port.h
+%%TEST%%include/gtest/gtest-death-test.h
+%%TEST%%include/gtest/gtest-message.h
+%%TEST%%include/gtest/gtest-param-test.h
+%%TEST%%include/gtest/gtest-param-test.h.pump
+%%TEST%%include/gtest/gtest-printers.h
+%%TEST%%include/gtest/gtest-spi.h
+%%TEST%%include/gtest/gtest-test-part.h
+%%TEST%%include/gtest/gtest-typed-test.h
+%%TEST%%include/gtest/gtest.h
+%%TEST%%include/gtest/gtest_pred_impl.h
+%%TEST%%include/gtest/gtest_prod.h
+%%TEST%%include/gtest/internal/custom/gtest-port.h
+%%TEST%%include/gtest/internal/custom/gtest-printers.h
+%%TEST%%include/gtest/internal/custom/gtest.h
+%%TEST%%include/gtest/internal/gtest-death-test-internal.h
+%%TEST%%include/gtest/internal/gtest-filepath.h
+%%TEST%%include/gtest/internal/gtest-internal.h
+%%TEST%%include/gtest/internal/gtest-linked_ptr.h
+%%TEST%%include/gtest/internal/gtest-param-util-generated.h
+%%TEST%%include/gtest/internal/gtest-param-util-generated.h.pump
+%%TEST%%include/gtest/internal/gtest-param-util.h
+%%TEST%%include/gtest/internal/gtest-port-arch.h
+%%TEST%%include/gtest/internal/gtest-port.h
+%%TEST%%include/gtest/internal/gtest-string.h
+%%TEST%%include/gtest/internal/gtest-tuple.h
+%%TEST%%include/gtest/internal/gtest-tuple.h.pump
+%%TEST%%include/gtest/internal/gtest-type-util.h
+%%TEST%%include/gtest/internal/gtest-type-util.h.pump
include/yaml-cpp/anchor.h
include/yaml-cpp/binary.h
include/yaml-cpp/contrib/anchordict.h
@@ -90,10 +90,10 @@ lib/cmake/yaml-cpp/yaml-cpp-config-version.cmake
lib/cmake/yaml-cpp/yaml-cpp-config.cmake
lib/cmake/yaml-cpp/yaml-cpp-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/yaml-cpp/yaml-cpp-targets.cmake
-lib/libgmock.so
-lib/libgmock_main.so
-lib/libgtest.so
-lib/libgtest_main.so
+%%TEST%%lib/libgmock.so
+%%TEST%%lib/libgmock_main.so
+%%TEST%%lib/libgtest.so
+%%TEST%%lib/libgtest_main.so
lib/libyaml-cpp.so
lib/libyaml-cpp.so.0
lib/libyaml-cpp.so.0.6.0