aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-03-01 06:25:54 +0800
committerswills <swills@FreeBSD.org>2012-03-01 06:25:54 +0800
commitfa7aee96ee0fe0949a92dd0377c06351d4eb9397 (patch)
tree3b23c8f57ee019bffbdb7391436622170ad8789f /devel
parent6201dea58da6b9fc195344519764270872deb88c (diff)
downloadfreebsd-ports-gnome-fa7aee96ee0fe0949a92dd0377c06351d4eb9397.tar.gz
freebsd-ports-gnome-fa7aee96ee0fe0949a92dd0377c06351d4eb9397.tar.zst
freebsd-ports-gnome-fa7aee96ee0fe0949a92dd0377c06351d4eb9397.zip
Perl module that adds an AUTHORITY method to your class.
WWW: http://search.cpan.org/dist/Object-AUTHORITY/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Object-Authority/Makefile25
-rw-r--r--devel/p5-Object-Authority/distinfo2
-rw-r--r--devel/p5-Object-Authority/pkg-descr3
-rw-r--r--devel/p5-Object-Authority/pkg-plist3
5 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c45f54a21e58..49388c9f3144 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2180,6 +2180,7 @@
SUBDIR += p5-OOTools
SUBDIR += p5-Object-Accessor
SUBDIR += p5-Object-Array
+ SUBDIR += p5-Object-Authority
SUBDIR += p5-Object-Declare
SUBDIR += p5-Object-Destroyer
SUBDIR += p5-Object-Enum
diff --git a/devel/p5-Object-Authority/Makefile b/devel/p5-Object-Authority/Makefile
new file mode 100644
index 000000000000..66111e831a9d
--- /dev/null
+++ b/devel/p5-Object-Authority/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-object-authority
+# Date created: 2012-02-29
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Object-AUTHORITY
+PORTVERSION= 0.004
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl module that adds an AUTHORITY method to your class
+
+BUILD_DEPENDS= p5-Object-Role>=0:${PORTSDIR}/devel/p5-Object-Role
+RUN_DEPENDS= p5-Object-Role>=0:${PORTSDIR}/devel/p5-Object-Role
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+
+PERL_CONFIGURE= yes
+
+MAN3= Object::AUTHORITY.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Object-Authority/distinfo b/devel/p5-Object-Authority/distinfo
new file mode 100644
index 000000000000..6b6a0d01ea69
--- /dev/null
+++ b/devel/p5-Object-Authority/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Object-AUTHORITY-0.004.tar.gz) = 47734c174b2983ab30f525cad65f7255a1f31f805ad8ed66eba8f9efeb762c0f
+SIZE (Object-AUTHORITY-0.004.tar.gz) = 46142
diff --git a/devel/p5-Object-Authority/pkg-descr b/devel/p5-Object-Authority/pkg-descr
new file mode 100644
index 000000000000..3c3c27e31221
--- /dev/null
+++ b/devel/p5-Object-Authority/pkg-descr
@@ -0,0 +1,3 @@
+Perl module that adds an AUTHORITY method to your class.
+
+WWW: http://search.cpan.org/dist/Object-AUTHORITY/
diff --git a/devel/p5-Object-Authority/pkg-plist b/devel/p5-Object-Authority/pkg-plist
new file mode 100644
index 000000000000..36817011baf8
--- /dev/null
+++ b/devel/p5-Object-Authority/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Object/AUTHORITY.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Object/AUTHORITY/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Object/AUTHORITY