aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-09 21:10:09 +0800
committermiwi <miwi@FreeBSD.org>2009-02-09 21:10:09 +0800
commitfb32d0e13c102d196c7f8763567f6efb2b8d9a8e (patch)
tree75d385a0802f2840bdbc2965b57dc5ea70fda9c0 /devel
parent8590c45128c5fefe6b0514c5225a264dd8c254d2 (diff)
downloadfreebsd-ports-gnome-fb32d0e13c102d196c7f8763567f6efb2b8d9a8e.tar.gz
freebsd-ports-gnome-fb32d0e13c102d196c7f8763567f6efb2b8d9a8e.tar.zst
freebsd-ports-gnome-fb32d0e13c102d196c7f8763567f6efb2b8d9a8e.zip
rlock creates NFS safe lockfiles. it can optionally run a program while
holding the lock, ensuring lockfile removal on program exit. if a program is specified to be run rlock will spawn a background thread to kept the lockfile 'fresh' by touching it at a regular interval. in this way a lease is maintained on the lockfile and other processes attempting to obtain the lock can determine that it is in use. WWW: http://www.codeforpeople.com/lib/ruby/lockfile/ PR: ports/131023 Submitted by: Dennis Herrmann <adox at mcx2.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-lockfile/Makefile30
-rw-r--r--devel/rubygem-lockfile/distinfo3
-rw-r--r--devel/rubygem-lockfile/pkg-descr8
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bd279c469845..561031fa31b3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2498,6 +2498,7 @@
SUBDIR += rubygem-json
SUBDIR += rubygem-json_pure
SUBDIR += rubygem-linecache
+ SUBDIR += rubygem-lockfile
SUBDIR += rubygem-main
SUBDIR += rubygem-metaid
SUBDIR += rubygem-mocha
diff --git a/devel/rubygem-lockfile/Makefile b/devel/rubygem-lockfile/Makefile
new file mode 100644
index 000000000000..c359b4215e41
--- /dev/null
+++ b/devel/rubygem-lockfile/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: rubygem-lockfile
+# Date created: 2009-01-25
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lockfile
+PORTVERSION= 1.4.3
+CATEGORIES= devel rubygems
+MASTER_SITES= RF/codeforpeople
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A ruby library for creating NFS safe lockfiles
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+USE_RAKE= yes
+
+post-install:
+ @${ECHO} bin/rlock >> ${TMPPLIST}
+ @${ECHO} bin/rlock-${PORTVERSION} >> ${TMPPLIST}
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-lockfile/distinfo b/devel/rubygem-lockfile/distinfo
new file mode 100644
index 000000000000..bfae01972177
--- /dev/null
+++ b/devel/rubygem-lockfile/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/lockfile-1.4.3.gem) = 53a63206bbaefb7106db5a74a5adf148
+SHA256 (rubygem/lockfile-1.4.3.gem) = 63a9afc59c5084ebc46745d1f22e909c53d292d10c3e5f50d7bde891fbf6ab33
+SIZE (rubygem/lockfile-1.4.3.gem) = 19456
diff --git a/devel/rubygem-lockfile/pkg-descr b/devel/rubygem-lockfile/pkg-descr
new file mode 100644
index 000000000000..41124383ab7d
--- /dev/null
+++ b/devel/rubygem-lockfile/pkg-descr
@@ -0,0 +1,8 @@
+rlock creates NFS safe lockfiles. it can optionally run a program while
+holding the lock, ensuring lockfile removal on program exit. if a program
+is specified to be run rlock will spawn a background thread to kept the
+lockfile 'fresh' by touching it at a regular interval. in this way a lease
+is maintained on the lockfile and other processes attempting to obtain the
+lock can determine that it is in use.
+
+WWW: http://www.codeforpeople.com/lib/ruby/lockfile/