aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-07-01 13:42:55 +0800
committeraz <az@FreeBSD.org>2012-07-01 13:42:55 +0800
commitfe3a448ba66eb86df0ac94a0aebfbeb86cc59ab7 (patch)
tree05e35e823c6c0839698e5cbca1fb402d5046521c /devel
parent1012906806e6b8c0a4e2370861093f5cd51d2a52 (diff)
downloadfreebsd-ports-gnome-fe3a448ba66eb86df0ac94a0aebfbeb86cc59ab7.tar.gz
freebsd-ports-gnome-fe3a448ba66eb86df0ac94a0aebfbeb86cc59ab7.tar.zst
freebsd-ports-gnome-fe3a448ba66eb86df0ac94a0aebfbeb86cc59ab7.zip
- Remove SITE_PERL from *_DEPENDS
Approved by: portmgr@ (bapt@)
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-SVN-Mirror/Makefile18
-rw-r--r--devel/p5-VCP-Dest-svk/Makefile8
-rw-r--r--devel/pushmi/Makefile5
3 files changed, 16 insertions, 15 deletions
diff --git a/devel/p5-SVN-Mirror/Makefile b/devel/p5-SVN-Mirror/Makefile
index 85dc5d7a666e..1e7feb6b6a02 100644
--- a/devel/p5-SVN-Mirror/Makefile
+++ b/devel/p5-SVN-Mirror/Makefile
@@ -15,15 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= Mirror remote subversion repository to local
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
- ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
- ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/File/chdir.pm:${PORTSDIR}/devel/p5-File-chdir \
- ${SITE_PERL}/SVN/Simple/Edit.pm:${PORTSDIR}/devel/p5-SVN-Simple \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/VCP.pm:${PORTSDIR}/devel/p5-VCP-autrijus
+BUILD_DEPENDS= p5-Data-UUID>=0:${PORTSDIR}/devel/p5-Data-UUID \
+ p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-File-chdir>=0:${PORTSDIR}/devel/p5-File-chdir \
+ p5-SVN-Simple>=0:${PORTSDIR}/devel/p5-SVN-Simple \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-VCP-autrijus>=0:${PORTSDIR}/devel/p5-VCP-autrijus
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-VCP-Dest-svk/Makefile b/devel/p5-VCP-Dest-svk/Makefile
index a1e4df8f3015..b76319d1de0f 100644
--- a/devel/p5-VCP-Dest-svk/Makefile
+++ b/devel/p5-VCP-Dest-svk/Makefile
@@ -16,10 +16,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= rafan@FreeBSD.org
COMMENT= VCP destination driver for svn/svk
-BUILD_DEPENDS= ${SITE_PERL}/VCP.pm:${PORTSDIR}/devel/p5-VCP-autrijus \
- ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
- ${SITE_PERL}/SVK.pm:${PORTSDIR}/devel/svk \
- ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= p5-VCP-autrijus>=0:${PORTSDIR}/devel/p5-VCP-autrijus \
+ p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
+ svk>=0:${PORTSDIR}/devel/svk \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/pushmi/Makefile b/devel/pushmi/Makefile
index 16a3784aca7b..57e4320e3355 100644
--- a/devel/pushmi/Makefile
+++ b/devel/pushmi/Makefile
@@ -16,7 +16,7 @@ DISTNAME= Pushmi-v${PORTVERSION}
MAINTAINER= rafan@FreeBSD.org
COMMENT= Subversion repository replication tool
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
+RUN_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-App-CLI>=0.06:${PORTSDIR}/devel/p5-App-CLI \
p5-Cache-Memcached>=0:${PORTSDIR}/databases/p5-Cache-Memcached \
p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
@@ -27,9 +27,10 @@ BUILD_DEPENDS:= ${RUN_DEPENDS} \
p5-IPC-Run3>=0:${PORTSDIR}/devel/p5-IPC-Run3 \
p5-RunApp>=0.13:${PORTSDIR}/devel/p5-RunApp \
p5-Test-Output>=0:${PORTSDIR}/devel/p5-Test-Output \
- ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
+ ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2
PERL_CONFIGURE= yes
+USE_APACHE= 20+
MAN3= Pushmi.3 \
Pushmi::Command::Mirror.3 \