aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-07-17 06:57:23 +0800
committermarcus <marcus@FreeBSD.org>2005-07-17 06:57:23 +0800
commitff1fd55d242ba164ee979ee4dd2067ed62110e02 (patch)
tree689453c432f436cfaf06a3ac2d3068b23cfa60c0 /devel
parent2ffaef7f16258b133aa7e5550e73ae32dcf71b62 (diff)
downloadfreebsd-ports-gnome-ff1fd55d242ba164ee979ee4dd2067ed62110e02.tar.gz
freebsd-ports-gnome-ff1fd55d242ba164ee979ee4dd2067ed62110e02.tar.zst
freebsd-ports-gnome-ff1fd55d242ba164ee979ee4dd2067ed62110e02.zip
Gamin was using its own, debugging, versions of the g_list glib functions.
They were written to find problems in GList usage, but were causing gamin to segfault on 4.X. Disable debugging by default, and only use the debugging versions of g_list_* if debugging is enabled. Additionally, add <string.h> to gam_api.c which would certainly fix problems on 4.X alpha. Reported by: Stefan Thurner <thurners@nicsys.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/gamin/Makefile3
-rw-r--r--devel/gamin/files/patch-libgamin_gam_api.c18
-rw-r--r--devel/gamin/files/patch-server_gam_debug_lists.c17
3 files changed, 32 insertions, 6 deletions
diff --git a/devel/gamin/Makefile b/devel/gamin/Makefile
index 497c1151bfb5..f6513c33aff0 100644
--- a/devel/gamin/Makefile
+++ b/devel/gamin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gamin
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= http://www.gnome.org/~veillard/gamin/sources/
@@ -17,7 +18,7 @@ USE_GMAKE= yes
USE_GNOME?= gnomehack glib20
INSTALLS_SHLIB= yes
CONFIGURE_ARGS?=--disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
- --without-python
+ --without-python --disable-debug
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/devel/gamin/files/patch-libgamin_gam_api.c b/devel/gamin/files/patch-libgamin_gam_api.c
index 704f97866301..37a239537f3e 100644
--- a/devel/gamin/files/patch-libgamin_gam_api.c
+++ b/devel/gamin/files/patch-libgamin_gam_api.c
@@ -1,6 +1,14 @@
---- libgamin/gam_api.c.orig Thu May 19 20:40:13 2005
-+++ libgamin/gam_api.c Thu May 19 20:41:38 2005
-@@ -421,7 +421,7 @@
+--- libgamin/gam_api.c.orig Sat Jul 16 14:50:35 2005
++++ libgamin/gam_api.c Sat Jul 16 15:05:33 2005
+@@ -14,6 +14,7 @@
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ #include <sys/uio.h>
++#include <string.h>
+ #include "fam.h"
+ #include "gam_protocol.h"
+ #include "gam_data.h"
+@@ -421,7 +422,7 @@ gamin_write_credential_byte(int fd)
{
char data[2] = { 0, 0 };
int written;
@@ -9,7 +17,7 @@
struct {
struct cmsghdr hdr;
struct cmsgcred cred;
-@@ -445,7 +445,7 @@
+@@ -445,7 +446,7 @@ gamin_write_credential_byte(int fd)
#endif
retry:
@@ -18,7 +26,7 @@
written = sendmsg(fd, &msg, 0);
#else
written = write(fd, &data[0], 1);
-@@ -650,7 +650,7 @@
+@@ -655,7 +656,7 @@ gamin_check_cred(GAMDataPtr conn, int fd
s_uid = getuid();
diff --git a/devel/gamin/files/patch-server_gam_debug_lists.c b/devel/gamin/files/patch-server_gam_debug_lists.c
new file mode 100644
index 000000000000..ad850bd90a49
--- /dev/null
+++ b/devel/gamin/files/patch-server_gam_debug_lists.c
@@ -0,0 +1,17 @@
+--- server/gam_debug_lists.c.orig Sat Jul 16 18:53:23 2005
++++ server/gam_debug_lists.c Sat Jul 16 18:53:43 2005
+@@ -28,6 +28,8 @@
+ #include <string.h> /* for memset() debug */
+ #include "glib.h"
+
++#ifdef GAM_DEBUG_ENABLED
++
+ GList*
+ g_list_alloc (void)
+ {
+@@ -252,4 +254,4 @@ g_list_length (GList *list)
+
+ return length;
+ }
+-
++#endif /* GAM_DEBUG_ENABLED */