aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-28 22:26:15 +0800
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-28 22:26:15 +0800
commitfff485a93bf4fa9cd0fdf4a3f7830c9ccfb6114e (patch)
tree7fa61c64a2a932bbe30e63f2b259e48dfb490218 /devel
parentc6e8abf4ed78d4e6f77cffad99d7c22f179c9857 (diff)
downloadfreebsd-ports-gnome-fff485a93bf4fa9cd0fdf4a3f7830c9ccfb6114e.tar.gz
freebsd-ports-gnome-fff485a93bf4fa9cd0fdf4a3f7830c9ccfb6114e.tar.zst
freebsd-ports-gnome-fff485a93bf4fa9cd0fdf4a3f7830c9ccfb6114e.zip
Add p5-Sys-Syscall 0.21, access system calls that Perl doesn\'t provide
access to. PR: ports/103744 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sys-Syscall/Makefile22
-rw-r--r--devel/p5-Sys-Syscall/distinfo3
-rw-r--r--devel/p5-Sys-Syscall/pkg-descr4
-rw-r--r--devel/p5-Sys-Syscall/pkg-plist6
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1a5e0f93a2e4..350ecc0d0088 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1364,6 +1364,7 @@
SUBDIR += p5-Sub-Uplevel
SUBDIR += p5-Sys-Mmap
SUBDIR += p5-Sys-SigAction
+ SUBDIR += p5-Sys-Syscall
SUBDIR += p5-System2
SUBDIR += p5-Taint-Runtime
SUBDIR += p5-Term-ANSIColor
diff --git a/devel/p5-Sys-Syscall/Makefile b/devel/p5-Sys-Syscall/Makefile
new file mode 100644
index 000000000000..fc30d7b3d57a
--- /dev/null
+++ b/devel/p5-Sys-Syscall/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Sys-Syscall
+# Date created: 2006-09-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Syscall
+PORTVERSION= 0.21
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Sys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Access system calls that Perl doesn\'t provide access to
+
+PERL_CONFIGURE= yes
+
+MAN3= Sys::Syscall.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sys-Syscall/distinfo b/devel/p5-Sys-Syscall/distinfo
new file mode 100644
index 000000000000..c560660ecd2d
--- /dev/null
+++ b/devel/p5-Sys-Syscall/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sys-Syscall-0.21.tar.gz) = 712b88ab24316a0b49c12be81212fa66
+SHA256 (Sys-Syscall-0.21.tar.gz) = bedb9e4a39fa3437f754c1d7667c2ae7dd829dbe3cd0a5de07c8eacf2c424fcf
+SIZE (Sys-Syscall-0.21.tar.gz) = 6229
diff --git a/devel/p5-Sys-Syscall/pkg-descr b/devel/p5-Sys-Syscall/pkg-descr
new file mode 100644
index 000000000000..da18bbac270c
--- /dev/null
+++ b/devel/p5-Sys-Syscall/pkg-descr
@@ -0,0 +1,4 @@
+Use epoll, sendfile, from Perl. Mostly Linux-only support now, but
+more syscalls/OSes planned for future.
+
+WWW: http://search.cpan.org/dist/Sys-Syscall/
diff --git a/devel/p5-Sys-Syscall/pkg-plist b/devel/p5-Sys-Syscall/pkg-plist
new file mode 100644
index 000000000000..ce8c91042ee1
--- /dev/null
+++ b/devel/p5-Sys-Syscall/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Syscall/.packlist
+%%SITE_PERL%%/Sys/Syscall.pm
+@dirrmtry %%SITE_PERL%%/Sys
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/Syscall
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys