aboutsummaryrefslogtreecommitdiffstats
path: root/dns/autotrust
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-01-13 22:20:09 +0800
committerosa <osa@FreeBSD.org>2010-01-13 22:20:09 +0800
commitee48cc365d6c4863272b0d983a22826b97d2be96 (patch)
tree915461bf2c6d2d282370aa45bfae401bc7f6a94b /dns/autotrust
parente506a0a7ee9ac71b4e682492def10401f997104b (diff)
downloadfreebsd-ports-gnome-ee48cc365d6c4863272b0d983a22826b97d2be96.tar.gz
freebsd-ports-gnome-ee48cc365d6c4863272b0d983a22826b97d2be96.tar.zst
freebsd-ports-gnome-ee48cc365d6c4863272b0d983a22826b97d2be96.zip
Fix build by change dependences.
Fix COMMENT. Respect CC/CFLAGS. Write install target. Bump PORTREVISION. Report by: QAT@ Approved by: Jaap Akkerhuis aka jaap at NLnetLabs dot nl (maintainer) Pointy hat to: nemoliu@
Diffstat (limited to 'dns/autotrust')
-rw-r--r--dns/autotrust/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/dns/autotrust/Makefile b/dns/autotrust/Makefile
index 775dbde70c89..72345db645e1 100644
--- a/dns/autotrust/Makefile
+++ b/dns/autotrust/Makefile
@@ -7,15 +7,17 @@
PORTNAME= autotrust
PORTVERSION= 0.3.1
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://www.nlnetlabs.nl/downloads/autotrust/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= jaap@bartok.nlnetlabs.nl
-COMMENT= A a tool to automatically update DNSSEC trust anchors
+COMMENT= A tool to automatically update DNSSEC trust anchors
-BUILD_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
-BUILD_DEPENDS+= unbound:${PORTSDIR}/dns/unbound
+LIB_DEPENDS+= ldns.1:${PORTSDIR}/dns/ldns \
+ unbound.2:${PORTSDIR}/dns/unbound
+
+GNU_CONFIGURE= yes
MAN8= autotrust.8
@@ -23,6 +25,16 @@ PLIST_FILES= sbin/autotrust \
etc/autotrust/autotrust.conf.sample
PLIST_DIRS= etc/autotrust
-GNU_CONFIGURE= yes
+do-patch:
+ ${REINPLACE_CMD} \
+ '45s!=!\?=!; \
+ 46s!^\(CFLAGS \)\(= -I.\) @CFLAGS@!\1+\2!' \
+ ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+ ${MKDIR} ${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${ETCDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
.include <bsd.port.mk>