aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-08-03 21:28:04 +0800
committermat <mat@FreeBSD.org>2016-08-03 21:28:04 +0800
commit0f7f276f35952bb88d853ef1a248870ef42a0023 (patch)
tree3bb4e48f7a0fd3b39c01f12612e63cf2f9972b96 /dns/bind9-devel
parentcb18a82088042bed11e0876cd0a1af572f8e89ed (diff)
downloadfreebsd-ports-gnome-0f7f276f35952bb88d853ef1a248870ef42a0023.tar.gz
freebsd-ports-gnome-0f7f276f35952bb88d853ef1a248870ef42a0023.tar.zst
freebsd-ports-gnome-0f7f276f35952bb88d853ef1a248870ef42a0023.zip
Update to latest snapshot.
Sponsored by: Absolight
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile9
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/pkg-plist5
5 files changed, 21 insertions, 23 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 251617f034d4..4bae8fb803b3 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -16,8 +16,8 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= MPL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.0a.2016.07.25
-HASH= c854d9c
+ISCVERSION= 9.12.0a.2016.07.30
+HASH= 32b4a9a
MAKE_JOBS_UNSAFE= yes
@@ -47,14 +47,14 @@ SUB_FILES= pkg-message
OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE DLZ_FILESYSTEM
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON START_LATE \
- FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA LMDB
+ FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
OPTIONS_DEFAULT+= RRL
OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS NEWSTATS GEOIP \
- MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE
+ MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE LMDB
OPTIONS_GROUP= DLZ
OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
DLZ_LDAP DLZ_FILESYSTEM DLZ_STUB
@@ -108,7 +108,6 @@ SSL_CONFIGURE_OFF= --disable-openssl-version-check --without-openssl
LMDB_CONFIGURE_WITH= lmdb
LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
-LMDB_BROKEN_OFF= Does not install without LMDB
NEWSTATS_CONFIGURE_ENABLE= newstats
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 3755fa1aa5b7..8cb297ed51eb 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1469455518
-SHA256 (bind9-c854d9c.tar.gz) = 94ebac19753f17c9e64efa4d08916df8dea79aaa2233f741c5985c3ba306bb4a
-SIZE (bind9-c854d9c.tar.gz) = 11756529
+TIMESTAMP = 1470230492
+SHA256 (bind9-32b4a9a.tar.gz) = 62ee065529227bb823101b44a8db3b322a7479b89e33d1860424359f41bac2e9
+SIZE (bind9-32b4a9a.tar.gz) = 11763591
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 7639b30ad451..aebb23264afb 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2016-07-14 05:13:57 UTC
+--- bin/named/config.c.orig 2016-07-29 21:44:23 UTC
+++ bin/named/config.c
-@@ -151,6 +151,8 @@ options {\n\
+@@ -152,6 +152,8 @@ options {\n\
lame-ttl 600;\n\
servfail-ttl 1;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
@@ -9,9 +9,9 @@
max-cache-ttl 604800; /* 1 week */\n\
transfer-format many-answers;\n\
max-cache-size 90%;\n\
---- bin/named/server.c.orig 2016-07-14 05:13:57 UTC
+--- bin/named/server.c.orig 2016-07-29 21:44:23 UTC
+++ bin/named/server.c
-@@ -3549,6 +3549,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -3567,6 +3567,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -28,9 +28,9 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2016-07-14 05:13:57 UTC
+--- lib/dns/include/dns/view.h.orig 2016-07-29 21:44:23 UTC
+++ lib/dns/include/dns/view.h
-@@ -145,6 +145,8 @@ struct dns_view {
+@@ -146,6 +146,8 @@ struct dns_view {
isc_boolean_t requestnsid;
isc_boolean_t sendcookie;
dns_ttl_t maxcachettl;
@@ -39,7 +39,7 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2016-07-14 05:13:57 UTC
+--- lib/dns/resolver.c.orig 2016-07-29 21:44:23 UTC
+++ lib/dns/resolver.c
@@ -5431,6 +5431,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -60,7 +60,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2016-07-14 05:13:57 UTC
+--- lib/isccfg/namedconf.c.orig 2016-07-29 21:44:23 UTC
+++ lib/isccfg/namedconf.c
@@ -1707,6 +1707,8 @@ view_clauses[] = {
{ "nosit-udp-size", &cfg_type_uint32, CFG_CLAUSEFLAG_OBSOLETE },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 73f21a13a75f..a2c06ed5a592 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2016-07-25 11:18:47 UTC
+--- configure.orig 2016-07-29 21:44:23 UTC
+++ configure
-@@ -14345,27 +14345,9 @@ done
+@@ -14339,27 +14339,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14408,47 +14390,7 @@ $as_echo "no" >&6; } ;;
+@@ -14402,47 +14384,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22464,7 +22406,7 @@ $as_echo "" >&6; }
+@@ -22446,7 +22388,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 28a2d5e29746..5a0dfcccabb2 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -1,9 +1,11 @@
+bin/arpaname
bin/bind9-config
bin/delv
bin/dig
bin/host
bin/isc-config.sh
bin/mdig
+bin/named-rrchecker
bin/nslookup
bin/nsupdate
include/bind9/check.h
@@ -270,7 +272,6 @@ man/man1/arpaname.1.gz
man/man1/bind9-config.1.gz
man/man1/delv.1.gz
man/man1/dig.1.gz
-man/man1/dnstap-read.1.gz
man/man1/host.1.gz
man/man1/isc-config.sh.1.gz
man/man1/mdig.1.gz
@@ -393,7 +394,6 @@ man/man8/nsec3hash.8.gz
man/man8/rndc-confgen.8.gz
man/man8/rndc.8.gz
man/man8/tsig-keygen.8.gz
-sbin/arpaname
sbin/ddns-confgen
%%PYTHON%%sbin/dnssec-checkds
%%PYTHON%%sbin/dnssec-coverage
@@ -415,7 +415,6 @@ sbin/named-checkzone
sbin/named-compilezone
sbin/named-journalprint
%%LMDB%%sbin/named-nzd2nzf
-sbin/named-rrchecker
sbin/nsec3hash
%%NATIVE_PKCS11%%sbin/pkcs11-destroy
%%NATIVE_PKCS11%%sbin/pkcs11-keygen