aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind9/Makefile
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2005-10-29 15:13:29 +0800
committerdougb <dougb@FreeBSD.org>2005-10-29 15:13:29 +0800
commit88c5a531cb6a6005e92562b2b543a866d3024bd4 (patch)
tree9f4b172b88f694477d0b20d2473a1005ed584ce4 /dns/bind9/Makefile
parent829ba133c8622e0339248b7f0d74725e152e5bad (diff)
downloadfreebsd-ports-gnome-88c5a531cb6a6005e92562b2b543a866d3024bd4.tar.gz
freebsd-ports-gnome-88c5a531cb6a6005e92562b2b543a866d3024bd4.tar.zst
freebsd-ports-gnome-88c5a531cb6a6005e92562b2b543a866d3024bd4.zip
For the ports that I maintain, do the following as appropriate:
1. Add myself as a backup master site (Sourceforge and CPAN ports already have good enough coverage, so skip them). 2. For all ports that have them, download the PGP signature files. 3. For ports in 2, add a verify target to the Makefile 4. For ports where I was already providing a master site, update the URL. 5. Pet portlint in a couple of places.
Diffstat (limited to 'dns/bind9/Makefile')
-rw-r--r--dns/bind9/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/dns/bind9/Makefile b/dns/bind9/Makefile
index ed42babb841f..276a8d1bea48 100644
--- a/dns/bind9/Makefile
+++ b/dns/bind9/Makefile
@@ -14,7 +14,8 @@
PORTNAME= bind9
PORTVERSION= 9.3.1
CATEGORIES= dns net ipv6
-MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
@@ -91,6 +92,9 @@ MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 nsupdate.8 rndc-confgen.8 rndc.8
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
pre-fetch:
.if defined(PORT_REPLACES_BASE_BIND9)
@${ECHO} ""