aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind913
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-06-06 18:31:30 +0800
committermat <mat@FreeBSD.org>2018-06-06 18:31:30 +0800
commit5cf62d391650a73707a25ed99ff22888046b20cb (patch)
tree1218141d841f842eaec4a2cb35dd814298d76b17 /dns/bind913
parentde3fc05fd5676cd0c01e6d3d66fee95e12674d3f (diff)
downloadfreebsd-ports-gnome-5cf62d391650a73707a25ed99ff22888046b20cb.tar.gz
freebsd-ports-gnome-5cf62d391650a73707a25ed99ff22888046b20cb.tar.zst
freebsd-ports-gnome-5cf62d391650a73707a25ed99ff22888046b20cb.zip
Move things around a bit to be more handbook compliant.
Sponsored by: Absolight
Diffstat (limited to 'dns/bind913')
-rw-r--r--dns/bind913/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/dns/bind913/Makefile b/dns/bind913/Makefile
index 744fa96bda17..e64edb4376af 100644
--- a/dns/bind913/Makefile
+++ b/dns/bind913/Makefile
@@ -29,9 +29,11 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+LIB_DEPENDS= libxml2.so:textproc/libxml2
+
+USES= cpe libedit ssl
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
ISCVERSION= 9.13.0
-USES= cpe libedit ssl
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -39,8 +41,6 @@ CPE_VERSION= ${ISCVERSION:C/-.*//}
CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
.endif
-LIB_DEPENDS= libxml2.so:textproc/libxml2
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--disable-symtable \
@@ -152,15 +152,15 @@ GOST_ASN1_CONFIGURE_ON= --with-gost=asn1
GOST_CONFIGURE_ON= --with-gost
-GSSAPI_BASE_CONFIGURE_ON= \
+GSSAPI_BASE_CONFIGURE_ON=\
--with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_BASE_USES= gssapi
-GSSAPI_HEIMDAL_CONFIGURE_ON= \
+GSSAPI_HEIMDAL_CONFIGURE_ON=\
--with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_HEIMDAL_USES= gssapi:heimdal
-GSSAPI_MIT_CONFIGURE_ON= \
+GSSAPI_MIT_CONFIGURE_ON=\
--with-gssapi=${GSSAPIBASEDIR} KRB5CONFIG="${KRB5CONFIG}"
GSSAPI_MIT_USES= gssapi:mit
@@ -199,7 +199,6 @@ RPZ_NSIP_CONFIGURE_ENABLE= rpz-nsip
SIGCHASE_CONFIGURE_ON= STD_CDEFINES="-DDIG_SIGCHASE=1"
-
START_LATE_SUB_LIST= NAMED_REQUIRE="SERVERS cleanvar" \
NAMED_BEFORE="LOGIN"
START_LATE_SUB_LIST_OFF=NAMED_REQUIRE="NETWORKING ldconfig syslogd" \