aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind98/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-03-07 01:31:55 +0800
committermat <mat@FreeBSD.org>2014-03-07 01:31:55 +0800
commitd14ac5617f0d46a9c4c225894a1365295b10b87e (patch)
tree074697a1898d40bc9dddf55a8913ab3c3573d2c9 /dns/bind98/Makefile
parentca25af1f2ed41b9f010dfbd4440c0c317ee98e09 (diff)
downloadfreebsd-ports-gnome-d14ac5617f0d46a9c4c225894a1365295b10b87e.tar.gz
freebsd-ports-gnome-d14ac5617f0d46a9c4c225894a1365295b10b87e.tar.zst
freebsd-ports-gnome-d14ac5617f0d46a9c4c225894a1365295b10b87e.zip
Always depend on libxml[1]
Add XML newstats support to bind99[2] PR: 186890[1], 186791[2] Submitted by: Jason Mann[1], Matthew Seaman[2] Sponsored by: Absolight
Diffstat (limited to 'dns/bind98/Makefile')
-rw-r--r--dns/bind98/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/dns/bind98/Makefile b/dns/bind98/Makefile
index 260b9e88bd8f..8e76a5b2d665 100644
--- a/dns/bind98/Makefile
+++ b/dns/bind98/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.8.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
@@ -19,16 +19,19 @@ ISCVERSION= 9.8.7
MAKE_JOBS_UNSAFE= yes
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--disable-symtable \
+ --with-libxml2=${LOCALBASE} \
--with-randomdev=/dev/random
ETCDIR= ${PREFIX}/etc/namedb
CONFLICTS= bind9*-9.[45679].* bind9*-sdb-9.[45679].* bind-tools-9.*
-OPTIONS_DEFAULT= IPV6 SSL XML THREADS GSSAPI
-OPTIONS_DEFINE= SSL LINKS XML IDN REPLACE_BASE LARGE_FILE \
+OPTIONS_DEFAULT= IPV6 SSL THREADS GSSAPI
+OPTIONS_DEFINE= SSL LINKS IDN REPLACE_BASE LARGE_FILE \
FIXED_RRSET RPZ_NSIP RPZ_NSDNAME RPZRRL_PATCH \
SIGCHASE IPV6 THREADS GSSAPI FILTER_AAAA DOCS
OPTIONS_GROUP= DLZ
@@ -37,7 +40,6 @@ OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
SSL_DESC= Build with OpenSSL (Required for DNSSEC)
LINKS_DESC= Create conf file symlinks in ${PREFIX}
-XML_DESC= Support for xml statistics output
REPLACE_BASE_DESC= Replace base BIND (FreeBSD 9.x and earlier)
LARGE_FILE_DESC= 64-bit file support
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
@@ -58,10 +60,6 @@ SSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
SSL_USE= openssl=yes
SSL_CONFIGURE_OFF= --disable-openssl-version-check --without-openssl
-XML_CONFIGURE_ON= --with-libxml2=${LOCALBASE}
-XML_CONFIGURE_OFF= --without-libxml2
-XML_LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
-
IDN_USES= iconv
IDN_CONFIGURE_ON= --with-idn=${LOCALBASE} ${ICONV_CONFIGURE_BASE}
IDN_CONFIGURE_OFF= --without-idn