aboutsummaryrefslogtreecommitdiffstats
path: root/dns/djbdns
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2004-12-29 16:05:50 +0800
committerroam <roam@FreeBSD.org>2004-12-29 16:05:50 +0800
commitaea8f48ddb161e824cd9c8897caabc7cae76fd97 (patch)
tree74938cfe4555734f7cc60e15eca099e2c791bfb7 /dns/djbdns
parent29e8739d22dc900c2412c1164c80c992e4d17b4a (diff)
downloadfreebsd-ports-gnome-aea8f48ddb161e824cd9c8897caabc7cae76fd97.tar.gz
freebsd-ports-gnome-aea8f48ddb161e824cd9c8897caabc7cae76fd97.tar.zst
freebsd-ports-gnome-aea8f48ddb161e824cd9c8897caabc7cae76fd97.zip
Fix the parallel build when WITH_IPV6 is specified: the Makefile was
missing a couple of dependencies on the uint32.h header, so make(1) was postponing its creation. Bump PORTREVISION, since it is the same for the IPv6 and !IPv6 cases, although this particular change does not affect the !IPv6 case at all. PR: 75564 Submitted by: oHmEr <ohmer@epita.info>
Diffstat (limited to 'dns/djbdns')
-rw-r--r--dns/djbdns/Makefile3
-rw-r--r--dns/djbdns/files/uint32.patch80
2 files changed, 82 insertions, 1 deletions
diff --git a/dns/djbdns/Makefile b/dns/djbdns/Makefile
index 0a1cbb01cc6f..fff53b066d1c 100644
--- a/dns/djbdns/Makefile
+++ b/dns/djbdns/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= djbdns
PORTVERSION?= ${DJBDNS_VER}
-PORTREVISION?= 8
+PORTREVISION?= 9
CATEGORIES?= dns
MASTER_SITES= http://cr.yp.to/djbdns/ \
ftp://cr.yp.to/djbdns/
@@ -35,6 +35,7 @@ PORTVERSION= ${DJBDNS_VER}.${DJBDNS_V6_VER:S/test/b/:S/diff//}
PATCH_SITES+= http://www.fefe.de/dns/:ipv6
PATCHFILES+= ${PORTNAME}-${DJBDNS_VER}-${DJBDNS_V6_VER}.diff.bz2:ipv6
PATCH_DIST_STRIP= -p1
+EXTRA_PATCHES+= ${FILESDIR}/uint32.patch
.endif
.if defined(WITH_DNSCACHE_DUMPCACHE)
diff --git a/dns/djbdns/files/uint32.patch b/dns/djbdns/files/uint32.patch
new file mode 100644
index 000000000000..b677eb10628c
--- /dev/null
+++ b/dns/djbdns/files/uint32.patch
@@ -0,0 +1,80 @@
+--- Makefile.orig Wed Dec 29 09:37:36 2004
++++ Makefile Wed Dec 29 09:52:11 2004
+@@ -333,7 +333,7 @@
+ dns_transmit.o: \
+ compile dns_transmit.c socket.h uint16.h alloc.h error.h byte.h \
+ uint16.h dns.h stralloc.h gen_alloc.h iopause.h taia.h tai.h uint64.h \
+-taia.h
++taia.h uint32.h
+ ./compile dns_transmit.c
+
+ dns_txt.o: \
+@@ -855,15 +855,15 @@
+ rm -f trylsock.o trylsock
+
+ socket_accept.o: \
+-compile socket_accept.c byte.h socket.h uint16.h
++compile socket_accept.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_accept.c
+
+ socket_accept6.o: \
+-compile socket_accept6.c byte.h socket.h uint16.h
++compile socket_accept6.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_accept6.c
+
+ socket_bind.o: \
+-compile socket_bind.c byte.h socket.h uint16.h
++compile socket_bind.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_bind.c
+
+ socket_bind6.o: \
+@@ -871,7 +871,7 @@
+ ./compile socket_bind6.c
+
+ socket_conn.o: \
+-compile socket_conn.c byte.h socket.h uint16.h
++compile socket_conn.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_conn.c
+
+ socket_connect6.o: \
+@@ -879,11 +879,11 @@
+ ./compile socket_connect6.c
+
+ socket_listen.o: \
+-compile socket_listen.c socket.h uint16.h
++compile socket_listen.c socket.h uint16.h uint32.h
+ ./compile socket_listen.c
+
+ socket_recv.o: \
+-compile socket_recv.c byte.h socket.h uint16.h
++compile socket_recv.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_recv.c
+
+ socket_recv6.o: \
+@@ -891,7 +891,7 @@
+ ./compile socket_recv6.c
+
+ socket_send.o: \
+-compile socket_send.c byte.h socket.h uint16.h
++compile socket_send.c byte.h socket.h uint16.h uint32.h
+ ./compile socket_send.c
+
+ socket_send6.o: \
+@@ -899,7 +899,7 @@
+ ./compile socket_send6.c
+
+ socket_tcp.o: \
+-compile socket_tcp.c ndelay.h socket.h uint16.h
++compile socket_tcp.c ndelay.h socket.h uint16.h uint32.h
+ ./compile socket_tcp.c
+
+ socket_tcp6.o: \
+@@ -907,7 +907,7 @@
+ ./compile socket_tcp6.c
+
+ socket_udp.o: \
+-compile socket_udp.c ndelay.h socket.h uint16.h
++compile socket_udp.c ndelay.h socket.h uint16.h uint32.h
+ ./compile socket_udp.c
+
+ socket_udp6.o: \