aboutsummaryrefslogtreecommitdiffstats
path: root/dns/doc/Makefile
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-12-05 04:43:27 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-12-05 04:43:27 +0800
commit19917bd4cbfafef95ca1ec4d26e8520e054ede65 (patch)
treec16252150784dcca12a088438428c4e921c80acd /dns/doc/Makefile
parentad7f751dfae2d54e9d9e1c656a95a4c5410a9554 (diff)
downloadfreebsd-ports-gnome-19917bd4cbfafef95ca1ec4d26e8520e054ede65.tar.gz
freebsd-ports-gnome-19917bd4cbfafef95ca1ec4d26e8520e054ede65.tar.zst
freebsd-ports-gnome-19917bd4cbfafef95ca1ec4d26e8520e054ede65.zip
Doc is an automated tool for verifying (to an extent) that a
domain is configured and functioning correctly. It makes no attempt to validate the data inside a domain, only the structure. PR: 15256 Submitted by: MIHIRA Yoshiro <sanpei@sanpei.org>
Diffstat (limited to 'dns/doc/Makefile')
-rw-r--r--dns/doc/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/dns/doc/Makefile b/dns/doc/Makefile
new file mode 100644
index 000000000000..d94a90584d8d
--- /dev/null
+++ b/dns/doc/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: doc
+# Version required: 2.1.4
+# Date created: 28 November 1999
+# Whom: MIHIRA Yoshiro <sanpei@jp.FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= doc-2.1.4
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.his.com/pub/brad/dns/
+
+MAINTAINER= sanpei@jp.FreeBSD.org
+
+AUX_DIR= lib/doc
+AUX_FILES= doc1.awk doc3.awk doc4.awk INFO RFC.XXXX
+
+MAN8= doc.8
+
+do-build:
+ @${MV} ${WRKSRC}/doc ${WRKSRC}/doc.org
+ @${SED} -e 's|$${PREFIX}|${PREFIX}|g' -e 's|$${AUX_DIR}|${AUX_DIR}|g' ${WRKSRC}/doc.org \
+ > ${WRKSRC}/doc
+
+do-install:
+ @${MKDIR} ${PREFIX}/${AUX_DIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/doc ${PREFIX}/bin/doc
+ @for file in ${AUX_FILES}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$file ${PREFIX}/${AUX_DIR}/ ; \
+ done
+.if !defined(NOPORTDOCS)
+ @${INSTALL_DATA} ${WRKSRC}/doc.8 ${PREFIX}/man/man8/doc.8
+.endif
+
+.include <bsd.port.mk>