aboutsummaryrefslogtreecommitdiffstats
path: root/dns/knot/Makefile
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-03-15 05:41:59 +0800
committerscheidell <scheidell@FreeBSD.org>2012-03-15 05:41:59 +0800
commit6e3fbc2e679245e6cc64cc395e4fd61e10bbc219 (patch)
treeb2beca31e143a2e3f15775f01ed02ecb643ba5cc /dns/knot/Makefile
parentd8eb4cd2cd028c582c82924f3a798c0d99e45412 (diff)
downloadfreebsd-ports-gnome-6e3fbc2e679245e6cc64cc395e4fd61e10bbc219.tar.gz
freebsd-ports-gnome-6e3fbc2e679245e6cc64cc395e4fd61e10bbc219.tar.zst
freebsd-ports-gnome-6e3fbc2e679245e6cc64cc395e4fd61e10bbc219.zip
New port: dns/knot high-performance auth-only DNS server by NIC-CZ
PR: ports/165798 Submitted by: Leo Vandewoestijne <freebsd@dns-lab.com> Approved by: Leo Vandewoestijne <freebsd@dns-lab.com> (maintainer) Feature safe: yes
Diffstat (limited to 'dns/knot/Makefile')
-rw-r--r--dns/knot/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/dns/knot/Makefile b/dns/knot/Makefile
new file mode 100644
index 000000000000..14f3e99dffc0
--- /dev/null
+++ b/dns/knot/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: knot
+# Date created: 29 February 2012
+# Whom: Leo Vandewoestijne <freebsd@dns-lab.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= knot
+PORTVERSION= 1.0.1
+CATEGORIES= dns ipv6
+MASTER_SITES= http://public.nic.cz/files/knot-dns/ \
+ http://www.dns-lab.com/downloads/knot-dns/
+
+MAINTAINER= freebsd@dns-lab.com
+COMMENT= Knot DNS is a high performance authoritative-only DNS server
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
+ flex>=2.5.35_1:${PORTSDIR}/textproc/flex
+LIB_DEPENDS= urcu.1:${PORTSDIR}/sysutils/userspace-rcu
+
+CONFIGURE_ARGS= --sysconfdir=${ETCDIR}
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool
+USE_OPENSSL= yes
+
+SUB_FILES= pkg-message
+
+USE_RC_SUBR= ${PORTNAME}d
+
+MAN8= knotc.8 knotd.8
+
+PORTDOCS= AUTHORS ChangeLog CodingStyle COPYING \
+ INSTALL KNOWN_ISSUES NEWS README RELNOTES
+
+post-install:
+ @${MKDIR} ${ETCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/samples/knot.min.conf ${ETCDIR}
+ @if [ ! -f ${ETCDIR}/knot.conf ]; then \
+ ${INSTALL_DATA} ${ETCDIR}/knot.min.conf ${ETCDIR}/knot.conf; \
+ fi
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>