aboutsummaryrefslogtreecommitdiffstats
path: root/dns/mydns-ng/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-02-12 06:35:34 +0800
committerale <ale@FreeBSD.org>2004-02-12 06:35:34 +0800
commit3b57f58bc05ada6ba13a170b5547fd0cdb157000 (patch)
tree7ea896c89749be2bf08f624dc47702067fac6afe /dns/mydns-ng/Makefile
parente9263891c991cb9675a3dfd81954a2c87683e3f7 (diff)
downloadfreebsd-ports-gnome-3b57f58bc05ada6ba13a170b5547fd0cdb157000.tar.gz
freebsd-ports-gnome-3b57f58bc05ada6ba13a170b5547fd0cdb157000.tar.zst
freebsd-ports-gnome-3b57f58bc05ada6ba13a170b5547fd0cdb157000.zip
Update to 0.10.2 release.
Submitted by: Liam J. Foy <liamfoy@sepulcrum.org> Approved by: nork (mentor/implicitly)
Diffstat (limited to 'dns/mydns-ng/Makefile')
-rw-r--r--dns/mydns-ng/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index d367cc9eee53..f368d8af8420 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -6,18 +6,16 @@
#
PORTNAME= mydns
-PORTVERSION= 0.10.1
-PORTREVISION= 1
+PORTVERSION= 0.10.2
CATEGORIES= dns databases
MASTER_SITES= http://mydns.bboy.net/download/
MAINTAINER= ale@FreeBSD.org
COMMENT= DNS server designed to utilize the MySQL database
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
+USE_ICONV= yes
USE_GETTEXT= yes
USE_LIBTOOL= yes
USE_BZIP2= yes
@@ -28,16 +26,18 @@ MAN8= mydns.8 mydnscheck.8 mydnsexport.8 mydnsimport.8 mydns-conf.8
DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART.mysql QUICKSTART.postgres README TODO
-.if defined (WITH_ALIAS)
+.if defined(WITH_ALIAS)
CONFIGURE_ARGS+=--enable-alias
.endif
-.if defined (WITH_OPENSSL)
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-openssl
.endif
-.if defined (WITH_PGSQL)
-LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql-client
+.if defined(WITH_PGSQL)
+POSTGRESQL_PORT?= databases/postgresql-client
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+=--without-mysql
PKGNAMESUFFIX= -pg
.else
@@ -65,6 +65,7 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
.endfor
@${INSTALL_DATA} ${WRKSRC}/contrib/*.php ${DOCSDIR}/contrib/
+ @${INSTALL_DATA} ${WRKSRC}/contrib/*.pm ${DOCSDIR}/contrib/
@${INSTALL_DATA} ${WRKSRC}/contrib/README ${DOCSDIR}/contrib/
.endif
@${PREFIX}/sbin/mydns --dump-config >${PREFIX}/etc/mydns.conf.sample