aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-Net-DNS-ZoneFile-Fast
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2004-10-15 03:16:28 +0800
committertobez <tobez@FreeBSD.org>2004-10-15 03:16:28 +0800
commit25f78ee1f519ddb15d411aa211a27ad35737399c (patch)
tree9af305abb7e4599a0f3c26914710f71ebccf8793 /dns/p5-Net-DNS-ZoneFile-Fast
parente7faae76af9fa62d5987d34186872f12ea5974e1 (diff)
downloadfreebsd-ports-gnome-25f78ee1f519ddb15d411aa211a27ad35737399c.tar.gz
freebsd-ports-gnome-25f78ee1f519ddb15d411aa211a27ad35737399c.tar.zst
freebsd-ports-gnome-25f78ee1f519ddb15d411aa211a27ad35737399c.zip
Add p5-Net-DNS-ZoneFile-Fast, a perl module to parse BIND8/9 zone files.
Diffstat (limited to 'dns/p5-Net-DNS-ZoneFile-Fast')
-rw-r--r--dns/p5-Net-DNS-ZoneFile-Fast/Makefile25
-rw-r--r--dns/p5-Net-DNS-ZoneFile-Fast/distinfo2
-rw-r--r--dns/p5-Net-DNS-ZoneFile-Fast/pkg-descr7
-rw-r--r--dns/p5-Net-DNS-ZoneFile-Fast/pkg-plist9
4 files changed, 43 insertions, 0 deletions
diff --git a/dns/p5-Net-DNS-ZoneFile-Fast/Makefile b/dns/p5-Net-DNS-ZoneFile-Fast/Makefile
new file mode 100644
index 000000000000..382b52decfef
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile-Fast/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: dns/p5-Net-DNS-ZoneFile-Fast
+# Date created: 14 October 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DNS-ZoneFile-Fast
+PORTVERSION= 0.5
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl module to parse BIND8/9 zone files
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::DNS::ZoneFile::Fast.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-DNS-ZoneFile-Fast/distinfo b/dns/p5-Net-DNS-ZoneFile-Fast/distinfo
new file mode 100644
index 000000000000..201935a4c1dd
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile-Fast/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-DNS-ZoneFile-Fast-0.5.tar.gz) = bf5071c30f2605e60bd5c519aa27920f
+SIZE (Net-DNS-ZoneFile-Fast-0.5.tar.gz) = 11423
diff --git a/dns/p5-Net-DNS-ZoneFile-Fast/pkg-descr b/dns/p5-Net-DNS-ZoneFile-Fast/pkg-descr
new file mode 100644
index 000000000000..713f5dce2468
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile-Fast/pkg-descr
@@ -0,0 +1,7 @@
+The Net::DNS::ZoneFile::Fast module provides an ability to parse zone
+files that BIND8 and BIND9 use, fast. Currently it provides a single
+function, parse(), which returns a reference to an array of traditional
+Net::DNS::RR objects, so that no new API has to be learned in order to
+manipulate zone records.
+
+WWW: http://search.cpan.org/dist/Net-DNS-ZoneFile-Fast
diff --git a/dns/p5-Net-DNS-ZoneFile-Fast/pkg-plist b/dns/p5-Net-DNS-ZoneFile-Fast/pkg-plist
new file mode 100644
index 000000000000..8b098ce18c54
--- /dev/null
+++ b/dns/p5-Net-DNS-ZoneFile-Fast/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Net/DNS/ZoneFile/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/ZoneFile/Fast/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/ZoneFile/Fast
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/ZoneFile 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/DNS/ZoneFile
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net/DNS 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true