aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-Net-DNS/Makefile
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-02-15 17:44:39 +0800
committerdougb <dougb@FreeBSD.org>2012-02-15 17:44:39 +0800
commitb8b38b19c81c2de69d41ba0a7d4ce3da53fa16ca (patch)
tree20edd669942694e5a984dd37b048252919f592cf /dns/p5-Net-DNS/Makefile
parent82a5fb47671f6feaf4acbb9c44790465e1d160f0 (diff)
downloadfreebsd-ports-gnome-b8b38b19c81c2de69d41ba0a7d4ce3da53fa16ca.tar.gz
freebsd-ports-gnome-b8b38b19c81c2de69d41ba0a7d4ce3da53fa16ca.tar.zst
freebsd-ports-gnome-b8b38b19c81c2de69d41ba0a7d4ce3da53fa16ca.zip
Update to version 0.68; Jan 30, 2012
Lots of fixes for older Perl versions, and several other bug fixes The parse and data methods are renamed to decode and encode respectively New feature: IDN query support, requires Net::LibIDN New modules: Mailbox.pm, Text.pm For the port: * Add TEST_DEPENDS (probably won't work on its own due to CONFIGURE_ARGS) * Add an OPTION for IDN support, off by default * Use the PORTDOCS macro * Move the OPTIONS= to the more standard location
Diffstat (limited to 'dns/p5-Net-DNS/Makefile')
-rw-r--r--dns/p5-Net-DNS/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/dns/p5-Net-DNS/Makefile b/dns/p5-Net-DNS/Makefile
index 4d5081c9702b..7f597bc0bbdb 100644
--- a/dns/p5-Net-DNS/Makefile
+++ b/dns/p5-Net-DNS/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: p5-Net-DNS
# Date created: April 5th 1997
-# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= Net-DNS
-PORTVERSION= 0.67
+PORTVERSION= 0.68
CATEGORIES= dns net perl5 ipv6
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,8 +17,14 @@ COMMENT= Perl5 interface to the DNS resolver, and dynamic updates
# Warnings during build are harmless, the port does not need these to build
RUN_DEPENDS= ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC
+TEST_DEPENDS= ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
+ ${SITE_PERL}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble
+
MAKE_JOBS_SAFE= yes
+OPTIONS= IPV6 "Enable functionality over IPv6 transport" on \
+ IDN "Add support for IDN domain names" off
+
PERL_CONFIGURE= yes
CONFIGURE_ARGS+= --no-online-tests --no-IPv6-tests
@@ -43,11 +49,11 @@ MAN3= Net::DNS.3 Net::DNS::Header.3 Net::DNS::Packet.3 \
Net::DNS::RR::Unknown.3 Net::DNS::Resolver::Recurse.3 \
Net::DNS::RR::APL.3 Net::DNS::RR::APL::ApItem.3 \
Net::DNS::RR::DHCID.3 Net::DNS::Domain.3 \
- Net::DNS::DomainName.3 \
+ Net::DNS::DomainName.3 Net::DNS::Text.3 Net::DNS::Mailbox.3 \
Net::DNS::RR::KX.3 Net::DNS::RR::HIP.3 \
Net::DNS::Resolver::Cygwin.3 Net::DNS::RR::SPF.3
-OPTIONS= IPV6 "Enable functionality over IPv6 transport" on
+PORTDOCS= *
.include <bsd.port.pre.mk>
@@ -59,6 +65,10 @@ RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-Socket-INET6
.endif
+.if defined(WITH_IDN)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/LibIDN.pm:${PORTSDIR}/dns/p5-Net-LibIDN
+.endif
+
DOCSDIR= ${PREFIX}/share/doc/p5-Net-DNS
DOCS= Changes README TODO