aboutsummaryrefslogtreecommitdiffstats
path: root/dns/p5-Net-DNS
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2002-11-11 17:54:18 +0800
committerdougb <dougb@FreeBSD.org>2002-11-11 17:54:18 +0800
commitf29b1e2bff5e487b4935d49660795193705cf93a (patch)
treed446b1ecf92d1f84dbb3534bcf22fd8670e48625 /dns/p5-Net-DNS
parentea070a2815fb4b84700a04c6eebd1129cc70f34e (diff)
downloadfreebsd-ports-gnome-f29b1e2bff5e487b4935d49660795193705cf93a.tar.gz
freebsd-ports-gnome-f29b1e2bff5e487b4935d49660795193705cf93a.tar.zst
freebsd-ports-gnome-f29b1e2bff5e487b4935d49660795193705cf93a.zip
Update to 0.30, which has TKEY support, a new safe_push() method
for detecting duplicate RR's in an update packet, and some more tests. Note, the tests are not installed by the port, but are useful to examine as samples, and to test your installation. * Update the port to handle the new TKEY and FAQ files. * Patch the new FAQ, since pod2man is choking on the CVS Id. * Update the comment by mentioning dynamic updates. * Add a comment to the Makefile about the harmless build errors you see if you don't have the run-time depends already installed.
Diffstat (limited to 'dns/p5-Net-DNS')
-rw-r--r--dns/p5-Net-DNS/Makefile15
-rw-r--r--dns/p5-Net-DNS/distinfo2
-rw-r--r--dns/p5-Net-DNS/pkg-comment2
-rw-r--r--dns/p5-Net-DNS/pkg-plist2
4 files changed, 16 insertions, 5 deletions
diff --git a/dns/p5-Net-DNS/Makefile b/dns/p5-Net-DNS/Makefile
index 79afa6038d14..39e7cbe00269 100644
--- a/dns/p5-Net-DNS/Makefile
+++ b/dns/p5-Net-DNS/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Net-DNS
-PORTVERSION= 0.29
+PORTVERSION= 0.30
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
@@ -14,6 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= DougB@FreeBSD.org
+# Warnings during build are harmless, the port does not need these to build
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
@@ -34,13 +35,21 @@ MAN3= Net::DNS.3 Net::DNS::Header.3 Net::DNS::Packet.3 \
Net::DNS::RR::NIMLOC.3 Net::DNS::RR::NSAP.3 \
Net::DNS::RR::NULL.3 Net::DNS::RR::PX.3 Net::DNS::Update.3 \
Net::DNS::Nameserver.3 Net::DNS::RR::CERT.3 \
+ Net::DNS::FAQ.3 Net::DNS::RR::TKEY.3 \
Net::DNS::RR::OPT.3 Net::DNS::RR::TSIG.3 Net::DNS::RR::DNAME.3
+post-patch:
+ ${CP} ${WRKSRC}/lib/Net/DNS/FAQ.pod ${WRKSRC}/lib/Net/DNS/FAQ.pod.Dist
+ ${SED} -e '1d' ${WRKSRC}/lib/Net/DNS/FAQ.pod.Dist > \
+ ${WRKSRC}/lib/Net/DNS/FAQ.pod
+ ${RM} ${WRKSRC}/lib/Net/DNS/FAQ.pod.Dist
+
+DOCSDIR= ${PREFIX}/share/doc/p5-Net-DNS
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/p5-Net-DNS
+ @${MKDIR} ${DOCSDIR}
.for file in Changes README TODO
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/p5-Net-DNS
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/dns/p5-Net-DNS/distinfo b/dns/p5-Net-DNS/distinfo
index 9e317e20b165..a8c5bbf4aebb 100644
--- a/dns/p5-Net-DNS/distinfo
+++ b/dns/p5-Net-DNS/distinfo
@@ -1 +1 @@
-MD5 (Net-DNS-0.29.tar.gz) = 14f3ee438ca7120dfa7789127c2c3732
+MD5 (Net-DNS-0.30.tar.gz) = b45480dd38349e195e4316f03496d3b0
diff --git a/dns/p5-Net-DNS/pkg-comment b/dns/p5-Net-DNS/pkg-comment
index fb0e93803963..f26aa35b1375 100644
--- a/dns/p5-Net-DNS/pkg-comment
+++ b/dns/p5-Net-DNS/pkg-comment
@@ -1 +1 @@
-Perl5 interface to the DNS resolver
+Perl5 interface to the DNS resolver, and dymanic updates
diff --git a/dns/p5-Net-DNS/pkg-plist b/dns/p5-Net-DNS/pkg-plist
index 1437fa22914a..1bd43bca1b4b 100644
--- a/dns/p5-Net-DNS/pkg-plist
+++ b/dns/p5-Net-DNS/pkg-plist
@@ -1,4 +1,5 @@
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/FAQ.pod
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Header.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Nameserver.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/Packet.pm
@@ -31,6 +32,7 @@ lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/RP.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/RT.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/SOA.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/SRV.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/TKEY.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/TSIG.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/TXT.pm
lib/perl5/site_perl/%%PERL_VER%%/Net/DNS/RR/X25.pm