aboutsummaryrefslogtreecommitdiffstats
path: root/dns/pdnsd
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2014-01-20 07:39:17 +0800
committerAshish SHUKLA <ashish@FreeBSD.org>2014-01-20 07:39:17 +0800
commit6c109c60a04e14f6426861b4e1062576b5635a3b (patch)
treeaff684c09ac340945c90de620dc5be5c7cb136c6 /dns/pdnsd
parent7a4a6c7b2f4e614161f3d506e936f2ef7c518829 (diff)
downloadfreebsd-ports-gnome-6c109c60a04e14f6426861b4e1062576b5635a3b.tar.gz
freebsd-ports-gnome-6c109c60a04e14f6426861b4e1062576b5635a3b.tar.zst
freebsd-ports-gnome-6c109c60a04e14f6426861b4e1062576b5635a3b.zip
- Add STAGE support
- Fix issue during installation[1] - Remove incorrect pkg-message Submitted by: Серж ИвановЪ <evasive.gyron at gmail.com> (via private mail)
Diffstat (limited to 'dns/pdnsd')
-rw-r--r--dns/pdnsd/Makefile17
-rw-r--r--dns/pdnsd/pkg-install2
-rw-r--r--dns/pdnsd/pkg-message3
-rw-r--r--dns/pdnsd/pkg-plist3
4 files changed, 8 insertions, 17 deletions
diff --git a/dns/pdnsd/Makefile b/dns/pdnsd/Makefile
index 1099352ac7c2..3fcdb725e7bb 100644
--- a/dns/pdnsd/Makefile
+++ b/dns/pdnsd/Makefile
@@ -24,9 +24,6 @@ OPTIONS_DEFINE= IPV6 DOCS
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-MAN5= pdnsd.conf.5
-MAN8= pdnsd.8 pdnsd-ctl.8
-
PDNSDB= /var/db/pdnsd
DOCSRCDIR= ${WRKSRC}/doc
DOC_FILES= html/dl.html html/doc.html html/faq.html html/index.html
@@ -34,20 +31,14 @@ DOC_FILES+= txt/faq.txt txt/intro.txt txt/manual.txt
CFLAGS+= -pthread
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+IPV6_CONFIGURE_ENABLE= ipv6
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
+.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DOC_FILES:S@^@${DOCSRCDIR}/@} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${DOC_FILES:S@^@${DOCSRCDIR}/@} ${STAGEDIR}${DOCSDIR}
.endif
- @[ -f ${PREFIX}/etc/pdnsd.conf ] || \
- ${INSTALL_DATA} ${PREFIX}/etc/pdnsd.conf.sample ${PREFIX}/etc/pdnsd.conf
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/dns/pdnsd/pkg-install b/dns/pdnsd/pkg-install
index 9c5a371fc852..5dd75a02d92d 100644
--- a/dns/pdnsd/pkg-install
+++ b/dns/pdnsd/pkg-install
@@ -4,6 +4,6 @@ PDNSDB=/var/db/pdnsd
mkdir -p ${PDNSDB}
chown nobody ${PDNSDB}
chmod 755 ${PDNSDB}
-truncate -s 4 ${PDNSDB}
+touch ${PDNSDB}/pdnsd.cache
chown nobody ${PDNSDB}/pdnsd.cache
chmod 640 ${PDNSDB}/pdnsd.cache
diff --git a/dns/pdnsd/pkg-message b/dns/pdnsd/pkg-message
deleted file mode 100644
index 9d33034b2f91..000000000000
--- a/dns/pdnsd/pkg-message
+++ /dev/null
@@ -1,3 +0,0 @@
-
-You'll need to manually copy ${PREFIX}/etc/pdnsd.conf.sample to
-${PREFIX}/etc/pdnsd.conf and modify it for your needs.
diff --git a/dns/pdnsd/pkg-plist b/dns/pdnsd/pkg-plist
index 512b980e7f46..6a13ce7f57e7 100644
--- a/dns/pdnsd/pkg-plist
+++ b/dns/pdnsd/pkg-plist
@@ -1,6 +1,9 @@
@unexec if cmp -s %D/etc/pdnsd.conf %D/etc/pdnsd.conf.sample; then rm %D/etc/pdnsd.conf; fi
etc/pdnsd.conf.sample
@exec [ -f %D/etc/pdnsd.conf ] || install -m 644 %D/etc/pdnsd.conf.sample %D/etc/pdnsd.conf
+man/man5/pdnsd.conf.5.gz
+man/man8/pdnsd-ctl.8.gz
+man/man8/pdnsd.8.gz
sbin/pdnsd
sbin/pdnsd-ctl
%%PORTDOCS%%%%DOCSDIR%%/dl.html