aboutsummaryrefslogtreecommitdiffstats
path: root/dns/sshfp
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-10-05 20:50:47 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-10-05 20:50:47 +0800
commit60cb9e6b5e663704f0d6e67ae0cb6c2f29012798 (patch)
tree6b351e9a045cf741b3ad6ab2b9dc896281684239 /dns/sshfp
parent435f44e87956536a60f2e4ed0beb580ff42096eb (diff)
downloadfreebsd-ports-gnome-60cb9e6b5e663704f0d6e67ae0cb6c2f29012798.tar.gz
freebsd-ports-gnome-60cb9e6b5e663704f0d6e67ae0cb6c2f29012798.tar.zst
freebsd-ports-gnome-60cb9e6b5e663704f0d6e67ae0cb6c2f29012798.zip
Add sshfp, generate SSHFP DNS records from knownhosts files or ssh-keyscan
Diffstat (limited to 'dns/sshfp')
-rw-r--r--dns/sshfp/Makefile33
-rw-r--r--dns/sshfp/distinfo3
-rw-r--r--dns/sshfp/pkg-descr6
3 files changed, 42 insertions, 0 deletions
diff --git a/dns/sshfp/Makefile b/dns/sshfp/Makefile
new file mode 100644
index 000000000000..2c2c00111b7c
--- /dev/null
+++ b/dns/sshfp/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sshfp
+# Date created: 5 Oct 2006
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sshfp
+PORTVERSION= 1.1.1
+CATEGORIES= dns security
+MASTER_SITES= ftp://ftp.xelerance.com/sshfp/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Generate SSHFP DNS records from knownhosts files or ssh-keyscan
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython
+
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+
+MAN1= sshfp.1
+PLIST_FILES= bin/sshfp
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PYTHON_CMD}|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/dns/sshfp/distinfo b/dns/sshfp/distinfo
new file mode 100644
index 000000000000..008417cc9a55
--- /dev/null
+++ b/dns/sshfp/distinfo
@@ -0,0 +1,3 @@
+MD5 (sshfp-1.1.1.tar.gz) = 5424ed55c50d2038934940737680e8da
+SHA256 (sshfp-1.1.1.tar.gz) = 43bbc40ed5e868181f2660cc1fa2640bac5771821198acf69a8dee3c7713ab61
+SIZE (sshfp-1.1.1.tar.gz) = 14049
diff --git a/dns/sshfp/pkg-descr b/dns/sshfp/pkg-descr
new file mode 100644
index 000000000000..d4c85175f4ef
--- /dev/null
+++ b/dns/sshfp/pkg-descr
@@ -0,0 +1,6 @@
+sshfp generates DNS SSHFP records from SSH public keys. sshfp can take public
+keys from a knownhosts file or from scanning the host's sshd daemon. The ssh
+client can use these SSHFP records if you set "VerifyHostKeyDNS yes" in the file
+/etc/ssh/ssh_config.
+
+WWW: http://freshmeat.net/projects/sshfp/