aboutsummaryrefslogtreecommitdiffstats
path: root/dns/walker/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 13:35:23 +0800
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 13:35:23 +0800
commitcd67e41e0d51df2ca5a44fa0191da87ce844e336 (patch)
treef84caf72256901b87de75bc269e8d3ee8aaf46a7 /dns/walker/Makefile
parent040530344471cd4c838364eed7c8e97ac9ff6af5 (diff)
downloadfreebsd-ports-gnome-cd67e41e0d51df2ca5a44fa0191da87ce844e336.tar.gz
freebsd-ports-gnome-cd67e41e0d51df2ca5a44fa0191da87ce844e336.tar.zst
freebsd-ports-gnome-cd67e41e0d51df2ca5a44fa0191da87ce844e336.zip
[non maintainer update] dns/walker to 3.2
Update to 1.2.3. This replaces my previous PR number 60784. PR: ports/60832 Submitted by: Vincent Tantardini <vinc@FreeBSD-fr.org>
Diffstat (limited to 'dns/walker/Makefile')
-rw-r--r--dns/walker/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/dns/walker/Makefile b/dns/walker/Makefile
index f644771dcfc9..57465cb21c6f 100644
--- a/dns/walker/Makefile
+++ b/dns/walker/Makefile
@@ -7,28 +7,26 @@
#
PORTNAME= walker
-PORTVERSION= 1.0
+PORTVERSION= 3.2
CATEGORIES= dns
MASTER_SITES= http://josefsson.org/walker/
MAINTAINER= ports@FreeBSD.org
COMMENT= Recover zone file information from servers that use DNSSEC
-RUN_DEPENDS= ${LOCALBASE}/bin/dig:${PORTSDIR}/dns/bind9
+RUN_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+ ${SITE_PERL}/Net/DNS/SEC.pm:${PORTSDIR}/dns/p5-Net-DNS-SEC
-USE_REINPLACE= yes
NO_BUILD= yes
-CONFLICTS= dnssecwalker-2.*
-
-post-patch:
- @${REINPLACE_CMD} -e 's,`dig,`${LOCALBASE}/bin/dig,g' ${WRKSRC}/walker
+MAN1= walker.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/walker ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/walker ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/walker
- ${INSTALL_DATA} ${WRKSRC}/walker.html ${PREFIX}/share/doc/walker
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
.endif
.include <bsd.port.mk>