aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-07-15 21:37:58 +0800
committermat <mat@FreeBSD.org>2004-07-15 21:37:58 +0800
commit2961123ec3befcfae7a140ea9ec06f2ce4941c73 (patch)
treec318674c98bc746d569aeefd2f97b8db6d26c34f /dns
parentb1c42b1b48c4ea3b59b9741526b0a42594c31ccf (diff)
downloadfreebsd-ports-gnome-2961123ec3befcfae7a140ea9ec06f2ce4941c73.tar.gz
freebsd-ports-gnome-2961123ec3befcfae7a140ea9ec06f2ce4941c73.tar.zst
freebsd-ports-gnome-2961123ec3befcfae7a140ea9ec06f2ce4941c73.zip
Add p5-DNS-ZoneParse 0.91, parse and manipulate DNS Zone Files.
Diffstat (limited to 'dns')
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-DNS-ZoneParse/Makefile29
-rw-r--r--dns/p5-DNS-ZoneParse/distinfo2
-rw-r--r--dns/p5-DNS-ZoneParse/pkg-descr12
-rw-r--r--dns/p5-DNS-ZoneParse/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index d2842833ba49..67f5215f204a 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -51,6 +51,7 @@
SUBDIR += p5-BIND-Conf_Parser
SUBDIR += p5-DNS-Config
SUBDIR += p5-DNS-Zone
+ SUBDIR += p5-DNS-ZoneParse
SUBDIR += p5-Net-DNS
SUBDIR += p5-Net-DNS-SEC
SUBDIR += p5-Net-DNS-ZoneFile
diff --git a/dns/p5-DNS-ZoneParse/Makefile b/dns/p5-DNS-ZoneParse/Makefile
new file mode 100644
index 000000000000..0d3a15e22001
--- /dev/null
+++ b/dns/p5-DNS-ZoneParse/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-DNS-ZoneParse
+# Date created: 15 July 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= DNS-ZoneParse
+PORTVERSION= 0.91
+CATEGORIES= dns textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DNS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Parse and manipulate DNS Zone Files
+
+PERL_CONFIGURE= yes
+
+MAN3= DNS::ZoneParse.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/dns/p5-DNS-ZoneParse/distinfo b/dns/p5-DNS-ZoneParse/distinfo
new file mode 100644
index 000000000000..f6b01d86ba1d
--- /dev/null
+++ b/dns/p5-DNS-ZoneParse/distinfo
@@ -0,0 +1,2 @@
+MD5 (DNS-ZoneParse-0.91.tar.gz) = b487c33bb5708c0346533afe9b0e9bda
+SIZE (DNS-ZoneParse-0.91.tar.gz) = 8376
diff --git a/dns/p5-DNS-ZoneParse/pkg-descr b/dns/p5-DNS-ZoneParse/pkg-descr
new file mode 100644
index 000000000000..ca95bfb3c1cd
--- /dev/null
+++ b/dns/p5-DNS-ZoneParse/pkg-descr
@@ -0,0 +1,12 @@
+This module will parse a Zone File and put all the Resource Records (RRs) into
+an anonymous hash structure. At the moment, the following types of RRs are
+supported: SOA, NS, MX, A, CNAME, TXT, PTR. It could be useful for maintaining
+DNS zones, or for transferring DNS zones to other servers. If you want to
+generate an XML-friendly version of your zone files, it is easy to use
+XML::Simple with this module once you have parsed the zonefile.
+
+DNS::ZoneParse scans the DNS zonefile - removes comments and seperates the file
+into it's constituent records. It then parses each record and stores the
+records internally. See below for information on the accessor methods.
+
+WWW: http://search.cpan.org/dist/DNS-ZoneParse/
diff --git a/dns/p5-DNS-ZoneParse/pkg-plist b/dns/p5-DNS-ZoneParse/pkg-plist
new file mode 100644
index 000000000000..4c136ba02d44
--- /dev/null
+++ b/dns/p5-DNS-ZoneParse/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/DNS/ZoneParse.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS/ZoneParse/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS/ZoneParse
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DNS 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DNS 2>/dev/null || true